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Chapter 1: Setting Word Up



Can I set up Word 95 for multiple users on the same machine?



What are the Word startup switches?

Problem

How can I set up Word 95 for multiple users on the same machine?

Perhaps you work with Word on a single workstation shared by several people. The people on your workstation would like their personal information, such as their names, initials, and correct return addresses, available to them as default options when they work with Word. How do you set Word up so that several people can share it on a single machine but still personalize this information?

Solution


1.
First, create a macro that sets personal information for each user. The macro should take the following form:

Sub MAIN

ToolsOptionsUserInfo.Name = "User Smith",.Initials _= "US",.Address = "User Smith" + Chr$(13) + "555 _User Street" + Chr$(13) + "Userplace, USA 00000-_0000"

End Sub



Each user requires a macro with a unique name.


2.
Attach each macro to a button that you add to one of the toolbars. (Alternately, you could create a custom toolbar to contain the user macros.) Or add a menu that contains items to invoke each macro.


3.
If the toolbar is visible, open the Tools menu and select the Customize option. Click on the Toolbars tab if it is not already selected. Alternately, you can open the View menu, select the Toolbars option, select the toolbar in the Toolbars list box in the Toolbars dialog box, and click on the Customize button. Either procedure opens the Customize dialog box and displays the Toolbars tab.


4.
In the Customize dialog box, select the macro Categories list box.


5.
Select the macro in the list box that replaces the Buttons group. Drag the item from the list box and drop it on your toolbar. A generic button appears on the toolbar and the Custom Button dialog box appears.


6.
In the Custom Button dialog box, select an existing button or click on the Edit button. If you select an existing button, click on the Assign button and proceed to step 10. If you click on the Edit button, the Button Editor dialog box appears.


7.
In the Button Editor dialog box, select a color (including Erase) from the palette presented in the Colors group. Click on any square in the Picture grid to fill that square with the selected color.


8.
Click on the arrow buttons in the Move group to move your image one square in the direction of the arrow on the Picture grid.


9.
Once you have created the button image, click on OK. (If you need to start over, click on the Clear button.) Word adds the button you have created to the toolbar.


10.
When you are finished creating custom buttons, click on Close in the Customize dialog box.


11.
Instruct users to begin their work in Word by clicking on the button or menu item with their name on it. If they do so, their personal information will always be correctly set.

If you want to force users to remember to change their personal information, create a dialog box by means of WordBasic (see Chapter 12 for instructions about creating dialog boxes) that contains one button for each user. Add the macro that displays the dialog box and that processes the button clicks to the AutoNew and AutoOpen macros in the templates your users employ to do their work. Each time the users create a new document or open an existing document, they are prompted to set their information.
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Problem

What are the Word startup switches?

Word enables you to use startup switches on the command line to control what Word does when it loads. What are these switches, what do they do, and how do I use them from within the Windows 95 graphical environment? 

Solution



/a Starts Word without loading any add-in or global template, including the Normal template. Also prevents the Word 95 registry entries from being read or edited.



/l filename.wll starts Word and adds a Word link library (WLL) add-in. For example: winword /l doodle.wll.



/m Prevents an autoexec macro from running at startup. If you wish to run a different macro, add that macro name to the switch, as in this example: winword /mHelpQuickPreview. Note that the macro name immediately follows the switch, with no spaces.



/n Starts Word without opening a document. For example: winword /n.



/t templatename Opens Word and displays a new file based on the template you specify.



/w Starts Word without showing the Tip of the Day.

If you are running Word 95 under Windows 95 (rather than Windows NT), you will need to learn a new method of loading Word with a switch: 


1.
Select the icon representing a shortcut to Word. The Setup program normally creates one and places it in the Winword or Office95 folder.  


2.
Open the Properties tabbed dialog box by right-clicking on the icon and selecting Properties. 


3.
Choose the Shortcut tab. 


4.
In the Target box, add the switch you want to use to load Word from this shortcut icon. 

If you wish, you can create multiple shortcut icons for Word, each loading with a different switch. 

If you happen to be running Word 95 under Windows NT, you can tell Windows NT to load Word with a switch the same way you would have done it in Windows 3.x: 


1.
Select the Microsoft Word program icon and choose Properties from the File menu. 


2.
In the Command Line box, add the switch to the command line already there. 

3. Choose OK. 
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Chapter 2: Using Word To Perform Advanced Tasks

Word provides an exceptional number of features and the power to create complex documents of different types. Its features and power are, however, sometimes a liability. Even with the help of menus and dialog boxes, you sometimes might have trouble remembering how to make Word do what you want it to do. This chapter provides solutions, many not covered in the manuals, for the following questions about performing advanced tasks:



How do I use field codes?



How do I make a table of contents?



Can I use field codes to create a table of contents?



How do I make an index?



How do I create index page ranges?



How do I create index cross-references?



How do I automate the creation of index entries?



How do I do mail merge?



What kinds of advanced projects can I undertake with mail merge?



How do I create a form?



Can I draw a picture in my document?



How do I protect Word documents in a secure environment?



How do I create annotations?



How do I use revision marks?



How do I compare two documents?



How do I merge revisions into a document?



Can I prevent a reviewer from making unauthorized changes in a document?



How do I sort text?

Problem

How do I use field codes?

A field is a set of codes that directs Word to perform specific tasks. Fields enable you to automate Word to perform new tasks, and to keep performing those tasks as your document changes, updating your document when necessary. Suppose you want to enter today's date on a document, and you want the date to be updated each time you open the document. You can enter a date field that has the code to perform the action. The first time the field executes, the code checks the system date and displays it. Each time you open the document thereafter, the field executes. On each subsequent execution, the field retrieves the system date, compares it to the date already displayed, and displays the later of the two dates.

Word provides a number of fields to perform common tasks, including six different date and time fields and autosequence fields for automatically numbering lists. Fields can calculate formulae and automatically insert your return address.

Solution


1.
Position the insertion point where you want the field to appear.


2.
Open the Insert menu and select the Field item.


3.
In the Field dialog box, select the type of field you want to use in the Categories list box. Select the specific field you want in the Field Names list box. The actual code for the field appears in the Field Code text box and a description of what it does appears in the Description list box.


4.
Check the Preserve Formatting During Updates check box when you want the format of the field preserved when data is added to it. Clear this check box if you want the formatting to change to match that of the data inserted.


5.
Click on the Options button to open the Field Options dialog box. The Options button will not be active if there are no options to set for the field.


6.
In the list box inside the Field Options dialog box, select the options you want to use. These options are different for each field. An explanation of the selected option appears in the Description box. To add an option to the field code, click on the Add to Field button. To remove an option from the field code, click on the Undo Add button.


7.
When you are finished adding options, click on OK in the Field Options dialog box. Then click on OK in the Field dialog box. Word inserts the field at the insertion point.


8.
Word can show either the result of the field code or the field code itself in your document. Normally, Word shows the result. If you enter a date field, you see the date. To switch between the two views, click on the field and then press the right mouse button. On the menu that appears, select Toggle Field Codes. You can also click on the field and press Shift+F9.


9.
Word can also break the link between the code and the result of the field. When you select this operation, Word replaces the field with text that represents the field's last value. Unlinking a date field means that Word retrieves the last date displayed, deletes the field, and replaces it with the text representing the date. The field never changes again, because its result has been permanently converted to text. To unlink a field, select it and press Ctrl+Shift+F9.
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Problem

How do I make a table of contents?

If you structure your document appropriately, Word can automatically compile a table of contents for you. The secret to structuring your document is to apply styles to the headings for each section of your document. By default, Word expects that you'll want to use the styles Heading 1 through Heading 9 in your Table of Contents. If you do not want to use these styles, you can instead define the styles you want to use immediately before you compile the table of contents. Once you have applied the appropriate styles, follow the procedure outlined in this section.

Solution 1

To compile a table of contents using the built-in styles Heading 1 through Heading 9, follow these steps:


1.
Apply the built-in heading styles to the headings in your document. Make sure parallel subheadings are formatted in the same style. If you do not see the built-in headings in the Style drop-down list box, press and hold down the Shift key while you click on the drop-down arrow to open the list box.


2.
Locate the insertion point where Word should insert the Table of Contents.


3.
Open the Insert menu and select the Index and Tables item.


4.
In the Index and Tables dialog box, click on the Table of Contents tab.


5.
In the Formats list box, select the format to use for the table of contents. The Preview list box shows you what the table will look like. Use the Show Levels spin box to adjust the number of heading levels displayed in the Preview list box. Use the Tab Leader drop-down list box to select the tab leader you want.


6.
Check the Right Align Page Numbers check box to align the page numbers at the right margin of the table of contents. Clear this box to have page numbers appear immediately after the section title.


7.
Check the Show Page Numbers check box to include page numbers in the table of contents. Clear this box if you do not want page numbers to show.


8.
Click on OK. Word builds and inserts the table of contents.

Solution 2

If you do not want to use the built-in styles, you can define your own styles to use for marking the heading levels. After step 5 of the preceding sequence, perform the following steps:


1.
Click on the Options button in the Index and Tables dialog box.


2.
In the Table of Contents Options dialog box, select the style for each level of heading in the Available Styles list box. In the TOC Level text box to the right of each style, enter a number from 1 to 9 that represents the level for a heading formatted in that style. Delete any pre-assigned level numbers that do not suit your purposes.


3.
Click on OK in the Table of Contents Options dialog box.


4.
Check the Right Align Page Numbers check box to align the page numbers at the right margin of the table of contents. Clear this box to have page numbers appear immediately after the section title.


5.
Check the Show Page Numbers check box to include page numbers in the table of contents. Clear this box if you do not want page numbers to show.


6.
Click on OK. Word builds and inserts the table of contents.

After you create a table of contents, you can update it by clicking anywhere in the table of contents and pressing F9. In the dialog box that appears, select the Update Page Numbers Only option button if you have not edited the headings. Click on the Update Entire Table option button to update both page numbers and headings after editing. Click on OK to start the update.
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Problem

Can I build a table of contents using text elements other than styles? 

You can create a table of contents using field codes.

Solution

Enter a TC code at each table of contents entry. These codes are formatted as hidden text and do not show up in the document. Where the table of contents should appear, enter a TOC field code. The code in the TOC field builds the table of contents from the TC field codes you entered.

The Index and Tables command can build the table of contents for you from the TC field codes:


1.
Apply the built-in heading styles to the headings in your document. Make sure parallel subheadings are formatted in the same style. If you do not see the built-in headings in the Style drop-down list box, press and hold down the Shift key while you click on the drop-down arrow to open the list box.


2.
Locate the insertion point where Word should insert the Table of Contents.


3.
Open the Insert menu and select the Index and Tables item.


4.
In the Index and Tables dialog box, click on the Table of Contents tab.


5.
In the Formats list box, select the format to use for the table of contents. The Preview list box shows you what the table will look like. Use the Show Levels spin box to adjust the number of heading levels displayed in the Preview list box. Use the Tab Leader drop-down list box to select the tab leader you want.


6.
Check the Table Entry Fields check box in the Table of Contents Options dialog box instead of defining TOC Levels for styles. Clear the Styles check box, unless you are mixing styles and field codes as the means for defining table of contents entries.


7.
Click on OK in the Table of Contents Options dialog box.


8.
Check the Right Align Page Numbers check box to align the page numbers at the right margin of the table of contents. Clear this box to have page numbers appear immediately after the section title.


9.
Check the Show Page Numbers check box to include page numbers in the table of contents. Clear this box if you do not want page numbers to show.


10.
Click on OK. Word builds and inserts the table of contents.

After you create a table of contents, you can update it by clicking anywhere in the table of contents and pressing F9. In the dialog box that appears, select the Update Page Numbers Only option button if you have not edited the headings. Click on the Update Entire Table option button to update both page numbers and headings after editing. Click on OK to start the update.
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Problem

How do I make an index?

Indexes can be incredibly useful for locating information, even in short documents. But they are tedious to compile and maintain by hand. How does Word automate the task of building and maintaining an index?

Solution

Building an index requires three stages: creating the index entries, formatting and compiling the index, and updating the index. If you are creating both an index and a table of contents, create the index first. The Table of Contents will then contain the index as an entry.

To create index entries, follow these steps:


1.
Read through the document, identifying text that should be noted in the index. Good candidates are main ideas, main subjects, headings and subheadings, and variations on headings and subheadings.


2.
To mark text contained in the document, select the text and press Alt+Shift+X.


3.
In the Mark Index Entry dialog box, the text you selected appears in the Main Entry text box. Edit this text if necessary. If you want a colon or quotation mark to appear in the entry, you must make sure a backslash (\) appears before the colon or quotation mark. Word automatically inserts one; the only thing you need to do is remove the backslash if it is unnecessary. (The Mark Index Entry dialog box is modeless, so you can select a new entry in your document while it stays on-screen.)


4.
Type any subentry you want in the Subentry text box. You may have two levels of subentries. Type a colon between the two levels as you type them in the Subentry text box.


5.
To apply character formatting to entries or subentries, select the text in the appropriate text box and press Ctrl+B, Ctrl+I, or Ctrl+U to apply bold, italics, or underlining.


6.
Check the Bold and/or Italic check boxes if you want to apply these character formats to the page numbers that appear in the index.


7.
Click on the Mark button to mark only a single instance of the entry. Click the Mark All button to mark all identically spelled entries in the document.

To format and compile the index, follow these steps:


1.
After marking the index entries, position the insertion point where you want the index to appear.


2.
Open the Insert menu and select the Index and Tables option.


3.
In the Index and Tables dialog box, click on the Index tab.


4.
In the Type group, select either the Indented or Run-in option button. The Preview box shows you a sample of your choice.


5.
Select a format from the Formats list box. The Preview box shows a sample of your choice.


6.
Use the Columns spin box to select the number of columns for the index.


7.
Check the Right Align Page Numbers check box to align the page numbers at the right margin of the column.


8.
Use the Tab Leader drop-down list box to select a tab leader, if the list box is active for the format you have selected.


9.
Click on OK and Word inserts the index into your document.

To edit your index, you have two options. Index entries are placed in your document as XE field codes. You can display these field codes by clicking on the Show/Hide button on the Standard toolbar. To change an entry, you can edit each field code in the document.

Alternately, you can click anywhere in the index and press Ctrl+Shift+F9 or Ctrl+6. This action unlinks the fields. You can edit the index as regular text. However, if you update the index as described in the next procedure, you lose all the changes you make by editing the unlinked index. The information in the XE fields will be restored when you update.

To update the index, take these steps:


1.
Open the Insert menu and select the Index and Tables option.


2.
Click on the Index tab and click on OK. Word searches for an existing index and selects it. Word then initiates the update process.


3.
In the dialog box that appears, click on the Yes button to replace the existing index.
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Problem

How do I create index page ranges?

Indexes often contain page range references. How do I create these in Word?

Solution


1.
Mark the index entry as described in How do I make an index? in this chapter.


2.
In the Mark Index Entry dialog box, select the Page Range option button in the Options group.


3.
Enter the name for a bookmark in the Bookmark box.


4.
Click on the Mark button. Exit the Mark Index Entry dialog box by clicking on the Close button.


5.
Select the text that represents the page range you want to create for the index entry in the document.


6.
Open the Edit menu and select the Bookmark option.


7.
Type the name of the bookmark from step 3 in the Bookmark Name text box.


8.
Click on the Add button.
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Problem

How do I create index cross-references?

Indexes often contain cross-references among topics. How do I create these in Word?

Solution


1.
Mark the index entry as described in How do I make an index? in this chapter.


2.
In the Mark Index Entry dialog box, select the Cross-reference option button in the Options group. Word automatically enters See in the Cross-reference text box. You can edit this word if you want and add the text for the cross-referenced topic. You can apply character formatting using the Ctrl+B, Ctrl+I, and Ctrl+I keystrokes.


3.
Click on the Mark button.


4.
Click on the Close button when you are finished marking entries in the Mark Index Entry dialog box.
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Problem

How can I automate the creation of index entries?

Creating index entries is a tedious process. Is there any way to automate it?

Solution

You need to perform two steps: create a concordance file and mark the index entries automatically. To create a concordance file, follow these steps:


1.
Create a new Word document.


2.
Open the Table menu and select Insert Table.


3.
Click on OK in the Insert Table dialog box, accepting all the default settings.


4.
In the two-column table Word inserts, type the text that will occur in your Word document in the left column. (This is the text you would select and then mark by pressing Alt+Shift+X if you were marking entries by hand.) Press the Tab key. Type the index entry to pair with this text in the right column. (This is the text you would type into the Main Entry text box if marking entries by hand.) Press the Tab key.


5.
Repeat step 4 until you have finished entering pairs.


6.
Save the file.

To mark index entries automatically, follow this procedure:


1.
Open the document to index.


2.
Open the Insert menu and select the Index and Tables item.


3.
Click on the Index tab.


4.
Click on the AutoMark button.


5.
Use the controls in the Open Index Automark File dialog box to select the concordance file you created. These controls work exactly like those in the Open and Save As dialog boxes.


6.
Click on OK. Word searches your file and creates the index entries for you.
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Problem

How do I do mail merge?

Mail merge has always been a confusing process. Does Word 95 do anything to simplify the procedure? 

Solution

In Word 95, mail merge is handled by the Mail Merge Helper, which organizes the complex process of merging files for you. Mail merge requires four operations: creating the main document, creating the data, inserting the merge fields into the main document, and merging the data with the main document.

Create the main document

To create the main document, follow these steps:


1.
If you want to base the main document on an existing document or on a special template, open the existing file you want to use or create a file based on the template you want to use.


2.
Open the Tools menu and select the Mail Merge option. The Mail Merge Helper appears on-screen.


3.
Creating a main document is labeled as step 1 in the helper. Click on the Create button and select the type of document you want to create. Your choices are Form Letters, Envelopes, Mailing Labels, and Catalog.


4.
In the dialog box that appears, click on the Active Window button if you have opened a document to serve as your main document in step 1. Otherwise, click on the New Main Document button to create a new document to serve as your main document.

Create data

To create the data, take these steps:


1.
Click on the Get Data button in the Mail Merge Helper.


2.
To open an existing data source, select the Open Data Source option on the menu.


3.
Use the controls in the Open Data Source dialog box to select the data file. These controls work like those in the familiar Open and Save As dialog boxes.


4.
Word displays a dialog box after you have selected the data file. Click on the Edit Main Document button.


5.
To create a new data source, select Create Data Source option on the Get Data button menu.


6.
The Create Data Source dialog box appears. In it, you see the fields commonly used in the type of data file for the main document you have selected in the Field Names in Header Row list box. You can delete a field from the list by selecting and clicking on the Remove Field Name button. You can add a field name to the list by typing the field name in the Field Name text box and clicking on the Add Field Name button. You can change the position of a field in the list by selecting it and clicking on one of the Move buttons.



Field names are descriptions of the type of data located at that position in each record in the data file. In a form letter, for instance, the first field is Title and the second field is FirstName. This ordering means that the first data item in each record will be the individual's title and the second item the individual's first name.



The best way to order the fields is the same way you plan to insert them into the main document. Field names also serve as placeholders in the main document. They are the locations in the main document where the data they describe will be inserted.



Field names therefore appear in two places. They are the first line, or record, in your data file. This record is called the header. Each record (or line) thereafter contains data ordered according to the field names in the header record. Field names also appear in your main document. Here, they describe the location where the data they name will be inserted during the merge.


7.
Click on OK in the Create Data Source dialog box.


8.
When Word displays a dialog box, click on the Edit Data Source button.


9.
The Data Form dialog box appears, which contains text boxes for each of the field names you made a part of the header line in step 6. Type the information in each text box. Click on the Add New button to store the information you entered in a data record and to start a new data record. You can use the Record navigation buttons to review the records you have already entered. You can use the Delete button to remove a record that was entered erroneously. The Find button allows you to search for a record, and the View Source button allows you to view the entire data file you have entered in a window.


10.
When you have finished entering the data to merge into the main document, click on OK.

Merge the fields into the main document

To insert the merge fields into the main document, follow these steps:


1.
Open the main document, if it is not already open.


2.
Add the text and graphics that you want in every document, regardless of the data merged.


3.
At each location where data should be merged, click the Insert Merge Field button on the Mail Merge toolbar. Select the appropriate field from the list that appears. Type any spaces or punctuation before and after the field.


4.
After you finish editing, save the main document by selecting Save from the File menu.

Merge your new data

To merge the data, follow this procedure:


1.
Place the main document in the active document window.


2.
Click on the View Merged Data button on the Mail Merge toolbar. Word replaces the field names in the main document with the data from the first record. You can see how the data will look in each version of the merged document by clicking on the arrow buttons on the Mail Merge toolbar.


3.
Click on one of the following buttons to finish the merge:



Merge to New Document. Places the merged documents into a new document. You can then print this document and all the merged documents.



Merge to Printer Sends each merged document to be printed.

This section covers the basics of mail merge. Many more options and subtleties are available that you can try out as you become more confident with the procedure. Explore your Word manuals and Help files for suggestions about possible uses for this powerful data-merging feature.
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Problem

What advanced projects can I undertake with mail merge?

Mail merge provides sophisticated data-merging capabilities. For what sort of advanced projects could you use it?

Solution

Here are some suggestions:



Create your company's catalog as a master document and create a database of all the catalog items in a table. Merge the two together to create the final catalog document. You maintain the products in a single list and can make changes easily at any time. You maintain the marketing copy in the master document, which you can change easily without affecting product information. The accuracy of your catalog can easily improve under such a scheme.



Use a database to store the information to be merged. Word can access most databases through Windows Open Database Connectivity support.



Use mail merge to create electronic mail for distribution to large audiences, or to create FAX documents for distribution to customers with fax machines.



Use custom paper to create personalized messages to clients. The messages could be in the form of greeting cards, reminder cards, or special announcements.



Use mail merge in conjunction with your database to create customized monthly bills or statements for customers.

Return to Table of Contents
Problem

How do I create a form?

With Word 95 you can create electronic forms for use in place of print forms. These forms can have protected cells, check boxes, and other controls. They can be mailed electronically or printed for distribution. Word's form capabilities can help you reduce the amount of paper you use in doing your work. How do you create a form?

Solution


1.
Open the File menu and select the New option.


2.
In the New dialog box, click on the Template option button and then click on OK. All forms start with templates, and in this step you create the template for your form.


3.
Enter the text, tables, graphics, and controls that you want the form to have. Lay out the form the way you want it to appear on the page.


4.
Position the insertion point where you want the user to be able to insert information.


5.
Open the Insert menu and select the Form Field option.


6.
In the Form Field dialog box, select the type of field you want by selecting the Text, Check Box, or Drop-down option button.


7.
Click on the Options button and fill in the Options dialog box for the type of field you are inserting. The controls in the Options dialog box enable you to choose the type of data the form can receive, the format for the data, and how the form field responds to activating and deactivating.


8.
Repeat steps 4-7 until you have completed your form.


9.
Open the Tools menu and select the Protect Document option.


10.
In the Protect Document dialog box, click on the Forms option button, then click on OK. This action protects all areas of the document except the form fields from changes.


11.
Save the template, and then close it.


12.
To create a usable form, open the File menu, select the New option, click on the Document option button in the New dialog box, select the form template in the Template list box, and click on OK.
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Problem

Can I draw a picture in my document?

In Word 95, you can draw directly on your document. Here's how.

Solution


1.
Click on the Drawing button on the Standard toolbar. Word switches to page layout view and the Drawing toolbar appears at the bottom of the screen.


2.
Use the tools on the Drawing toolbar to draw objects anywhere in the document. You can add lines to highlight text or to show connections within the text. You can add callout balloons to insert commentary on the text as well.


3.
If you want to embed a picture in the document, click on the Create Picture button on the Drawing toolbar. If you want a frame around the picture, click on the Insert Frame button.
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Problem

How do I secure Word documents in a networked environment?

When working on a network, you may want to keep other users from opening a document. You may have security reasons for doing so, but you may also just want to work on ideas in privacy before sharing them with others. What options does Word have for protecting documents in a networked environment?

Solution

Your first line of defense in a secure environment should always be your network and operating system security features. Isolate files that you want to keep secure by placing them in a folder for your eyes only. Set security privileges on the file so that no one but you has access to it.

Word enables you to set a password on a document when you save so that others cannot open the document. To invoke this option, follow these steps:


1.
Click on the Options button in the Save As dialog box.


2.
Enter a Protection Password in the Protection Password text box, accessed from the Save tab in the Options dialog box.


3.
Click on OK.


4.
Confirm the password by retyping it when you are asked to do so.
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How do I create annotations?

If you are collaborating with a colleague on a document, you may want to make comments on the document, rather than actual physical changes to the document. These comments can be inserted as annotations, as described in this section.

Solution


1.
Either select the text that will receive your comments, or position the insertion point at the end of the text or object on which you want to comment.


2.
Open the Insert menu and select the Annotation option. Word opens an annotation pane and inserts in the file an annotation mark based on the initials you entered in the User Info tab of the Options dialog box.


3.
Enter your comments in the annotation pane.


4.
You can close the annotation pane by clicking on its Close button, or else leave it open to add more annotations. To leave it open, simply click on the document pane and scroll to the next place where you want to leave a comment. Repeat steps 1-3.


5.
To view the annotations, open the View menu and select the Annotations option. This option is active only when the file contains annotations. Unless you choose to view annotations, they remain invisible in your document because they are formatted as hidden text.


6.
Use the drop-down list box in the annotation pane to select whether to review a single reviewer's comments or the comments of all the reviewers.


7.
Scroll through the document to review annotations. You can use the Go To command on the Edit menu to go to the next annotation.


8.
When you are finished reviewing annotations, close the annotation pane.

You can print annotations by selecting them in the Print what drop-down list box in the Print dialog box. If you have a sound card and a microphone, you can insert voice annotations by clicking on the tape cassette icon in the annotation pane.
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Problem

How do I use revision marks?

Sometimes you have to work as a collaborator on a document. You want to suggest changes, but you do not want to physically edit the file. Is there a way you can mark your suggested changes to the text of the document so that your colleague can easily choose to accept or reject your comments? Word provides revision marks for this purpose.

Solution


1.
Double-click on the MRK box on the status bar, or open the Tools menu and select the Revisions item.


2.
Check the Mark Revisions While Editing check box in the Revisions dialog box.


3.
Click on OK.

From this point on, any changes you make to the file will be marked. The default marking uses blue text for all changes made by the first reviewer of a document, though you can choose another color and change other default settings in Tools, Options, Revisions. By default, added text is underlined. Deleted text is rendered as strike-through characters. A vertical line is placed in the outside margin next to any line of text that has been changed. Word keeps track of each revision you make in the original file.

The Revisions dialog box provides two methods for displaying revisions. By default, revisions are displayed on-screen and in the printed version of the file. You can convert your view of the revisions on-screen, and make them look like a regular part of the document by clearing the Show Revisions On Screen check box in the Revisions dialog box. All revisions then appear in normal color and normal font. By clearing the Show Revisions in Printed Document check box, you can effect a similar conversion while printing a document. These options enable you to see how the revised document might look in finished form if all your revisions were accepted.

After you (and perhaps others) have marked revisions, you have three options. First, you can accept or reject all the revisions by clicking on the Accept All or Reject All buttons in the Revisions dialog box, and then click on the Yes button in the subsequent confirmation dialog box. Or you can also review the revisions individually. To review revisions, follow this procedure:


1.
Double-click on the MRK box on the status bar or open the Tools menu and select the Revisions item.


2.
Click on the Review button in the Revisions dialog box. The Review Revisions dialog box appears.


3.
Click on one of the arrow buttons to move to the next revision.


4.
For each revision, click on the Accept or Reject button.


5.
You can undo revisions by clicking on the Undo Last button. Repeated clicks undo the last revision back. If you want to hide the revision marks as you preview the revised document, you can click on the Hide button.


6.
Click on the Close button when you are finished.
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Problem

How do I compare two documents?

Workgroups often produce multiple copies of a document, each with slight differences. Is there any way to compare the documents to see how they differ?

Solution


1.
Determine which version of the document you want as the base version for comparison purposes. You might want to work with a copy of the document rather than the original, so that you can return to the original version later.


2.
Open the base version of the document.


3.
Open the Tools menu and select the Revisions option.


4.
Click on the Compare Versions button in the Revisions dialog box.


5.
Use the controls in the Compare Versions dialog box to select a version of the file to compare to the base version. These controls work like the Open and Save As dialog boxes. The two files for comparison must have different names; or if they have the same name, they must be in different folders. Click on OK.


6.
Word displays the base version of the document with revision marks to indicate the differences. Open the Tools menu and select the Revisions item to accept or reject the revisions.
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How do I merge revisions into a document?

When working on collaborative documents, you might wind up with versions that have revision marks created by different workgroups. Is there a way to merge these revisions into the original copy of the document?

Solution


1.
Open the document containing the marked revisions.


2.
Open the Tools menu and select the Revisions option.


3.
Click on the Merge Revisions button.


4.
Use the controls in the Merge Revisions dialog box to select the file that contains the original document. These controls work like those in the Open and Save As dialog boxes. Click on OK.


5.
Word merges the revision marks and annotations into the original document. Open the Tools menu and select the Revisions option to accept or reject the marked revisions.
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Problem

How can I prevent a reviewer from making unauthorized changes in a document?

You may want to have your document reviewed by colleagues, but also want to prevent reviewers from changing anything. Little mistakes or changes often go unnoticed until it is too late. Is there a way to prevent reviewers from making unauthorized changes? 

Solution


1.
Open the Tools menu and select the Protect Document option.


2.
In the Protect Document dialog box, select either the Revisions option button or the Annotations option button. Revisions turns on revision marks, forcing all changes to be marked as revisions. Reviewers cannot turn off revision marks or accept or reject changes. Annotations allows reviewers only to insert annotations.


3.
Enter a password (but write it down for future reference). Without a password, any reviewer can select Unprotect Document from the Tools menu and make all the changes they want.


4.
Click on OK and confirm the password. To remove protection, select Unprotect Document from the Tools menu and enter the password when requested.

Keep in mind the limitations on Word's passwords when you protect a document. There are ways to circumvent passwords.
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Problem

How do I sort text?

Entering alphabetical lists or other sorted lists can be a pain. Can Word sort a list so that you do not have to sort it manually?

Solution


1.
Select the list you want to sort. If you do not select a region of text, Word selects the entire document.


2.
Open the Table menu and select the Sort Text option.


3.
In the Sort Text dialog box, use the left-hand drop-down list box in the Sort By group to indicate whether you are sorting text in paragraphs or text in fields. Use the Type drop-down list box to select whether you are sorting Text, Number, or Date. The type tells Word what sorting criteria to apply to the items on the list. Click on the Ascending or Descending option button to determine the direction of the sort. Select the Header Row or No Header Row option button to indicate whether the first row in the list is a set of titles for columns in the list.


4.
Click on the Options button.


5.
In the Sort Text Options dialog box, click on the Tab, Comma, or Other option button to select the character that separates fields in your list. If you select Other, enter the character that separates fields. Check the Case Sensitive check box if you need the sort to be case sensitive. Check the Sort Column Only text box if you want to sort only in a given column.


6.
Click on OK in the Sort Text Options dialog box and then click on OK in the Sort Text dialog box. Word performs the sort.

Chapter 3: Managing Files

Every Word user faces issues of file management. These may include converting files to and from Word 95 format, recovering damaged files, locating files, making files available to other users, and even performance issues related to Word's file structure. This chapter outlines frequent problems, including:



How do I avoid increasing the file size when I convert Word 2.0 files?



Can I save in rich text format to fix a damaged file?



How do I convert WordPerfect 6.0 files and Ami Pro 3.0 files?



Can I convert Word documents from Macintosh format?



Can I save both to a floppy and to the hard drive with one command?



How do I keep from losing work if the power goes out?



Can I search for a file in Word?



How do I do an advanced file search?



How do I embed fonts in a file?



Can I perform DOS file operations from Word?

Problem

How do I avoid increasing file size when I convert Word 2.0 files?

I've upgraded to Word 95 directly from Word 2.0, and I've found that my files dramatically increased in size when I started working on them in Word 95. Is there any way to avoid this problem?

Solution

Word 2.x files when converted to Word 6/Word 95 format should gain between 4 kilobytes and 8 kilobytes in size. The Word 6/Word 95 file format needs this amount of space to store its internal allocation tables for text, graphics, and objects. You should not notice a gain in file size larger than this, and the increase in size should occur only once. If your files are increasing in size more than this amount, the fast save process is probably the culprit.

Fast saving is a process in which changes to a file are attached to the end of the existing file. If you open a 30 kilobyte file and make 5 kilobytes worth of edits, when you fast save the file will be 35 kilobytes long (at least in theory). Word keeps all of the original file and all of the changes. If you delete a large block of text and replace it with an equal amount of text, you expect the file to remain the same size. The fast save process, however, actually increases the file size.

When you open a Word 1.x or a Word 2.x document in Word 95, Word 95 may reserve more file space than is necessary for the file as a part of the conversion process. If you fast save the file, Word 95 may attach that extra space to your file, bloating its size considerably. Your file then contains a large block of empty space. The only solution is to perform a full save, which causes the changes to be integrated into the document before the file is saved. The file then returns to its appropriate size.

To solve the problem, follow these steps:


1.
Open the Tools menu and select the Options item.


2.
Click on the Save tab in the Options dialog box.


3.
In the Save tab, clear the Allow Fast Saves check box.


4.
Click on OK to close the Options dialog box.


5.
Open the file that you suspect has increased in size more than necessary.


6.
Save the file in Word 95 format.

With fast saves turned off, minor editing may not cause any change in file size. Word 95 adds edited material to a file in 512-byte chunks. You must add enough material to fill a 512-byte chunk before Word adds another one. As a result, minor editing may not increase (or decrease) the size of the file as expected.
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Problem

Can I save in rich text format to fix a damaged file?

One of your Word documents is damaged. The formatting does not look right when you open the file. Other tell-tale evidence also alerts you that the file is not as it should be. The file may even crash Word 95 as you try to edit it. Can saving in Rich Text Format (RTF) help?

Solution

Usually, if a Word file has suffered damage, saving the file in Rich Text Format (RTF) will recover as much of the file as possible. If you open a file and find that the formatting is wrong but can find no reason for the problem, this often solves the problem. The conversion to rich text format causes all of the formatting instructions in the Word file to be converted to text instructions inserted in the file. Converting the file back to Word format converts all of the rich text formatting instructions back to Word formatting instructions. This operation essentially rebuilds the Word document.

To save a file in RTF, follow these directions:


1.
Open the File menu and select the Save As option.


2.
In the Save As dialog box, open the Save File as Type drop-down list box and select the Rich Text Format option.


3.
Enter a new file name in the File name combination box. You must use a different file name to avoid a conversion error when you are converting to rich text format.


4.
Click on OK.

After you have saved the file using rich text format, open the file using the Open command on the File menu. (Remember to look for a file with an. RTF extension rather than the familiar. DOC extension. In the Files of type box, choose either All Files or Rich Text Format.) Allow Word to convert the file, then repeat the steps in this section using the Word Document file format rather than Rich Text Format. If the damage can be repaired, this operation will repair it.
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Problem

How can I convert files from a word processor that Word does not provide an import filter for, such as Ami Pro 3.0? 

Word 95 comes with a wide variety of file converters, but not all. For example, there's no Ami Pro filter. However, if you don't have the correct import filter, you have a number of options.

Solution

If you have access to the word processor the document was originally created in, you can export the files in a format that Word 95 will convert. Ami Pro, for example, will save documents in Word for Windows 2.0 format, or in RTF.

A second alternative is to contact Microsoft for the Supplemental File Conversions disk, which is available free to registered owners of Word 95. This disk contains a wide variety of additional file filters, including filters for programs such as Displaywrite, MultiMate, and WordPerfect 4.1. For more information, call Microsoft at 800-426-9400.

A third alternative is to purchase a file conversion program from a third-party vendor. Two vendors, Mastersoft, Inc. (602-970-0800) and Systems Compatibility Corporation (312-329-0700), specialize in products that convert files between otherwise incompatible data formats.

Problem

Can I convert Word documents from Macintosh format?

Some offices use both Macintosh and DOS/Windows computers. Is there any way to convert Word files from Macintosh to DOS/Windows format?

Solution

The Word 95 and Word 6 for the Macintosh formats are identical except that Word 6 for the Macintosh disregards features that only exist in Word 95, such as highlighting. Word 95 also comes with a converter for Word versions 4-5.1 for Macintosh.
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Problem

Can I save to both a floppy and the hard drive with one command?

I like to keep each Word document on my hard drive with a backup copy on a floppy disk. Is there any way to save to both drives with a single command?

Solution

Saving to both drives is possible with a WordBasic macro. Here is a macro that collects the path of the C: drive, then collects the path of the A: drive. The macro then saves to the A: drive, followed by saving to the C: drive.

Sub MAIN

cDrive$ = FileNameInfo$(FileName$(), 1)

aDrive$ = "A:\" + FileNameInfo$(FileName$(), 3)

FileSaveAs.Name = aDrive$

FileSaveAs.Name = cDrive$

End Sub

To create this macro, follow these steps:


1.
Open the Tools menu and select the Macro item.


2.
In the Macro dialog box, enter a name for the macro in the Macro Name combination box.


3.
Click on the Create button.


4.
Enter the commands for the macro in the macro editing window that opens.


5.
Open the File menu and select the Close option. Click on the Yes button to save the file when the dialog box appears.

You can run the macro from the Macro dialog box by selecting it in the Macro Name combination box. You can also assign it to a toolbar, menu, or keystroke as described in Chapter 11, "Customizing Word."
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Problem

How do I keep from losing work if the power goes out?

Power failures are a problem in my neck of the woods. I am afraid of losing documents when the power goes out. What options do I have to protect against such losses?

Solution

Power failures are a very real threat to anyone who depends on electronic documents. When the power goes out—even momentarily—you might lose everything you have done since the last save. If you are working toward a paperless office, power failures can be even more traumatic because all of your work resides somewhere on a computer that is susceptible to electrical disturbances.

You have several options for protecting against power failures:



Save frequently. You have heard this advice often, and it is still the best advice. If your work is saved to a disk, it is less likely to be destroyed from electrical disturbances.



Make automatic backups Open the Tools menu and select the Options item. In the Options dialog box, click on the Save tab. Check the Always Create Backup Copy check box, and click on OK. When Word saves a file, it now renames the previous version FILENAME.BAK. The backup file has the same root for its name as the newly saved file, but adds the. BAK extension. If something goes wrong with the save operation, you always have the last version of the file on the disk. (You cannot use the fast save option, however, if you make automatic backups.)



Turn on automatic saves. Open the Tools menu and select the Options item. In the Options dialog box, click on the Save tab. Check the Automatic Save Every check box and use the spin box to set the number of minutes between saves. The smaller the time span between saves, the greater the protection against loss.



As your documents grow longer, frequent automatic saves can pause your work while you wait a few seconds (or longer) for the automatic save. Set the frequency by balancing your tolerance for interruptions with your need to protect changes to the file.



Multiple saves to multiple drives Save to more than one drive at the same time. If you have two hard drives, create a folder on the second drive and save the file to both places. With each save, you create mirror copies of the file. See Can I save to both a floppy and the hard drive with one command? in this chapter for a sample macro that saves to two drives in one operation. Be aware that if you use a floppy drive as the second drive the save operation will be considerably slower because of the slower speed of the floppy drive. If you are on a network, you may be able to use a network drive as the second drive.



Store files on the network. If you are on a network, store your documents on the file server to take advantage of the file safety features built into your network operating system and network administration. File servers often have uninterruptible power supplies, built-in disk mirroring, or automated tape backups to protect files from loss.



Make frequent backups of your files to tape or other media. Use the backup program that comes with Windows 95, or a commercial backup program, to back up documents that have changed on a daily basis. If a power problem causes any damage, you can easily restore a file from its backup copy.



If power failures or power surges are a frequent problem, consider buying an uninterruptible power supply (UPS). If a power problem occurs, your computer has its own power supply. Even if the UPS you purchase gives you only a few minutes of power, you have enough time to save all changes to your files and shut down your system safely.
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Problem

Can I search for a file in Word?

Even though Windows 95 allows for long file names, I still have plenty of files named cryptically with DOS's 8.3 file-naming convention (filename.ext). I can no longer recognize several of them by their file names. Is there a way to search for files using Word?

Solution


1.
Choose Open from the File menu. 


2.
In the Look in box, specify the drive you want to search. 

If you want to search the entire drive, including subfolders, choose click the Commands and Settings button and choose Search Subfolders from the pop-upmenu. 

If you know the file name, enter it in the File name box. 

If you know the type of file -- for example, if you know that you want to search only for Word files -- make a choice in the Files of type drop-down list box. 

If you know when the file was last edited, make a choice from the Last modified the drop-down list box. 

If you know specific text that appears in the file you're looking for, such as a name, enter the text in the Text or property box. Word will search both the document and the Properties tabbed dialog box. 

To begin the search, choose Find Now. 
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Problem

How do I do an advanced file search?

Word's basic search features are great, but sometimes it displays lots of files – I'd like to narrow my search further. Other times, even after I use the basic search features, I still haven't found the file I'm looking for. Can Word help me any more? 

Solution

Use Word's advanced search features. 


1.
Choose File, Open.  


2.
Start by setting any basic search criteria you can in the File, Open dialog box. 


3.
Choose Advanced. The Advanced Find dialog box opens. Here, you can start building a search, by adding lines describing the more detailed criteria you want. For example, to search for all files that list William Shakespeare as author in their property sheets, choose Author from the Property box; choose Includes in the Condition box; and enter William Shakespeare in the Value box. To add the search criteria, click Add to List. 


4.
To add another search criterion, repeat the previous step. 


5.
If you've chosen to search for text contained either in the document or the Properties sheet, you can specify that Word expand its search to Match All Word Forms, or restrict its search to files containing text that Matches Case. Check the appropriate check boxes; these appear beneath the Find Files box. 


6.
If you haven't already specified where to search, do so in the Look in: box. Remember that if you want Word to search subfolders, you need to check the Search Subfolders check box. 


7.
When you're ready to search, click Find Now. 
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Problem

How do I embed fonts in a file?

Not everyone in my office has the same fonts installed on his or her system. How can I embed my TrueType fonts in my document so that my coworkers can display the documents in their original fonts?

Solution


1.
Open the Tools menu and select the Options item.


2.
In the Options dialog box, click on the Save tab.


3.
Check the Embed TrueType Fonts check box.


4.
Click on OK. Be sure to save your file after taking this action to embed the fonts.

Note that not every TrueType font can be embedded; some type vendors choose not to permit this because embedded fonts can be used on multiple computers at once without being purchased separately for each computer. However, all fonts that come with Word and Windows 95, as well as all fonts sold by Microsoft, can be embedded.
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Can I perform DOS file operations from within Word?

Can I perform DOS commands on files without leaving Word? Or do I need to open a DOS window or use Windows Explorer?

Solution

In Word 95, the File, Open and File, Save As dialog boxes contain capabilities that formerly appeared in the Find File dialog box or required you to use the Windows 3.1 File Manager or a DOS window.

To move or copy a file from one folder to another: 


1.
Choose File, Open or File, Save As. 


2.
Select and right-click on the file; a pop-up menu appears.


3.
To move the file, choose Cut. To copy the file, choose Copy.


4.
In the Look in box, display the folder where you want to place the file.


5.
Right-click in an empty location in the list of documents, and choose Paste from the pop-up menu.

To delete a file (other than one you're working on): 


1.
Choose File, Open or File, Save As. 


2.
Select and right-click on the file; a pop-up menu appears.


3.
Choose Delete.


4.
A confirming dialog box appears. Choose Yes.


5.
Windows 95 moves the file to the Recycle Bin. (It remains there until you empty the recycle bin.) 

To rename a file (other than one you're working on): 


1.
Choose File, Open or File, Save As. 


2.
Select the file you want to rename. 


3.
Wait a moment, and click on the file name.


4.
A rectangle appears around the file name, and an editing cursor appears. Edit the file name as you wish. 

To sort files in a file list, 


1.
Choose File, Open or File, Save As.


2.
Click the Commands and Settings button.


3.
Choose Sorting from the pop-up menu.


4.
The Sort by dialog box opens.


5.
Choose how you want to sort files: by file name, size, type of file, or date of last modification.


6.
Choose whether you want to sort the files in Ascending or Descending order.


7.
Choose OK. The files will be sorted and displayed in the File, Open or File, Save As window.

To create a new folder, 


1.
Choose File, Save As.


2.
Click the Create New Folder button.


3.
The New Folder dialog box appears. Enter the name of the new folder you want, and choose OK. 

Chapter 4: Formatting Word Documents

Word 95 provides you with dozens of formatting features, many of which previously existed only on advanced page layout programs. These Word 95 features are so numerous and advanced that you may not know when or how to use them. This chapter covers some very useful features that aren't familiar to most Word users, including:



How do I get rid of unwanted page breaks?



How do I substitute fonts in a document created on another system?



How do I create a drop cap?



How do I use the style gallery?



How do I use AutoFormat?



Can I build my own styles for use with AutoFormat?



Can I create styles for foreign language documents?



How do I use hyphenation to improve the look of my documents?



How do I use the Format Painter tool?



How do I do reveal codes in Word?



How do I get even columns on the last page of my document?



How do I create a watermark?



How do I mix bullets and numbering in a list?



How do I put graphics on an envelope?



Can I put text or graphics in a margin?



Can I build a hypertext document?



Can I put callouts into my document?



How do I use the Spike while formatting a document?



How do I keep from orphaning text at the bottom of a column?



Can I force text to stay in the same column?



How do I create special text effects in my document?



How do I enter an equation into my document?



How do I float a frame between columns?



How can I keep framed material in one place?



How can I split the justification on one line?
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Problem

How do I get rid of unwanted page breaks?

Page breaks are showing up in unusual places in your document. You are not sure why, and you don't know how the page break was inserted. How should you correct this problem?

Solution

Unwanted page breaks can arise from several sources. Check each of the following possibilities carefully.

Paragraph Format


1.
Place the insertion point in the paragraph after the page break. After you have followed these directions, place the insertion point in the paragraph before the page break and repeat the procedure.


2.
Open the Format menu and select the Paragraph Option.


3.
In the Paragraph dialog box, click on the Text Flow tab.


4.
Clear the Page Break Before, Keep With Next Paragraph, and Keep Lines Together check boxes.


5.
Click on OK.


6.
If the page break disappears, experiment with these three check boxes to see which of them caused the problem, and restore as much of the original formatting as you desire.

Footnote Format


1.
Open the View menu and select the Footnotes option.


2.
Place the insertion point inside the footnote pane.


3.
Open the Insert menu and select the Footnote option.


4.
In the Footnotes and Endnotes dialog box, click on the Options button.


5.
In the Note Options dialog box, click on the All Footnotes tab.


6.
Check the Place At drop-down list box. If the setting is Bottom of Page, the footnote must be printed at the bottom of the same page that contains its note marker. The result may be an unwanted page break. Try switching to the Beneath Text setting to see if the problem is resolved. If not (and if your style guide permits you to do so), click on the Convert button to convert the footnotes to endnotes.

Section Break Format


1.
Select a section break near the unwanted page break.


2.
Delete the section break by pressing the Delete key.


3.
Open the Insert menu and select the Break option.


4.
In the Section Breaks group in the Break dialog box, select any option button that seems appropriate, other than the Next Page option. Click on OK. If the problem is resolved, the section break you deleted was causing the problem.

Page Break Format


1.
Open the Tools menu and select the Options item.


2.
In the Options dialog box, click on the View tab.


3.
Check the Hidden Text check box.


4.
Scroll through the document looking for the offending page break. It may have been formatted as hidden text and not have been visible.


5.
Delete the page break. Repeat this procedure and clear the Hidden Text check box.
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How do I substitute fonts in a document created on another system?

Perhaps your coworkers do not have the same fonts installed on their computers as you have installed on yours. As a result, you do not see their fonts when you work with their documents, but instead see similar fonts that are installed on your system. Is there any way you can substitute fonts you prefer to see instead of fonts the system chooses?

Solution


1.
Open the Tools menu and select the Options item.


2.
Click on the Compatibility tab.


3.
Click on the Font Substitution button.


4.
In the Font Substitution dialog box, click on a font name in the Missing Document Font list box.


5.
Open the Substituted Font list box and select the font to replace the missing font.


6.
Repeat steps 4 and 5 for each font you want to replace.


7.
Click on OK. If you want to permanently substitute the fonts, click on the Convert Permanently button, then click on the Yes button in the dialog box that appears requesting confirmation of the permanent substitution. (Do not make the substitution permanent if you must return the file to its owner after you are finished. If you do, the file's owner will have to substitute all the original fonts for the fonts you substitute.)
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How do I create a drop cap?

I would like to use drop caps in formatting because they add flair to documents like newsletters and formal announcements. How do you create a drop cap in Word?

Solution


1.
Position the insertion point at the location for the drop cap.


2.
Open the Format menu and select the Drop Cap item.


3.
In the Drop Cap dialog box, click on the type of drop cap you want in the Position group.


4.
Select a font for your drop cap using the Font drop-down list box. You do not need to use the same font as that of your main text. In fact, drop caps are often in a different font.


5.
Use the spin boxes to set the Lines to Drop and Distance from Text.


6.
Click on OK to insert your drop cap.
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How do I use the style gallery?

I have noticed the Style Gallery option on the Format menu. I know it opens a dialog box, but I cannot figure out what the dialog box is for. When I click on OK, nothing seems to happen. How do I use the style gallery?

Solution

The style gallery allows you to preview styles so that you can choose the look you want for your document. To open the style gallery, open the Format menu and select the Style Gallery option. The Style Gallery dialog box appears, and it provides you with the following options:



The Preview of box option shows a document in the style of the template currently selected.



The Template combination box enables you to select a template to preview its styles.



The option buttons in the Preview group enable you to select the type of preview you want. By default, Word shows you the current document (the Document option). Selecting a new template may not show significant changes in the current document because none of the styles in the template are in use in the document. By clicking on Example, you can see a sample document that shows the actual styles in use. If you click on Style Samples you will see an example of each style available in a list format.



Click on OK to copy the styles from the selected template into the current document for use with that document. The styles are stored in the document, not the document's template. The advantage of this Style Gallery feature is that you can import styles for use in a single document that you may not want to import into the template (because the styles in the template become part of every subsequent document that is based on the template).
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How do I use AutoFormat?

I clicked on the AutoFormat button on the Standard toolbar once, and it reformatted my document. What exactly did it do and why?

Solution

Word can automatically format a document. You type characters as plain text, and AutoFormat finds headings, paragraphs, titles, lists, and so forth, according to Word's built-in rules. Word then applies the appropriate style to each document element that it finds. AutoFormat, therefore, can save you some time, because you do not have to apply styles by hand. However, Word uses the built-in default styles that are included in its templates. You need to make sure the built-in defaults match your needs.

Word offers you two ways to format a document automatically. If you want to format the document without reviewing any changes, click on the AutoFormat button on the Standard toolbar. Word formats the document and presents the finished version to you. If you find that you do not like the changes, you can undo them by means of the Undo button on the Standard toolbar.

If you want more control over the process, however, follow the following procedure. (The steps that follow describe how to AutoFormat a document all at once, once you've completed it. In Word 95, you can also tell Word to AutoFormat as You Type, making or suggesting changes as you write.) 


1.
Open the Format menu and select the AutoFormat option.


2.
Word displays the AutoFormat dialog box. Click on the Options button.


3.
Word displays the Options dialog box with the AutoFormat tab selected. Use the controls presented here to adjust the AutoFormat process.


4.
To preserve any styles that you have already applied, check the Previously Applied Styles check box in the Preserve group.


5.
To apply styles to particular document structures, check the check boxes for the relevant structure: Headings, Lists, or Other Paragraphs.


6.
To replace character groupings with the special symbols they represent, check the Straight Quotes with Smart Quotes, Ordinals with Superscript, Fractions with Fractional Characters, or Symbol Characters with Other Characters check boxes. When you replace Ordinals with Superscript, 1st becomes 1st, 2nd becomes 2nd, and so on. When you replace fractions with fractional characters, 1/2 becomes ½, and so on. When you replace symbols with symbol characters, character strings like (c) are replaced with the symbols like ©.


7.
Click on OK in the Options dialog box.


8.
Click on OK in the AutoFormat dialog box.


9.
The AutoFormat dialog box changes form.


10.
Click on the Accept button to accept all changes in the document, or the Reject all button to reject all changes.


11.
Click on the Style Gallery button to open the Style Gallery dialog box. Here you can review the types of document formats available by selecting each one in the list box. You can also preview the formats in the Preview box, and choose the one you like by clicking on OK after selecting it in the list box. When you click on OK in the Style Gallery dialog box, Word repeats the AutoFormat process.


12.
Click on the Review Changes button to display the Review AutoFormat Changes dialog box. The options in this dialog box enable you to accept or reject each change on an individual basis.


13.
Click on the Find button or the Find Next button to scroll to the previous change or the next change, respectively.


14.
Click on the Reject button to reject a change.


15.
Click on the Hide Marks/Show Marks button (whichever is displayed) to turn the display of paragraph marks off and on.


16.
Click on the Undo Last button to undo the results of previous button clicks in the Review AutoFormat Changes dialog box. Each click undoes one action.


17.
Check the Find Next after Reject check box to automatically move to the next change after you click on the Reject button.


18.
Click on the Close or Cancel button (whichever appears) to accept all remaining changes.
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Can I build my own styles for use with AutoFormat?

I like using AutoFormat because it is convenient and saves me lots of time. I do not, however, like all of its built-in styles. Can I change the AutoFormat styles?

Solution

You can change the AutoFormat styles, but there is a catch. You must change the built-in styles that are associated with a template. As a result, you lose default styles when you customize for AutoFormat. It may be difficult to return to the default styles after they have been modified.

The easiest way to modify a style is to modify it by example. Follow these steps:


1.
Create a new paragraph by pressing the Enter key.


2.
Type some text.


3.
Use the commands available on the Format menu to apply desired formats such as font and paragraph formats to the text.


4.
Make certain the insertion point is in the text you have just formatted.


5.
Open the Style drop-down list at the left side of the Formatting toolbar.


6.
Select the style you want to modify from the list.


7.
When the Reapply Style dialog box appears, make sure the Redefine the style using the selection as an example? option button is selected. Then click on OK.
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Can I create styles for foreign language documents?

I often have to work with text in foreign languages. I know I can purchase spelling dictionaries for the languages I use, but can I create a format for each language so that Word automatically applies the correct spelling, grammar, and country conventions?

Solution

Word enables you to create styles that include language information. When Word encounters that style, it automatically switches to the correct language information. For example, during a spelling check Word switches to the correct spelling dictionary if you have it installed. To add language information to a style, follow these steps:


1.
Open the Format menu and select the Style option.


2.
In the Style dialog box, click on the New button to create a new style, or select a style in the Styles list box and click on the Modify button.


3.
In either the New Style or the Modify Style dialog box (which are identical except for the title), click on the Format button and select Language from the list that appears.


4.
In the Language dialog box, select the language you want to use for that style in the list box and click on OK.


5.
Click on OK in the New or Modify Style dialog box, then click on Close in the Style dialog box. You can now apply the style as you want.
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How can I use hyphenation to improve the look of my documents?

You are not satisfied with the look of your right margins. You consider them too ragged, but you do not want to use full justification because you find fully justified text difficult to read. Is there anything you can do to improve the look of the right margin? Will hyphenation help?

Solution

Word provides several hyphenation methods to help you improve the look of your right margin. Word allows three types of hyphens. Optional hyphens break a word only when the word appears at the end of a line and using the hyphen would improve the appearance of the ragged margin. Nonbreaking hyphens always appear in the word but never break at the edge of a line. They are useful in compound words such as Somerset-Upon-Thyme or hyphenated personal names in which you do not want parts of the compound to wrap around a line. Ordinary hyphens are treated like any other mark of punctuation. Word always breaks a line at a punctuation mark. To insert an optional hyphen, press Ctrl+- (hyphen). For a nonbreaking hyphen, press Ctrl+Shift+-. For an ordinary hyphen, press the hyphen key.

Word also offers an automated hyphenation process so that you do not have to read the document and guess where hyphens should go. After you have completed your document, take these steps to use automatic hyphenation:


1.
Open the Tools menu and select the Hyphenation option. The Hyphenation dialog box appears.


2.
Check the Automatically Hyphenate Document check box.


3.
Check the Hyphenate Words in CAPS check box if you want to hyphenate words in caps; otherwise, Word will not hyphenate these words.


4.
Use the Hyphenation Zone spin box to adjust the width of the zone between the work and the margin where the hyphen break can occur. A wider zone produces a more ragged margin.


5.
Use the Limit Consecutive Hyphens To spin box to set the maximum number of consecutive lines that can be hyphenated.


6.
Click on OK, and Word hyphenates the text for you.

Instead of Word doing all the work for you, you can slow down the hyphenation process so that you confirm each hyphenation manually. To do so, follow these steps:


1.
Open the Tools menu and select the Hyphenation option to display the Hyphenation dialog box.


2.
Click on the Manual button to display the Manual Hyphenation dialog box (shown in fig. 4.17).


3.
Word searches through your document, displaying each word to be hyphenated in the Hyphenate At text box. Click on the Yes button to accept the suggested hyphenation. Click on the No button to prevent Word from hyphenating the word. Or click in the word itself at the location where the hyphen should go.
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How do I use the Format Painter tool?

I see the Format Painter button on the toolbar, but clicking it seems to do nothing. How do I use this tool?

Solution

The Format Painter allows you to copy formats from a sample block of text to text you want to format in the same way. (If you want to copy paragraph formatting, you must include the paragraph mark in the sample text you use with the Format Painter.) To copy formats, follow these steps:


1.
Select the text that will serve as the example. Remember to include the paragraph mark if you want to copy paragraph formatting. (You may want to click on the Show/Hide Paragraphs button on the Standard toolbar to see the paragraph marks.)


2.
Click on the Format Painter button if you want to copy formats to only one location. Double-click if you want to copy formats to several locations.


3.
The mouse pointer changes to a paintbrush. Select the text you want to format with this mouse cursor, and the formats are copied.


4.
If you double-clicked on the Format Painter button, click on this button again, or press the Escape key to turn off the Format Painter.
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How do I do reveal codes in Word?

I like WordPerfect's reveal codes feature. Is there any equivalent in Word?

Solution


1.
Click on the Help button on the Standard toolbar or the “What’s This?” choice under the Help Menu.


2.
Click anywhere in your text. A balloon dialog box opens that reveals the formats applied at that location in your document.
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How can I get even columns on the last page of my document?

I know that creating columns is as easy as clicking on the Columns button on the Standard toolbar and dragging over the number of columns that I want. But I want the columns on the last page to be even, not ragged. How do I get even columns on the last page of my document?

Solution

Word leaves the columns on the last page of your document ragged or unbalanced unless you insert a continuous section break at the end of the text in the columns. The continuous section break forces the columns to be balanced.

To insert a continuous section break, follow these steps:


1.
Open the Insert menu and select the Break option.


2.
Click on the Continuous option button in the Section Breaks group of the Break dialog box.


3.
Click on OK.
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How do I create a watermark?

You would like to use a watermark on your documents to display your company logo, but would prefer not to spend the money on the custom paper. Can Word use graphics as a substitute for watermarks in a document?

Solution

Word allows you to create or insert graphics as watermarks by placing the graphics in the header or footer of the document. Follow these steps:


1.
Open the View menu and select the Header and Footer option.


2.
Click on the Drawing button on the Standard toolbar to display the Drawing toolbar.


3.
Click on the Show/Hide document text button on the Header and Footer toolbar to hide the document text. You do this so you can see your watermark as you draw it.


4.
Using the drawing tools, draw the picture that you want to use as the watermark in the header box.


5.
Click on the drawing object to select it.


6.
Drag the drawing object to the position you want it to be on the page.


7.
On the Drawing toolbar, click on the Send Behind Text button.


8.
Click on the Close button on the Header and Footer toolbar.


9.
Click on the Drawing button on the Standard toolbar to close the Drawing toolbar. The graphic image you create appears as a watermark on each page of the printed document that contains the header.

If you want to use imported graphics as watermarks, first insert a frame into the header, then insert the graphic into the frame. You can then use the graphic as a watermark. Follow these steps:


1.
Open the View menu and select the Header and Footer option.


2.
Click on the Show/Hide document text button on the Header and Footer toolbar to hide the document text.


3.
Open the Insert menu and select the Frame option.


4.
Make sure the insertion point is inside the frame you created. Open the Insert menu and select the Picture option.


5.
In the Insert Picture dialog box, select the graphic image you want to use in the File name list box, then click on OK.


6.
After inserting the picture, double-click on it to open the Drawing toolbar to edit the picture.


7.
Use the selection tool (the arrow) to select the entire picture.


8.
Click on the Send Behind Text button on the Drawing toolbar.


9.
Click on the Close Picture button on the floating toolbar to stop editing the picture.


10.
Size the picture and position it on the page by dragging with the mouse.


11.
Click on the Close button on the Header and Footer toolbar.

Your imported graphic should now function as a watermark.
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How do I mix bullets and numbering in a list?

I would like to create a list that mixes bullets and numbering. I can find the Bullets button and the Numbering button. Is there any way of combining the two?

Solution


1.
Place the insertion point where you want to begin your list, or select the text that will be formatted as a list.


2.
Open the Format menu and select the Bullets and Numbering option. The Bullets and Numbering dialog box appears.


3.
Click on the Multilevel tab.


4.
Click on the box that shows a list that mixes bullets and numbering.


5.
Click on OK to format the list.

If the standard format offered for mixing bullets and numbering does not suit your needs, follow this procedure to create your own format:


1.
Open the Bullets and Numbering dialog box and select the Multilevel tab.


2.
Click on the box that shows the closest style to the one you want and then click on the Modify button. The Modify Multilevel List dialog box opens.


3.
Select the list level to modify using the Level list box.


4.
Enter any text that should appear before the number or bullet in the Text Before text box.


5.
Use the Bullet or Number drop-down list box to select a number or bullet format.


6.
Enter any text that should follow the number or bullet in the Text After text box.


7.
Click on the Font button to select the font and character styles from the Font tab in the Font dialog box. Click on OK after you have made your selection.


8.
Set the starting number in the Start At spin box if you are working with a number format.


9.
Select what to include from the previous level using the Include from Previous Level drop-down list box. The Preview box shows the results of your selection.


10.
Use the drop-down list box in the Number Position group to set the Alignment of List Text.


11.
Use the spin boxes in the Number Position group to set the Distance from Indent to Text and Distance from Number to Text.


12.
Check the Hanging Indent text box if you want your list to have hanging indentations.


13.
Click on OK, then click on OK in the Bullets and Numbering dialog box to apply your new format.
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How do I put graphics on an envelope?

Using the template for your company stationary, you want to include your company logo or special text on envelopes. How do you get the graphics and text to appear on every envelope you print?

Solution


1.
Open the Tools menu and select the Envelopes and Labels option. Click on the Envelopes tab.


2.
Click on the Add To Document or Change Document button (whichever appears) in the Envelopes and Labels dialog box.


3.
Open the View menu and select the Page Layout option.


4.
In the envelope section at the beginning of the document, add the graphics that you want to use by clicking on the Drawing button on the Standard toolbar and drawing in the envelope section. You can also use the Picture command on the Insert menu to insert a picture. (See How do I insert a graphic in a document? in Chapter 5, "Linking and Embedding Objects in Word" for more details.)


5.
Position the graphics as you want.


6.
Enter any text that you want to include on every envelope.


7.
Select the text and graphics.


8.
Open the Edit menu and select the AutoText option.


9.
In the Name text box in the AutoText dialog box, enter either EnvelopeExtra1 or EnvelopeExtra2. You can create both entries if you want.


10.
Select the template in which to store the template in the Make AutoText Entry Available To drop-down list box.


11.
Click on the Add button. Word adds the special AutoText entry and automatically prints it in the position you indicated on each envelope.
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Can I put text or graphics in a margin?

I want to use a wide margin in my document and place sidebars and text banners in the margins on certain pages. How do I get Word to let me do this?

Solution


1.
Set your margins as you want using the Page Setup command on the File menu.


2.
Scroll to the page where you want to put text in the margin.


3.
Open the View menu and select the Page Layout option.


4.
Open the Insert menu and select the Frame option.


5.
Draw the frame in the margin by dragging with the mouse. Position and size it as you want.


6.
Click on the frame to position the insertion point inside it.


7.
Enter the text you want to appear in the margin inside the frame. You can also place graphics in the frame.
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Can I build a hypertext document?

My friends can create hypertext documents with WordPerfect for Windows. I cannot find anything about hypertext in the Word documentation. Is it possible?

Solution

You can create hypertext in Word by using a GOTOBUTTON field to create links within your text. To do so, follow these steps:


1.
Position the insertion point where you want to insert the button.


2.
Open the Insert menu and select the Field option.


3.
In the Field dialog box, select All in the Categories list box and GoToButton in the Field Names list box.


4.
In the Field Codes text box, add a destination after the field name. If the jump will be to a page, enter the page number in this format: p8. (This code causes a jump to page 8.) If you want to jump to a bookmark, type the name of the bookmark. Enter a space.


5.
Following the space, type the text for the button, for example, Go to Page 8.


6.
Click on OK.

The button will appear in your text as normal text. As a result, you might want to apply some font formatting or a border or shading to make it look like a button. When you double-click on the button, you jump to your destination.
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Can I put callouts into my document?

I would like to annotate my text with callouts. Is that possible in Word 95?

Solution


1.
Scroll to the page where you would like to place the callout.


2.
Click on the drawing button on the Standard toolbar.


3.
Click on the Callout button in the Drawing toolbar.


4.
With the mouse, drag away from the point in your text where you want the callout. When you release the button, the callout is created.


5.
Enter the text in the callout box.


6.
If you need to change the format of the callout, click on it and then click on the Format Callout button on the Drawing toolbar.


7.
In the Callout Defaults dialog box, select the format you desire and click on OK.
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How do I use the Spike while formatting a document?

When laying out a document, I often need to cut several items to the Clipboard and paste them together into a new location. I have heard that you can do this with the Spike in Word. What is the Spike and where do I find it?

Solution

The Spike is just like the Clipboard, except that it is internal to Word rather than universal to Windows. Using the Spike, you can cut multiple items from various places in a document and paste them together in the same location. To use the Spike, follow this procedure:


1.
Select the text or graphics to cut from the document.


2.
Press Ctrl+F3. Word cuts the selection and places it on the Spike.


3.
Repeat steps 1 and 2 for each item you want to cut.


4.
Locate the insertion point where the spiked material should be inserted.


5.
Press Ctrl+Shift+F3 to insert the material and clear the Spike.


6.
If you want to paste the material without clearing the Spike, type spike and click on the Insert AutoText button on the Standard toolbar. Word replaces the word spike with the spiked material.
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How can I keep from orphaning text at the bottom of a column?

Sometimes a heading or text that should head a column is left behind at the bottom of the previous column. How do I prevent this? 

Solution


1.
Place the insertion point at the beginning of the text that has been orphaned.


2.
Open the Insert menu and select the Break option.


3.
In the Break dialog box, click on the Column Break button.


4.
Click on OK. The inserted column break forces the text into the next column.
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Can I force text to stay in the same column?

Sometimes I need two paragraphs, or a paragraph and related graphics, to stay in the same column. Is there a way of keeping things together in a column?

Solution


1.
Select the items that need to stay together in the column.


2.
Open the Format menu and select the Paragraph option.


3.
Click on the Text Flow tab.


4.
Check the Keep with Next check box.


5.
Click on OK. The selected items will stay within the same column.
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How do I create special text effects in my document?

I would like to create special text effects in my documents to build a simple logo for my company. Is there a way to do this with Word?

Solution

WordArt is a text-effect applet included with Word 95. To access WordArt, follow these steps:


1.
Open the Insert menu and select the Object option.


2.
The Object dialog box opens. In the Object Type list box on the Create New tab, select Microsoft WordArt 2.0. Next, click on OK.

When WordArt opens, it displays its own menu and toolbar. Although all the effects you can create with WordArt can be accessed from the menu, the toolbar is easier and more convenient to use. WordArt also presents you with a dialog box, into which you enter the text for your special effects, and a representation of the text object embedded in your document.

To create a special text effect, enter your text in the Enter Your Text Here dialog box. If you need to insert a symbol not readily available from your keyboard, click on the Insert Symbol button to open the Insert Symbol dialog box. You can select any symbol available in your current font for insertion into your text. Just click on the symbol and then click on OK. If you need a symbol not in your current font, select a new font from the font drop-down list box described later in this section.

You can design your special effect by working with the controls on the WordArt toolbar. First, select a shape by opening the Shape drop-down list box. This action displays a grid of the preset shapes you can give to your text. Just click on the shape you want.

Next, select the font and size you want to use from the Font and Size drop-down list boxes. These controls work exactly the same as those offered by Word on the Formatting toolbar. You can also apply the character styles bold and italic using the Bold and Italic buttons.

The next few buttons apply special effects to your text. You have the following options:



The Even Height button causes all the characters in your text to be the same height, regardless of whether they are uppercase or lowercase.



The Flip button causes each character of your text to lie on its left side, so that the test reads vertically from bottom to top.



The Stretch button causes your characters to expand to fill the space allotted for your WordArt effect. To cancel the stretch effect, click on the button again.



The Align button opens a drop-down list of alignment options, most of which should be familiar from working with Word. The less familiar options include letter justify, stretch justify, and word justify. Letter justify increases the spaces between letters to justify a line. Stretch justify stretches the width of the characters to justify a line. Word justify increases the space between words to justify a line.



The Spacing Between Characters button enables you to adjust the spacing between characters to achieve a more readable effect. Experiment with the options offered by the button captions in the dialog box until you achieve the effect you desire.



The Rotation button opens the Special Effects dialog box. This dialog box contains two spin buttons that control the angle of rotation and the slider (slant from vertical) of the rotated effect. Experiment with the controls until you have the effect you want.



The Shading button gives you access to the Shading dialog box. This dialog box enables you to select various shading patterns and colors for your characters. Experiment with the controls until you have the effect you want.



The Shadow button opens a list box that offers you several choices of shadow for your characters. The MORE option allows you access to the Shadow dialog box, which gives you the additional option of selecting the color of the shadow.



The Border button opens the Border dialog box, which enables you to select the border width and the border color for the characters you use. (The border, in this case, is the one that snakes along the edge of each character). Widening the border of the character reduces the area of the shading pattern you might have applied to your text effect.

When you are finished creating your WordArt effect, click anywhere outside the WordArt dialog box to return to work on your document. This action closes WordArt and embeds the text effect in your document. You can relocate the text effect by dragging on its frame. The text effect can be resized by dragging on the sizing handles on its frame. Later, you can edit the text or text effect by double-clicking on it.
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How do I enter an equation into my document?

You need to include equations in your document to explain how you arrived at an analysis. How do you create an equation? Do you use a special font?

Solution


1.
Locate the insertion point where you want the equation to appear.


2.
To create an equation, use the Equation Editor, an OLE applet that inserts equations into a frame in your document. Open the Insert menu and select the Object option.


3.
On the Create New tab in the Object dialog box, select Microsoft Equation 2.0 in the Object Type list box and click on OK.


4.
The Equation Editor opens, inserts a frame at the insertion point's location, and presents a button bar. Click on the buttons on the button bar until you find the symbol you need on the menus that open. Select that symbol and Equation Editor inserts the symbol into the frame.


5.
Some symbols have small boxes attached to them. These are edit fields where you enter arguments, ranges, and other elements, associated with the symbol in the equation. Click on the box and type the information that should appear for the symbol you have selected.


6.
Click anywhere on your document outside the equation frame to close the equation editor. Double-click on the equation to return to editing it.
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How do I float a frame between columns?

In a two-column document, you want to center a box of special text straddling the gutter between the columns. How do you accomplish this effect?

Solution


1.
Click and drag on the Columns button on the Standard toolbar to set up your columns. Enter the text that belongs in the columns.


2.
Open the View menu and select the Page Layout option.


3.
Open the Insert menu and select the Frame option.


4.
Drag with the mouse to draw your frame.


5.
Position the frame and enter any special text. Apply any additional formats that you would like, such as borders or shading.
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How can I keep framed material in one place?

I need to have my illustrations at the bottom of the page where the related explanation appears. Yet, as I create and edit the document, changes to the document force the explanatory paragraphs onto different pages. Can I format the document to keep the illustration and the explanation on the same page, no matter what?

Solution


1.
When you write a paragraph that requires an illustration, open the Insert menu and select Frame. Click on the Yes button in the dialog box that asks if it is all right to enter page layout view.


2.
Draw the frame where the illustration should appear at the bottom of the page.


3.
Click on the Show/Hide paragraph button on the Standard toolbar and click on the frame.


4.
Find the anchor icon on the page. This icon is next to the paragraph to which the frame is anchored (normally the closest paragraph to the frame). As you edit the text and the paragraphs shift position, the frame remains anchored to whichever paragraph is the closest. As a result, the frame stays on the same page.


5.
Drag the anchor and drop it next to the explanatory paragraph, if the anchor is not already next to the explanatory paragraph.


6.
Double-click on the anchor.


7.
In the Frame dialog box, check the Lock Anchor check box. By checking this box, you keep the frame and the explanatory paragraph locked together. They always appear on the same page, and the frame always appears where you positioned it on the page.


8.
Either draw your illustration in the frame or insert graphics into the frame.
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How can I split the justification on one line?

I want the text on the left side of my page left-justified and the text on the right side of my page right-justified. Is there any way to accomplish split justification?

Solution

There are two solutions to this problem: tables, and blank tab leaders.

To solve the problem with tables: 


1.
Click on the Insert Table button on the Standard toolbar and drag to create a two-celled table.


2.
Click on the left cell, then click on the Align Left button on the Standard toolbar.


3.
Click on the right cell, then click on the Align Right button on the Standard toolbar.


4.
Enter the text in the table.

To solve the problem with tabs: 


1.
Insert a tab between the text you want to appear left-aligned and the text you want to appear right-aligned.


2.
Select the entire line of text.


3.
Choose Tabs from the Format menu.


4.
Create a right-aligned tab at your right margin (by default, 6".) Use No leader.


5.
Choose OK. Your left-aligned text should remain left-aligned, but your right-aligned text should now butt up against the right margin. If it does not, insert another tab between the left-aligned text and the text you want to right-align.

Chapter 5: Linking and Embedding Objects in Word

Object Linking and Embedding technology lets you easily accomplish complex tasks in Word. Even simple tasks, however, can be problematic. Although OLE performs functions that seem like magic, figuring out the steps to get there can sometimes be mystical. This chapter provides the following solutions to some common OLE mysteries:



How do I insert a graphic in a document?



How do I insert a database in my document?



What kinds of objects can I insert in a document?



When should I use a frame?



Can I embed commands in my document?
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How do I insert a graphic in a document?

I learned to use OLE by means of the clipboard and the application's Paste Special command. I have noticed, however, that Word seems to offer other options for linking and embedding graphics in a document. What are these options, and when should I use them?

Solution

Word 95 offers three methods for inserting graphics into documents. Which method you should use depends on your needs at the time you insert the graphic. For example, the most familiar method—copying the graphic to the clipboard and using Word's Paste Special command—works well when both Word and the graphics application are open, and when the graphic you want to insert is loaded in the graphics application. Under these circumstances, inserting a graphic is simple:


1.
In the graphics application, select the graphic and copy it to the clipboard using the Copy command on the application's Edit menu.


2.
In Word, locate the insertion point where you want the graphic to be inserted into the document.


3.
Open the Edit menu and select the Paste Special command.


4.
In the Paste Special dialog box, select the data format you want to use when you insert the graphic in the As list box.


5.
Choose the Paste option button to insert the graphic as an object. Choose the Paste Link option button to make a link with the source file maintained by the graphics application. If you create the link, the picture will change in your document when you change the source file. Note that some applications do not support both of these option buttons.


6.
Check the Display as Icon check box if you want the picture to display as an icon, which displays the picture in the source application's window when you double-click on it.


7.
Click on OK to insert the graphic in your document.

These steps allow you to insert a graphic efficiently, but they have a disadvantage. Word always saves a picture of the graphic in the document file if you create a link using this method. If you edit the link using the Links command on the Edit menu, you find that you cannot clear the Save Picture in Document check box. As a result, you cannot reduce the size of a document file, as described in How do I prevent an inserted graphic from increasing the file size? in Chapter 15, "Troubleshooting."

To reduce the file size, you must insert the graphic as a picture. To do so, follow these steps:


1.
Position the insertion point where you want to insert the graphic.


2.
Open the Insert menu and select the Picture option.


3.
After the Insert Picture dialog box opens, select the file from the File name combination box. You can use the controls in this dialog box to navigate folders exactly as you do in the familiar Open and Save As dialog boxes.


4.
Check the Preview Picture check box if you want the graphic you have selected to be displayed in the Preview box.


5.
Check the Link to File check box if you want to establish a link to the source file. If you check this box, check or clear the Save Picture in Document check box, depending on whether you want a copy of the graphic stored in the document as a picture. (Saving a copy of a linked graphic in the document increases the file size.)


6.
Click on OK to insert the graphic.

Solution

You can also insert a graphic by creating it as an object from its file. This method is useful when you have only the file from which to work, and not the original application. To use this method, follow these steps:


1.
Position the insertion point where you want to insert the graphic.


2.
Open the Insert menu and select the Object option.


3.
In the Object dialog box, click on the Create from File tab.


4.
Enter the complete file name, including Path, or click Browse to search for the file in the Browse dialog box, which resembles the File Open dialog box.


5.
Check the Link to File check box if you want to establish a link to the source file.


6.
Check the Display as Icon check box if you want the picture to display as an icon, which when double-clicked displays the picture in the source appplication's window.


7.
Click on OK to insert the graphic.

This method has the same disadvantage as the procedure that uses the Paste Special command. If you edit the link using the Links command on the Edit menu, you cannot clear the Save Picture in Document check box.
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How do I insert a database in my document?

I want to include a small database in my document. There are also times when I want to include the results of queries from larger databases. Is there an efficient way to import data from my database and include it in my document as a table?

Solution


1.
Open the Insert menu and select the Database option.


2.
In the Database dialog box, click on the Get Data button.


3.
Use the controls in the Open Data Source dialog box to select a database file. This dialog box works exactly like the Open dialog box.


4.
In the Confirm Data Source dialog box, select the data source you want in the list box and click on OK.


5.
A dialog box appears specific to your database, enabling you to select the tables and queries you want to use. Adjust these controls to select the data you desire, and click on OK.


6.
In the Database dialog box, click on the Query Options button to open the Query Options dialog box. Click on the Filter Records tab. Use the Field drop-down list boxes to choose the field in the database from which to select data (for example, Last Name). Use the Comparison drop-down list boxes to select the comparison method (for example, Equal To). In the Compare To text boxes, enter the values that serve as the criteria for comparison (for example, Smith). From the small drop-down list boxes to the left, you can select the logical means by which multiple comparisons are connected. Your choices are And and Or.


7.
Click on the Sort Records tab. Use the Sort By drop-down list boxes to select the primary field for the sort. Then select the Ascending or Descending option button to determine the sort order. If after sorting by the primary field you want to sort the data again by secondary fields, you can use the Then By drop-down list boxes to specify up to two additional fields. Data is sorted first by the primary field, and then by each secondary field in turn. (For example, by Last Name, then by First Name, then by Middle Initial to give you a completely alphabetized list of names.)


8.
Click on the Select Fields tab. By default, every field in the database is shown in the Selected Fields list box for inclusion in your document. You can remove any single field by clicking on it in the list and then clicking on the Remove button. (You can remove them all by clicking on the Remove All button.) Click on a field listed in the Fields in Data Source list box, then click on the Select button to add it to the Selected Fields list. (You can select all fields by clicking on the Select All button.)


9.
When you have finished selecting query options, click on OK in the Query Options dialog box.


10.
Click on the Table AutoFormat button to select the format of the table into which the data is inserted.


11.
In the Table AutoFormat dialog box, select a format in the Formats list box. An example of how the table will look appears in the Preview box. Adjust the formatting by checking and clearing the check boxes in the Formats to Apply group and the Apply Special Formats To group. When the Preview box shows you the table you want, click on OK.


12.
Click on the Insert Data button in the Database dialog box to insert the data.


13.
In the Insert Data dialog box, click on the All or From option buttons to select the entire data set or only a portion of it. If you select From, fill in the record numbers in the text boxes to represent the starting record and ending record to include. Check the Insert data as Field check box if you want to insert the data into a Word field. Click on OK to insert the data as a table in your document.
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What kinds of objects can I insert in a document?

I know that OLE technology allows me to treat almost any kind of data or file as an object. But there have to be practical limits. What kinds of objects can I insert into a document? Where can I find the commands that enable me to insert each kind of object?

Solution

The types of objects that you can insert into Word 95 documents depend on the software you have installed on your system. All Windows 95 and many Windows 3.1 software packages support OLE technology to a certain extent. Each registers the types of objects it enables in the registration database. To find out what objects are available to you, open the Insert menu and select Object option. The Create New tab in the Object dialog box provides a list of the available object types in the Object Type list box.

If you own Microsoft Office, you can expect to see and use the following object types:



Microsoft ClipArt Gallery



Microsoft Data Map



Microsoft Draw



Microsoft Equation 2.0



Microsoft Excel 5.0 Chart



Microsoft Excel 5.0 Worksheet



Microsoft Graph 5.0



Microsoft Note-It



Microsoft PowerPoint Presentation



Microsoft PowerPoint Slide



Microsoft Word Document



Microsoft WordArt 2.0



MS Organization Chart 2.0



WordPad Document

Each of these objects is supported by the application that creates it. The main applications—Word, Excel, and PowerPoint—you probably recognize. WordPad is the scaled-down word processor built into Windows 95. You may not recognize some of the lesser-known applications described in the following sections. By selecting their object types and clicking on OK in the Object dialog box, you can start the application that embeds the object.

Equation Editor 2.0 Equation

The Equation Editor opens a small window you can use to insert equations into a Word document. You select the mathematical symbols to be inserted by clicking on the Equation Editor's buttons. The equation is inserted inside a sizable frame. You can make it as large or as small as you want. You can position the equation by dragging its frame in the document.

Microsoft ClipArt Gallery

The ClipArt Gallery is an application that simplifies clipart picture insertion. ClipArt Gallery displays by category the graphics files included in the clipart collection that ships with Word. You can select a category and a picture, and insert that picture by clicking on OK. You can also use the ClipArt Gallery's Options button to add images of your own creation to the gallery.

MS Organization Chart 2.0

Organization Chart enables you to create and edit organization charts by using buttons to insert boxes and lines in your chart diagrams. You can fill in the names and titles in the appropriate boxes simply by clicking on them. Your chart is inserted the same way a picture is inserted into your document.

Microsoft WordArt 2.0

WordArt enables you to create special text effects to include in your documents. You can bend, squeeze, rotate, shadow, outline and otherwise change text using any TrueType font. You can resize the text effect you've created, by resizing the frame. Dragging the frame relocates the text effect.
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When should I use a frame?

Although I have noticed the Insert Frame button on the Drawing toolbar, I have inserted drawings in a document without a frame and experienced no problems. What is a frame? Are there any advantages to using one?

Solution

A frame appears as a box around the object it encloses and has special properties. The border of the box is a hash-lined border unlike any other border Word 95 uses, and is easily recognizable.

A frame's most important special property is the capability to wrap text around an object. If you want to insert a drawing, a text box, or an equation that partially fills a page and you want text to appear in the portion of the page the object does not fill, the frame enables you to do so. By default, the text-wrapping property is on; you can, however, turn it off in the Format Frame dialog box.

Another special property is the capability to be resized. Because of this property, you can set aside page regions to contain whatever objects you want—text, text effects, or graphics. You can adjust the size of this region at will by dragging on the frame's sizing handles.

The use of a frame is similar to creating a page within a page. You need to use a frame if you are defining a page region that is not controlled by Word's margin settings. Frames can float between columns, enabling text from both columns to wrap around either side. Frames can also be placed in the margin, enabling you to place text banners down the sides of your pages.

You may also find that if you do not create a frame, only the bottom edge of a picture may be visible in the document, depending on the line spacing settings you've chosen in Format, Paragraph. This problem does not occur if you do use frames.

To insert a frame, follow this procedure:


1.
If you want the frame to go around an existing object, select the object.


2.
Open the Insert menu and select the Frame option.


3.
If your document is not in page layout view, click on the Yes button in the dialog box that asks you if you want to switch to page layout view.


4.
If you are framing an object, the frame is inserted around the object. If you are just inserting the frame, create the frame by dragging the cross-hair cursor. When you release the mouse button, the frame is inserted.

A blank frame may not seem useful. If you click on the frame, however, the insertion point moves into the frame. You can then insert objects into the frame, or text into the page region defined by the frame. If you insert text, the frame serves as the text's margin boundaries.

To adjust the characteristics of a frame, select the frame, open the Format menu, and select the Frame option. The Format Frame dialog box appears. Use the controls in this dialog box to set the text-wrapping property, the exact dimensions of the frame, and the exact position of the frame on the page.
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Can I embed commands in my document?

What if you want to distribute to other users a set of commands for performing an action, such as installing a set of custom templates? If the commands were embedded in a document file, distribution would be easy. Users could then open the document, read about what the commands do, and how to execute them, and double-click on icons to carry out the commands. By embedding commands in a document, you could distribute the commands by mail, even if your mail system is not OLE-compliant.

Solution


1.
Create a new document or open an existing document.


2.
Locate the insertion point where you want the command icon to appear.


3.
Open the Insert menu and select the Object option.


4.
Select Package in the Object Type dialog box and click on OK. The Object Packager application starts.


5.
Open the Object Packager's Edit menu and select Command Line.


6.
The Command Line dialog box opens. Enter the command line in the Command text box, including the full path to the application (or executable file for the command) and any switches. Click on OK.


7.
Click on the Insert Icon button in the Object Packager.


8.
Enter the path to the executable file, but not the switches, in the Insert Icon dialog box's File name text box. Click on OK. (If no icon is available for the command file, Packager will allow you to choose from among a series of existing icons.)


9.
Open the Object Packager's File menu and select the Update option. This action embeds the command and its icon in the mail message.


10.
Open the Object Packager's File menu and select the Exit option.


11.
Instruct users to double-click on the icon when they receive the document. The command you have embedded will run.
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How do I create an object from a file?

Many times I have already created information I want to embed as an object in Word and saved the information as a file using another application. I have an Excel spreadsheet, for example. I know where its file is, and would prefer not to consume memory by opening Excel to create the object in Word by cutting and pasting from Excel. When I am really busy, I have five applications open, and opening a sixth just slows down the process of creating the object in Word immeasurably. Can I build the Excel object in Word from the file created by Excel without opening Excel to cut and paste?

Solution


1.
Position the insertion point where you want to insert the object.


2.
Open the Insert menu and select the Object option.


3.
In the Object dialog box, click on the Create from File tab.


4.
Enter the complete file name, including Path, or click Browse to search for the file in the Browse dialog box, which resembles the File Open dialog box.


5.
Check the Link to File check box if you want to establish a link to the source file.


6.
Check the Display as Icon check box if you want the object to display as an icon that, when double-clicked, displays the picture in the source application's window.


7.
Click on OK to insert the graphic.

Chapter 6: Working with Tables

Tables are convenient for storing data, but Word 95's table features also allow tables to function like spreadsheets. Word's tables are able to perform many of the same actions as a full-blown spreadsheet. This chapter gives solutions for the following frequently asked questions:



Can I sort the information in a table?



How do I insert a formula in a table cell?



Can I number the cells of a table?



Inserting tables is easy using the Insert Table button. Why do I need a Table Wizard?



Can I exchange data between a table and Excel?



Can I create a graph from a table?



Can I center a table?



Can I use a table as a database?



Can I put a border around a cell's contents?
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Can I sort the information in a table?

When you build tables in Word, you often need to enter information that has to be sorted, although you may not receive the information in sorted fashion. You may receive customer contact information, for example, in the form of mail-in reply cards. Perhaps you want this information to appear in a Word table sorted alphabetically. Sorting the cards by hand prior to data entry is a slow process. As you receive additional cards, you not only have to sort them by hand prior to entering the information, but you also have to integrate new information into the existing table alphabetically. It is more convenient to apply an automated sort to the table after the data is entered.

Solution


1.
Create your table and enter the data as you want.


2.
Place the insertion point inside the table.


3.
Open the Table menu and select the Sort option.


4.
In the Sort dialog box, use the drop-down list box in the Sort By group to select the column number, field number, paragraph, or name that represents the item to sort by. The Sort By item is the item you would scan for if you were sorting cards of data by hand. For instance, if you needed to sort twenty 3x5 cards with addresses on them by last name, you would be sorting by last name. If you wanted to do the same in a table containing names and addresses, you would sort by the column containing the last name.


5.
In the Sort By group, use the Type drop-down list box to indicate whether the items to be sorted are text, numbers, or dates.


6.
In the Sort By group, use the Ascending and Descending option buttons to specify the direction of the sort.


7.
Use the controls in the Then By groups to specify up to two additional sorting criteria. These criteria are similar to those you use when manually sorting cards containing addresses by ZIP code and then by last name. In this example, ZIP code is the equivalent of the Sort By criterion. Last name is a Then By criterion.


8.
Use the option buttons in the My List Has group to indicate whether the table has a Header Row or No Header Row. The header row is a row of titles for the columns in the table. Specify Header Row to prevent the titles of the columns from being sorted into the data contained in the table. Specify No Header Row only if there is no header row. Otherwise the first row of data will not be sorted, because Word thinks it is the header row.


9.
Click on the Options button.


10.
In the Sort Options dialog box, use the check boxes in the Sort Options group to determine whether the sort is Case Sensitive and whether to Sort Column Only. You can sort the contents of a single column only if you have selected it before opening the Sort dialog box.


11.
Click on OK in the Sort Options dialog box. Then click on OK in the Sort dialog box. Word sorts the table according to the criteria you have defined.
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How do I insert a formula in a table cell?

Occasionally, you may need to create a small spreadsheet in a Word document but do not want to hassle with starting a spreadsheet program and importing a worksheet. All you may need are just a few rows and columns for financial data in a table that would be summed automatically. You can insert simple formulas into Word table cells so they behave just like spreadsheets.

Solution


1.
Create the table and fill in the data you want to include.


2.
Place the insertion point in a cell where you want to insert a formula.


3.
Select Table, Formula.


4.
If all you want to do is add the numbers in the cells directly above your current cell, simply press Enter; Word enters the formula and displays the results.



If you want to insert a different formula, either type the formula you want to use in the Formula text box or select a spreadsheet-style function from the Paste Function drop-down list box. When referring to cells in the table that are a part of your calculation, use the column letter and row number designation (a1, b2, and so on). The leftmost column is column A and the uppermost row is row 1.


5.
Click on the Help button for an explanation of the arguments for any function or an explanation of the mathematical operators you can use in the formula.


6.
When your formula is complete, click on OK.
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Can I number the cells of a table?

When presenting data in tabular format, numbered cells make locating data much more convenient. When you refer to the value in cell 23, for example, your audience can see exactly where you are referring on its copies or in your projected slide.

Solution


1.
Create your table and enter the data.


2.
Use the mouse to select the cells to be numbered.


3.
On the Formatting toolbar, click on the Numbering button.


4.
In the Table Numbering dialog box, select either the Number Across Rows or Number Down Columns option button. These option buttons determine the direction in which the numbers increase.


5.
Check the Number Each Cell Only Once box if your table cells contain more than one paragraph and you do not want each paragraph numbered separately. By default, Word adds a number to each paragraph in the cell and continues the paragraph number sequence across the cells you have indicated. As a result, three cells containing a total of five paragraphs would show a number before each paragraph. The numbers would be 1, 2, 3, 4, and 5. The first cell might contain paragraphs 1 and 2, the second cell paragraph 3, and the third cell paragraphs 4 and 5. Checking this check box causes, by contrast, each cell to contain a number, 1, 2, or 3 in sequence.


6.
Click on OK to number the cells you have indicated.

Keep in mind that if you try to add consecutive numbering to cells containing numeric data, Word will replace your numeric data with consecutive numbering. Instead, add an empty row or column for the consecutive numbering, select that row or column, and click the Numbering button to add the numbering there.

Alternate Solutions

You can number a single cell by placing the insertion point in the cell and clicking on the Numbering button on the Formatting toolbar.

You can exercise greater control over the types of numbers used (Arabic, Roman, Letters), the font used for numbering, and the paragraph style used in the numbered list if you open the Format menu and select the Bullets and Numbering option. Select the Numbered tab when the Bullets and Numbering dialog box appears. Select from the predefined styles in the preview boxes or click on the Modify button to customize your numbering scheme.

Return to Table of Contents
Problem

Inserting tables is easy enough using the Insert Table button. Why do I need a Table Wizard?

While inserting tables is easy, creating complex tables with lots of formatting, labels, and shading can be tedious. Word provides the Table Wizard as a means of automating and speeding the task of creating such complex tables. The Table Wizard contains predefined formats for common types of complex tables, and can easily build the tables according to the parameters you select. Keep in mind that each type of table built by the Table Wizard presents slightly different options on each screen of the Wizard.

Solution


1.
Place the insertion point where you want the table to appear in your document.


2.
Open the Table menu.


3.
Select the Insert Table item.


4.
Click on the Wizard button to start the initial Table Wizard screen.


5.
Select the table format from the six presented, using the option buttons. Click on the Next button to move to the next screen.


6.
Use the drop-down list box to set the number of columns. Click on the Next button to move to the next screen.


7.
Use the option buttons to set the type of column headings you want. Click on the Next button to move to the next screen.


8.
Use the option buttons to set the type of row headings you want. Click on the Next button to move to the next screen.


9.
Use the option buttons to indicate the contents of the cells. Click on the Next button to move to the next screen.


10.
Use the option buttons to select the printing orientation for the table. Click on the Next button to move to the next screen.


11.
Click on the Finish button.


12.
After the Table AutoFormat dialog box appears, select one of the predefined formats in the Formats list box. (The Preview box shows you what each table format looks like.)


13.
Use the check boxes in the Formats to Apply group to select whether to use Borders, Shading, Fonts, Colors, or any combination of these. (You can experiment with different combinations of features and view the results in the Preview box.)


14.
Use the check boxes in the Apply Special Formats To group to select whether the formats you chose in step 13 are applied to Heading Rows, First Column, Last Row, Last Column, or any combination of these. (You can experiment with different combinations of these features and view the results in the Preview box.)


15.
Click on OK to accept the AutoFormat you have chosen. The Wizard then inserts your table into the document.
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Can I exchange data between a table and Excel?

With Word's new capability to include formulae in table cells, I can build small spreadsheets in Word. Can I move this table easily to an Excel worksheet?

Solution

Actually, when you import an Excel worksheet into Word, Word converts the Excel worksheet into a Word table. When you import a Word table into Excel, Excel converts the Word table into an Excel worksheet. What you want to have happen is happening without your knowing it. You should have no trouble exchanging data between Word tables and Excel. You may not be able to copy styles between the two applications, however.
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Can I create a graph from a table?

If Word tables contain spreadsheet capabilities, is it possible to create a graph from a Word table?

Solution


1.
Select the cells you want to chart.


2.
Choose Object from the Insert menu. Choose Microsoft Graph 5.0 and OK.


3.
The Chart Wizard opens. Select a chart type, and choose Next.


4.
Select a format for the type of chart you've chosen, and choose Next.


5.
Set the specifications for the chart you want to create, and choose Next.


6.
Add a legend and titles for the X, Y, and/or Z axes. Choose Finish.


7.
The chart appears in your document, beneath the table cells you selected.

Note that the Insert Chart button formerly appeared on the Standard toolbar in Word 6, but no longer does. It does, however, appear in the Word for Windows 2 toolbar that can be displayed through View, Toolbars. If you create lots of charts in Word, and don't want to bother selecting Microsoft Graph through Insert, Object, you may want to copy the button back onto the Standard toolbar using Word's customization features.

Return to Table of Contents
Problem

Can I center a table?

Tables always extend to the left margin. Can a table be centered on the page?

Solution


1.
Select the table to be centered.


2.
Open the Table menu and select the Cell Height and Width option.


3.
Select the Row tab in the Cell Height and Width dialog box.


4.
Click on the Center option button.


5.
Click on the OK button.
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Can I use a table as a database?

If Word tables have spreadsheet capabilities, can they also function as databases? Being able to include a small database in a document could be extremely useful. For example, you could store client records within a Word document, and not have to take a database or spreadsheet with you on your notebook computer.

Word allows you to simplify data entry by placing a simple graphical front-end onto a table. The information you enter is still stored in the table itself, where it can appear in your document or be used as a data source for mail merge.

Solution

To do data entry in a Word table using a graphical front-end: 


1.
Place the insertion point within the table.


2.
Open the View menu and select the Toolbars option.


3.
Check the check box next to Database in the Toolbars list box.


4.
Click on the OK button.


5.
Click on the Data Form button on the Database toolbar.


6.
In the Data Form dialog box, enter the information for each row in the table into the text boxes provided. Click on the Add New button to add the row to the table. When you are finished adding data, click on the OK button.
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Can I put a border around a cell's contents?

Data in my table needs to be highlighted in several different ways. Shading a cell is no difficulty. But can I put a border around the data in a cell without putting a border around the cell itself?

Solution


1.
Select the text in the cell, but do not select the end-of-cell mark.


2.
Open the Format menu and select the Borders and Shading option.


3.
Click on the Borders tab, if necessary.


4.
Use the controls on the Borders tab to select the border you want.


5.
Click on the OK button. The border appears around the data only.

Chapter 7: Using Document Templates

Document templates are the blueprints for Word documents. They are easy to use, and you can accomplish many tasks with them quickly. Many Word users never explore the power document templates offer because they do not know what questions to ask. The solutions in this chapter address these questions:



How do I work with templates other than NORMAL.DOT?



Can I use global templates?



Can I use Word 2.0 templates?



Can I change my Word default folders?



Can I make an envelope template?



Can Word automatically open a document based on a template other than NORMAL.DOT on startup?



How does Word resolve conflicts between active templates?
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How do I work with templates other than NORMAL.DOT?

Every Word document is based on a template—a DOT file that contains any boilerplate text and formatting that will be used in all documents of its kind. Templates may also include styles, AutoText entries, macros, special toolbars, menus and menu items.

By default, Word uses the template Normal (NORMAL.DOT) when you create a new document, unless you tell it otherwise by specifying another template in the New dialog box that appears when you create a new file. When Word is first installed, NORMAL.DOT contains more than 70 basic document styles, but no text, text formatting, macros, or AutoText entries.

You can add styles, macros or AutoText entries to NORMAL.DOT, in which case they will be available to all the documents you create. In some cases, however, you'll want a style, macro, or AutoText entry to only be available to some of your documents. For example, you may have a sizable AutoText entry that includes your company's terms and conditions for doing business. You know you'll only use this AutoText entry when you're creating proposal documents. If you place it in NORMAL.DOT, however, it will load this text into memory along with the rest of NORMAL.DOT's contents every time you run Word. This can slow down Word.

More often, perhaps, you'll want to create a new template simply to include the text, formatting and styles for a specific type of document. For example, you may have a specific table layout you always use for purchase orders; you don't want to re-create that layout every time you create a new purchase order.

Solution


1.
Choose File, New.


2.
The New dialog box opens. To open a new file using the Normal template, just press Enter. To open a file using a different template, click the tab showing the category you want. Available categories are Memos; Reports; Other Documents (including agendas, awards, calendars, invoices, resumes, purchase orders, tables, and timesheets); Letters and Faxes; and Publications.


3.
Choose the template you want and choose OK. 

Note that most of Word 95's templates are organized into three graphical approaches: elegant, contemporary and professional. If you always use the same graphical approach regardless of the type of document you're creating, all your documents will fit together graphically.

To create a new template: 


1.
Choose File, New. The New dialog box opens.


2.
Select the template you want to base your new template on, as described in the previous procedure.


3.
Click the Template radio button.


4.
Choose OK.
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Can I use global templates?

When Word starts, it makes one document template—NORMAL.DOT— available to you on a global basis. Any  macro, style, or AutoText entry stored in NORMAL.DOT is available for you to use in any document.

However, if you have created other templates, you may need access to these items stored in these templates on a global basis. For example, suppose you will be working on a major market research project involving several kinds of documents, each with its own template. These documents are all related, so they will all use the same AutoText entries, custom menu items and toolbars, and common styles. You've stored these common elements in a template, and you want that template to be available from any of the documents you will be creating.

Word allows you to load as many templates as you desire as global templates, making their macros, styles, AutoText entries, custom menu items, and toolbars available to all documents. To load a template as global, use the Templates and Add-ins dialog box.

Solution


1.
Open the File menu and select the Templates item. Note that any global templates or add-ins that are currently loaded will appear checked in the Global Templates and Add-ins box.


2.
In the Global Templates and Add-ins dialog box, click on the Add button. The Add Template dialog box will appear, with the \Office95\Templates folder open. (A different default folder will open if you installed Word without the rest of Microsoft Office.) This is the default folder where Word stores all of its templates. In general, the template you want will be here. If so, select the template from the File name list, and choose OK.


3.
If the template you want is located elsewhere, use the dialog box controls to find the template you want. The Add Template dialog box works much like the File Open dialog box. 


4.
After you have selected the template you want to add globally, click on OK in the Add template dialog box. Afterward, click on OK in the Templates and Add-ins dialog box.

After you load a template as global, its macros, styles, toolbars, custom menu items and AutoText entries are available to any document you modify. They remain available until the end of your Word session. When you restart Word, you can reload any template you have previously loaded as global by opening the Templates and Add-ins dialog box and checking the check box next to the template's name in the Global Templates and Add-ins list box. When you click on OK to close the dialog box, the template is reloaded.

While you are working, you can conserve memory by making sure that only the global templates you need are loaded. You load and unload templates by checking or clearing the check box next to the template's name in the Global Templates and Add-ins list box. When you click on OK to close the Templates and Add-ins list box, Word loads and unloads the templates you designated. If you need to remove a template from the list, click on the Remove button.

If you want to load a template as global each time you start Word, copy its file to the Word startup folder (usually C:\WINWORD\STARTUP). You can check for its location by opening the Tools menu, selecting the Options item, and clicking on the File Locations tab. Be sure not to move the template to the startup folder. If you do, the template becomes unavailable in the New dialog box. You need copies of the template in both the STARTUP and TEMPLATE folders.
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Can I use Word 2.0 templates?

If you are moving directly from Word 2.0 to Word 95, most of the templates you created for use with Word 2.0 will automatically convert for use with Word 95. What changes will you have to make? 

Solution

You may have to edit some macros by hand to:



Change the way you check for paragraph marks



Change the way you access startup options



Correct for more specific error messages in Word 95



Change the names of variables, subroutines, and user-defined functions that became reserved in Word 6 and remain so in Word 95



Change the assumptions about limits in Word 2.0 that have changed in Word 95, such as maximum number of open documents, limited to 9 in Word 2, but now limited only by your available memory



Update the layout of your dialog boxes to be more consistent with Word 95 conventions



Take advantage of smart cutting and pasting and other features that were not present in Word 2



Verify that any keystrokes sent to a dialog box or application are still correct; many Word 2 controls were moved to new dialog boxes in Word 6, and remain in their new locations in Word 95



Verify that any command prefixed with WW2_ still functions correctly

Converting Word 1.x macros is a two-step process; first, open them in Word 2.0 and save them as Word 2.0 macros; then open them in Word 95 and save them as Word 95 macros. This assumes, of course, that each version of Word is still available to you. Several Word 1.x templates are obsolete and should not be used; in most cases, these templates have been replaced with new templates or more sophisticated features. Unusable Word 1.x templates include: DATADOC.DOT, ENVELOPE.DOT, LBL15COT.DOT, LBL1COLT.DOT, LBL2COL.DOT, LBL2COLT.DOT, LBL3COL.DOT, LBL3COLT.DOT, LETTER.DOT, and MEMO.DOT. 0.

Some Word 2 templates present similar issues. In many cases, you can simply open a Word 2 template in Word 95 and save it as a Word 95 template (first confirming that you want to overwrite it, and confirming that you want to save an old version with the. OLD extension). In a few cases—such as DATAFILE.DOT, which has been replaced by the Word 95 Mail Merge Helper—you should avoid using Word 2 templates in Word 95. Similarly, four Word 2.0 letter templates, LETBLOCK.DOT, LETMDSEM.DOT, LETMODBK.DOT, and LETPERSN.DOT have been replaced by Word 95's Letter Wizard.

Solution

If your Word 2 templates have custom styles, glossary entries or macros you want to preserve, you'll instead need to work through Word's Organizer:


1.
Choose Templates from the File Menu.


2.
Choose Organizer. The Organizer dialog box opens. Notice there are four tabs: Styles, AutoText, Toolbars and Macros. These are the four categories of elements you can copy between templates. Click the Macros tab to display only macros.


3.
On the left side of the window, Organizer will display all the macros available in your current template. Since the current template probably isn't the one you want to copy from, choose Close File.


4.
Choose Open File. The Open dialog box will appear, listing all DOT (template) files in your current folder. Use the dialog box controls for selecting the folder containing the Word 95 templates you've just downloaded. 


5.
Next, open the corresponding Word 2 template that contains the customized styles, AutoText entries, toolbars, and macros you still need. To do so, click on the Open File button appearing on the right side of the Organizer dialog box; then select the Word 2 template with the same name as the Word 95 template you've already opened. (As in Step D, the Open dialog box appears; select the right drive or folder, choose the template and click on OK.) 


6.
In the left-hand list box, select the entire list of macros. You can select the entire list at once by clicking on the top item, pressing Shift and clicking on the last item.


7.
Choose Copy. Word will display the message "Do you wish to overwrite the existing macro." Choose Yes or Yes to All.



You have now updated a template provided with Word 2 so that it will work under Word 95. Repeat the process with the remaining templates you've also downloaded.


8.
If the updated templates are not in the folder Word 95 is using to store templates, use the cut, paste and copy commands built into the File Open and File Save As dialog boxes to move them there, so that they will be available alongside all your other templates.
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Can I change my Word default folders?

When you install Word, it establishes specific default folders where it will store different kinds of files. For example, by default Word stores documents in the \My Documents folder, and stores your templates in the \Office95\Templates or \Winword\Templates folder. You can change some of these defaults during Setup; you can change any of these defaults afterward.

For example, you may want to create a new Document folder, perhaps by clicking the Create New Folder button in the File, Save As dialog box; and then establish that as the default location for your documents. Your default document folder is the one Word displays whenever you ask to open or save a file. You may also want to change the document default folder at various times. For example, if you will be working on a major project for the next few weeks, you may want to store all project-related files in a separate folder, and make that your default document folder.

You might also want to change other default folders. For example, if you have set Word to create backup files automatically, you might want to store them on a separate disk from the originals—either another hard disk or a floppy. (Then, if your primary disk crashes, you'll still have working backups.) Or, you might want to store all your clip art from every program in the same folder, instead of using \Office95\Clipart for your Word clip art, and other folders for the clip art provided by other programs. (Of course, if you change the default location of files you will need later, such as templates, make sure to move the files you need to the new folders you've designated.)

Solution

To change any default file location:


1.
Open the Tools menu and select the Options item.


2.
Select the File Locations tab in the Options dialog box. The File Types list box provides the list of folders Word uses and the types of files that go in them. If no folder is listed next to a file type, Word is not currently using a folder to store that type of file.


3.
To change the name of a folder that Word uses, select the file type item in the File Types list box and click on the Modify button.


4.
Use the dialog box controls in the Modify Location dialog box to select a new folder location. These controls work like those in the familiar Open or Save As dialog boxes. As mentioned earlier, if you are currently connected to a network, the Drives list will include network drives. If you are not connected to a network, but you want to use a network drive location as your default folder, choose Network Neighborhood, and follow your normal sign-on procedure. Once you do, your network drives will be available.


5.
To create a new folder, click on the Create New Folder button. Enter the folder name in the New Folder dialog box and click on OK. 


6.
When you are finished changing folder names, click on the Close button in the Options dialog box.


7.
If necessary, make sure you move the appropriate Word files to the new folders.


8.
Exit and restart Word to take advantage of the modifications you have made. Your changes are saved in the Windows 95 registry; Word learns your default file locations by reading the registry at startup.
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Can I make an envelope template?

You can use Word's envelope features to add an envelope to a document, or to define your own document template for envelopes. With your own template, you can print envelopes independently of other documents, simply by creating a new document based on the template. You may want to create several different types of templates; one for standard correspondence and one for business reply mail; or one for each size of envelope you use; or one for business correspondence and another for personal correspondence.

Solution


1.
Open the File menu, select the New command, select Normal as the template, and click on OK to create a new document.


2.
Open the Tools menu and select Envelopes and Labels item. This opens the Envelopes and Labels dialog box, which includes all of Word's controls for creating both envelopes and labels.


3.
Select the Envelopes tab.


4.
Use the controls on the Envelopes tab, including the Options button, to define the appearance of the envelope. For example, enter the return address you want to appear on all the envelopes that use the template you are creating. Choose Options to specify both Envelope Options and Printing Options.



In the Envelope Options tab, start by selecting an envelope size from the Envelope Size list box. Word's default setting is the standard #10 business envelope, but you can also choose several other standard American and European envelope sizes, or create a custom size by choosing the Custom Size list and specifying Width and Height in the Envelope Size dialog box. Most standard envelope sizes are built into Word; you'll probably use Custom Size only when you're working with envelopes, such as for custom direct mailings or wedding invitations.



Still within the Envelope Options tab, you can specify a Delivery Point Bar Code or a FIM-A Courtesy Reply Mail code or both. Delivery Point Bar Codes, also known as POSTNET codes, are ZIP Codes translated into bar code language that the U.S. Postal Service's computers can read. FIM-A Marks are most commonly used on Business Reply Mail. Notice that you can't specify a FIM-A code unless you also specify a Delivery Point bar code.



(If you are doing a large mailing, using POSTNET bar codes can qualify you for a postage discount. You may, however, have to pre-certify that your mailing list contains accurate addresses through the Postal Service's CASS (Coding Accuracy Support System) program. Call 1-800-238-3150 for more information.) 



Still in the Envelope Options window, you can specify the exact location on your envelope where the Delivery Address and Return Address will print, and their font sizes, styles and attributes. When you're finished with Envelope Options, choose OK.



You may need to use the Printing Options tab to specify an alternate envelope tray on your printer, or on very rare occasions, a different feed method. Choose OK when you're finished with the Printing Options tab.


5.
Click on the Add to Document button. Word will create a separate section at the front of your document, consisting of Page 0, and include your return address (and delivery address, if you've added one.) 


6.
Open the File menu and select the Save As option.


7.
In the Save As dialog box, type a name for the template in the File name text box. If you plan to create several different envelope templates, name them consistently so they appear next to each other in the New box. For example, ENV10.DOT for a template that creates #10 envelopes and ENV11.DOT for a template that creates #11 envelopes. Then, select Document Template in the Save as Type drop-down list box. Notice that Word changes to the TEMPLATE folder (or whatever folder you've selected as your default location for templates). Click on OK.

To use the envelope template you've created: 


1.
Choose New from the File menu.


2.
Choose your envelope template name from the New dialog box, and choose OK. A new document will open based on the envelope name you've chosen. If you've included a standard return address in your envelope, it will appear in the envelope section of your document in page 0.


3.
Choose Envelopes and Labels from the Tools menu. Choose the Envelopes tab if it hasn't already opened.


4.
Enter the addressee's name and address in the Delivery Address box.


5.
Choose Print.


6.
You will be prompted to insert an envelope in your printer's manual feeder. Do so, and choose OK. (If the message to insert an envelope does not appear within Word, double-click on the printer icon in the taskbar; it may be visible in the Printer window.) 



Notice that if you follow this procedure, the delivery address will not be included in your document; it will simply be printed. If you want to print another envelope with the same return address, you can simply reopen the Envelopes and Labels dialog box, enter a new delivery address and print again. If you want to save an envelope containing a specific delivery address, enter the address, choose Change Document, and then save the document. You can then print the envelope in one of two ways: 


A.
Reopen the Envelopes and Labels dialog box, and choose Print in the envelopes tab.


B.
Choose Print from the File menu, specify page 0, and choose OK.
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Can I open a document based on a template other than NORMAL.DOT on startupWord automatically open a document based on a template other than NORMAL.DOT on startup?

Let's say you're setting up Word for someone who is primarily responsible for generating a specific kind of document, such as a memo or form. How you can you get Word to automatically open a document based on the memo or form, without changing the Normal template? 

Solution

Word 95 has a new switch, /t, which can be used to load Word with a different template. In the following example, you create and use a shortcut icon that loads Word 95 with the template Macros7.dot, which is stored in Word's Macros folder and includes several useful macros. (You might create a template that opens a specific kind of form or document, and use that instead.)  


1.
Locate and select the original Word program file (probably \Office95\Winword\Winword.exe or \Winword\Winword.exe). 


2.
Right-click on the file to display the pop-up menu, and choose Create Shortcut. 


3.
A new shortcut appears in the same folder: Shortcut to Microsoft Word. Click in the name and edit it as you wish. 


4.
Right-click on the new shortcut and select Properties from the pop-up menu. 


5.
Choose the Shortcut tab. 


6.
In the Target box, add the switch you want, after the path and file name that is already there. In this example, add /t d:\office95\winword\macros\macros7.dot 


7.
Choose OK. 


8.
Double-click the new icon to load Word using the 
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How does Word resolve conflicts between active templates?

If several document templates are loaded and Word finds a conflict between two commands, how is the conflict resolved? I have occasionally received unpredictable results when executing a command, only to discover I was using the wrong version of a command.

Solution

If you base a document on a template other than NORMAL.DOT, you have at least two templates loaded while you are working. If you load additional templates as global templates, you might have several templates available. Some macros and commands in this set of templates might have the same name. When Word encounters this problem, it follows these rules to resolve the conflict:


1.
Use the command stored in the template attached to the active document.


2.
Use the command stored in NORMAL.DOT.


3.
Use the commands stored in additional global templates, in alphabetical order by template name.

Word applies these rules sequentially. If rule 1 fails to produce results, Word applies rule 2. If rule 2 fails, Word applies rule 3, using each global template successively in alphabetical order.

When you decide where to store your macros and what to name them, you should keep these rules in mind. The template attached to the document should contain macros unique to that type of document. You may not want to clutter NORMAL.DOT with lots of global macros that you have created for yourself, but you should store such macros in a document template whose name begins with the letter A. In this way, you can make certain that Word will find and use your global macros before it locates special purpose macros stored in other templates.

Chapter 8: Working with Master Documents

Master documents are designed to simplify work with long documents and to facilitate sharing a document on which several people are working. Master documents are still relatively new, so you may not know how to use them. Don’t work with Master Documents. Up through Word 2000 this feature is so buggy that it will destroy your work at exactly the wrong time. The solutions in this chapter address the following common questions:



How do I use master documents to manage long files?



How do I share a master document with coworkers?



How do I make a table of contents and index for a master document?



Can I move or rename a subdocument?



Can I split a subdocument into two subdocuments?



Can I merge several subdocuments into a single subdocument?



How do I make a subdocument part of the master document?



How do I get rid of errors in the index, table of contents, and cross-references I created?



How do I avoid losing formatting in my subdocuments when I view the entire master document?



Are there any problems with or limitations on master documents that I should know about?
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Warning!

Master Documents feature has been reported to irretrievably destroy documents in Word 95 – Word 2002. Use at your own risk!
See Master Document Feature in Microsoft Word for more on this as well as any updated information of whether it has been fixed.
Problem

How do I use master documents to manage long files?

Warning: See updated information before proceeding.  Word enables you to build master documents to help manage long files. Think of a master document as an outline, each heading of which represents a document. The document represented by each heading is called a subdocument, and Word maintains a unique file name for it. When you work with a master document, you see the overall structure of the document as an outline. When you open a heading, you open the subdocument represented by that heading and work with it as you would any other document.

You can open subdocument files independently of the master document and work on them exactly as if they were regular documents—with one exception. You cannot change the name of the file. If you do, you break the link with the master document. You can reintegrate the file into the master document by renaming it or merging, but these extra steps are unnecessary if you leave the file name alone.

When a long document is organized as a master document, various people can open and work on different subdocuments simultaneously. Master documents allow the same master copy to be shared much more easily. If the part you create and maintain is always separate (as a subdocument) from the rest of the master file, you can work on your section while others work on their sections.

Master documents also save time by allowing you to load only a portion of the entire document. Scrolling from beginning to end is faster. Editing is faster. You can reorganize sections of the master document simply by reordering the headings that represent the subdocuments. Master documents both simplify and speed work on large documents, especially those that are collaborative projects.

Solution

Creating a new master document

Warning: See updated information before proceeding. To work with master documents, you must master seven basic procedures. First, you must be able to create a new master document. To do so, follow these steps:


1.
Create a new Word document.


2.
Choose View, Master Document.


3.
Write an outline for the master document using Word's outlining features.


4.
Select the headings that represent the subdocuments.


5.
Click on the Create Subdocument button on the master document toolbar.


6.
Use the Save As option on the File menu to save the master document. Use any file name you want. You do not need a special name.

Creating a master document from an existing document

Warning: See updated information before proceeding. There will be times, however, when you want to convert an existing document into a master document. To do so:


1.
Open the document you want to convert.


2.
Choose View, Master Document.


3.
Select any text you want to become an outline heading in the master document and use the buttons on the Outlining toolbar to promote or demote it to the proper level.


4.
Select a heading and the text related to it that you want to make into a subdocument.


5.
Click on the Create Subdocument button on the master document toolbar to convert the heading and text into a subdocument. Word places a box around the newly created subdocument.


6.
Repeat step 5 until you have created all the subdocuments you need.


7.
Use the Save As option on the File menu to save the master document. Use any file name you want. You do not need a special name.

Creating new subdocuments

Warning: See updated information before proceeding. As you work with a master document, you will of course need to create new subdocuments. Use this procedure:


1.
Select the outline heading that you intend to represent the subdocument, or the outline heading and text that you intend to become the subdocument.


2.
Click on the Create Subdocument button on the master document toolbar.

Opening subdocuments from master document view

Warning: See updated information before proceeding. Once you have created a master document with subdocuments, you need to open subdocuments from within the master document. Remember, you can view your master document as a single document by selecting Normal from the View menu. You can also view your master document as a master document with subdocuments by selecting Master document from the View menu. One way to see all your subdocuments at once is to switch to normal document view. When you are working in master document view, however, use this procedure to open and view a subdocument:


1.
Open the master document.


2.
Switch to master document view, if necessary.


3.
Double-click on the subdocument icon for the subdocument you want to open. Word opens a document window for the subdocument. You can close the master document if you want, and you should do so in case a coworker needs to use it.


4.
Edit the subdocument in its document window.


5.
When you are finished editing, close and save the subdocument as you would any other document.

Creating subdocuments from existing Word files

Warning: See updated information before proceeding. On occasion, you might want to insert an existing Word document into an existing master document, thereby creating a new subdocument. Use this procedure to insert the document as a subdocument:


1.
Open the existing master document.


2.
Choose View, Master Document, if the document does not open on master document view.


3.
Place the insertion point at the location in the master document where you want to add the subdocument.


4.
Click on the Insert Subdocument button on the master document toolbar.


5.
In the Insert Subdocument dialog box, type the name of the file you want to insert in the File name text box. You also can use the controls in the dialog box to select the file name.


6.
Click on OK in the Insert Subdocument dialog box.


7.
Save the modified master document.

Changing the order of subdocuments

Warning: See updated information before proceeding. As you work with a master document, you may need to change the order of subdocuments in the outline. Use the following steps to rearrange subdocuments:


1.
Open the master document.


2.
Choose View, Master Document, if the document does not open in master document view.


3.
To move an entire subdocument, click on its icon to select it, then drag it to its new location.


4.
To move only a portion of a subdocument, select the portion you want to move and drag it to its new location.

Removing subdocuments

Warning: See updated information before proceeding. From time to time, you need to remove subdocuments from your master document. To do so, follow these steps:


1.
Open the master document.


2.
Choose View, Master Document, if the document does not open in master document view.


3.
Click on the subdocument icon that represents the subdocument you want to remove.


4.
Press either the Backspace or Delete key. Word removes the subdocument from the master document, but leaves its original file intact on the disk.
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How do I share a master document with coworkers?

Warning: See updated information before proceeding. Master documents are large documents that can be written and organized by several people collaboratively. One person can easily manage a master document, but the advantage of a master document is you can share them with others on a network.

Solution

Warning: See updated information before proceeding. The first and most obvious step in sharing a master document is to create the document in a shared folder on the network file server so that any user with the appropriate privileges can access the document. Once you have taken this step, Word provides several automatic features that facilitate sharing the document.

Word keeps track of the owner of each subdocument. The person whose name appears in the Author field of the subdocument's File, Properties, Summary Info tabbed dialog box is considered the owner of the subdocument. If you own a subdocument, you can open it with read-write privileges; in other words, you can edit the document. If you are not the owner of a subdocument, you can open the subdocument with read-only privileges; that is, you can read the subdocument but cannot edit it except by saving it with a new name. If one user has opened a subdocument with read-write privileges, you can only open a copy of it with read privileges.

These file protection features provide users with orderly access to subdocuments in a master document. The features are not intended to prevent changes. If you do not own a subdocument, you see a lock icon below its subdocument icon that indicates you have only read access to the subdocument. If you really need to make changes to that subdocument, however, you can unlock the subdocument by clicking on the Lock Document button on the master document toolbar. This feature gives you read-write access, and is useful if a coworker is absent and changes must be made to the subdocument.

Although the locking feature of master documents is intended mainly to prevent accidental changes, the locking mechanism can be made more robust. You can permanently lock a document if necessary. When you permanently lock a document, (also known as reserving read-write privileges), others can open the document but only with read privileges. The document has a password associated with it that allows read-write access, but even when other users have the password, they can open only a copy of the document. Your original document remains intact.

To permanently lock a subdocument, follow these steps:


1.
Open the subdocument by double-clicking on its subdocument icon.


2.
Open the File menu and select the Save As option.


3.
Click on the Options button in the Save As dialog box.


4.
On the Save tab in the Options dialog box, either type a password into the Write Reservation Password text box, or check the Read-Only Recommended check box.


5.
Click on OK in the Options dialog box. Then click on OK in the Save As dialog box.
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How do I make a table of contents and index for a master document?

Warning: See updated information before proceeding. Master documents are so different from regular documents that creating tables of contents and indexes may seem daunting. Fortunately, Word enables you to create these elements the same way you would for any other document.

Solution

To create a table of contents, follow these steps:


1.
Open the master document.


2.
Choose View, Master Document.


3.
Position the insertion point where the table of contents should appear.


4.
Open the Insert menu and select the Index and Tables item.


5.
Select the Table of Contents tab in the Index and Tables dialog box.


6.
Select a format from the Formats list box. A preview of the format appears in the Preview box.


7.
Click on OK.

To create an index, follow this procedure:


1.
Open the master document.


2.
Open the View menu and select the master document item.


3.
Mark the index entries. (See How do I create an index? in Chapter 2 for an explanation of how to mark entries.)


4.
Position the insertion point where the table of contents should appear.


5.
Open the Insert menu and select the Index and Tables item.


6.
Select the Index tab in the Index and Tables dialog box.


7.
Select the type of index using the option buttons in the Type group and a format from the Formats list box.


8.
Select the number of columns using the Columns spin box.


9.
Check the Right Align Page Numbers check box if you want the page numbers to be placed at the edge of the right margin. Select the tab leader you desire from the Tab Leader drop-down list box.


10.
Click on OK.

For more information on creating tables of contents and indexes, see How do I make an index? and How do I make a table of contents? in Chapter 2, "Using Word to Perform Advanced Tasks."
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Can I move or rename a subdocument?

Warning: See updated information before proceeding. Sometimes drives or folders become full and it is convenient to move files to new drives or new folders. Sometimes it is also necessary to rename files. Can you move and rename subdocuments as easily as you can regular files?

Solution


1.
Open the master document.


2.
Choose View, Master Document, if the document does not open in master document view.


3.
Double-click on the subdocument icon representing the subdocument to move or rename.


4.
Open the File menu and select the Save As item.


5.
Use the controls in the Save As dialog box to give the file a new name or new location. Click on OK when you are done.


6.
Close the subdocument.


7.
When you are done with your work in the master document, close the master document.
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Can I split a subdocument into two subdocuments?

Warning: See updated information before proceeding. Subdocuments can become long, or grow to include topics that should be organized as separate subdocuments. Can a subdocument be split into separate subdocuments?

Solution


1.
Open the master document.


2.
Choose View, Master Document, if the document does not open in master document view.


3.
Place the insertion point at the place where the subdocument needs to be split.


4.
Click on the Split Subdocument button on the master document toolbar.


5.
To save the new subdocument, open the File menu and select the Save item.
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How do I merge several subdocuments into a single subdocument?

Warning: See updated information before proceeding. Sometimes separate subdocuments would be better organized as a single subdocument. Is there a way to merge subdocuments together?

Solution


1.
Open the master document.


2.
Choose View, Master Document, if the document does not open in master document view.


3.
Rearrange the subdocuments to be merged so that they are next to one another. Make sure they are in the order in which the information should appear in the merged document.


4.
Click on the subdocument icon for the first document to merge.


5.
Hold down the Shift key. Click on the subdocument icons for each of the remaining subdocuments to merge.


6.
Click on the Merge Subdocument button on the master document toolbar.


7.
To save the newly created subdocument, open the File menu and select the Save item.
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How do I make a subdocument part of the master document?

Warning: See updated information before proceeding. Sometimes text that has been organized as a subdocument should really be built directly into the master document instead. Is there a way to make this change?

Solution


1.
Open the master document.


2.
Choose View, Master Document, if the document does not open in master document view.


3.
Click on the subdocument icon representing the subdocument that should become a part of the master document.


4.
Click on the Remove Subdocument button on the master document toolbar. The subdocument is removed and the text in it becomes a part of the master document.


5.
Open the File menu and select Save option to save the change.
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How do I get rid of errors in the index, table of contents, and cross-references I created?

Warning: See updated information before proceeding. If you created an index, table of contents, or cross-reference in subdocuments, when you update them in master document view, the field codes in the subdocuments report errors. Use this procedure to eliminate the errors.

Solution


1.
Close the problem subdocument.


2.
Open the master document.


3.
Open the View menu and select the Normal item.


4.
Select the index, table of contents, and/or cross-references, and press F9 to update them.
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How do I avoid losing formatting in my subdocuments when I view the entire master document?

Warning: See updated information before proceeding. Formatting in subdocuments changes when I view the entire master document. Can this problem be avoided?

Solution

Word uses the formatting of the master document to override any similar formatting in subdocuments. Any formats that should apply to the entire document should be set at the master document level. Formats that should apply to a subdocument only should be set at the subdocument level. Do not set up formatting in a subdocument that overrides a format in the master document. You will lose such formats when you switch to normal view to print or view the entire document.
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Are there any problems with or limitations on master documents that I should know about?

Master documents sound great. But new features often have problems. Are there any problems or limitations to be aware of? Many users report irretrievable destruction of their documents by the Master Document feature in Word 95 – Word 2002. Warning: See updated information before proceeding.
Solution

There are two limitations, one a part of the design and one reported by users:


1.
By design, a master document can contain only 80 subdocuments.


2.
Some users report that you can make only limited changes to tables in master documents. The workaround is to save the document after every three changes.

Possible problems include the following items:


1.
Some users report slow system performance while working on a master document.


2.
Some users report that when rearranging subdocuments they must select the section break preceding the subdocument and the subdocument icon, then drag both to the new location in the master document.

Working in master documents generally seems to require a faster system and more memory to provide speedy system performance (though working in subdocuments is likely to be faster than trying to maintain an entire large document in a single file). If speed is an issue for you, test master documents on your system before committing to their use on a large scale.

Chapter 9 : Proofing Word Documents

Proofreading documents is never easy work. If you do it by hand, you have hours of tedious reading ahead of you, and you may not catch all the errors. If you use Word's automated proofing tools, however, you can speed up the task and increase accuracy. A drawback to Word's automatic proofing is how tedious it becomes when the spell checker stops at every reference to product codes because they contain both letters and numbers. This chapter offers solutions to this problem, and answers the following often-asked questions:



Can I prevent a section of a document from being proofread?



Can I check spelling in a foreign language?



Can I choose which rules to apply when I check grammar?



What do I do if I inadvertently add a misspelled word to my spelling dictionary?



Can I use more than one custom dictionary?



Can I force Word to question a particular spelling?
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Can I prevent a section of a document from being proofread?

Sometimes you do not want to have the spelling or grammar checker proofread part of a document. You might have words that contain numbers in the document, such as product names like MX5 or XL40. Checking each of these might slow you down considerably because Word will flag all of them as incorrect. You might have sections in a foreign language, or you might have strings of characters that Word's spell checker cannot handle. (Enter three asterisks with a leading and trailing space several times throughout a document and watch what happens when you try to check spelling!) Perhaps you have a list of names that Word's spell checker cannot recognize. (Word's spell checker actually does contain some, but not all, first names.) 

Solution

Word provides three methods for getting around such problems.

The first proofreading prevention method is designed to solve two narrow problems: it prevents Word from flagging expressions typed entirely in uppercase letters, or words that contain numbers. The second and third proofreading methods allow you to mark any portion of a document as off-limits to spell checking.


1.
Open the Tools menu and select the Options item. The Options dialog box displays, showing twelve tabs that each allow you to control twelve different parts of Word's behavior.


2.
Select the Spelling tab. From here, you can control many aspects of spell checking, including how Word makes suggestions and which custom dictionaries Word checks. For now, you'll be instructing Word to ignore certain types of words.


3.
Check the Words in UPPERCASE or the Words with Numbers check boxes, whichever you need, in the Ignore group of controls.



If you check Words in UPPERCASE, Word will skip any word spelled entirely in capital letters. Notice that Word will not check the word for spelling at all, so all-capitalized spelling mistakes like DIKSHUNARY will be left alone. Even if you check Words in UPPERCASE, Word will still flag words that are partially in uppercase, such as IntelliSense.



If you check Words with Numbers, Word will ignore combinations like SOOPER8 even if the "word" portion of the combination is spelled incorrectly. Notice that word will always treat a combination like SOOPER-8 as two separate words because of the hyphen, so it will be checked regardless of your settings in this dialog box.


4.
Click on OK. Word's spelling checker will now ignore words in uppercase or words that contain numbers. (Remember, a word to Word is anything that comes between two blank spaces.)

The remaining proofreading prevention methods are a little less obvious than the first. In these methods, you mark specific text as not to be proofed. Such text will not be checked by either Word's spelling checker or its grammar checker. They simply ignore it.

There are two ways to instruct Word not to proof text. The first is to select the text directly and mark it "no proofing." The second is to create a style that includes "no proofing" as one of its attributes, and to use that style whenever you create text that should not be proofed. In Word, you mark text as "no proofing" the same way you mark it as being written in another language—use the Tools, Language dialog box.

Solution

To mark directly text as "no proofing," follow these instructions: 


1.
Select the text.


2.
Choose Language from the Tools menu. The Language dialog box will open, showing the language Word currently assumes you are using—probably English (US).


3.
Select (no proofing)—the item at the top of the list. You may have to scroll up to see it; afterward, choose OK.

Now, when you run a spell check (or a grammar check) on the document, Word will ignore the text you've just marked.

Solution

You can partially automate the process of telling Word what not to proof by making No Proofing a part of a Word style, as follows:


1.
Open the Format menu and select the Style option.


2.
In the Style dialog box, either modify an existing style for the text you don't want to proof, or create a new style. This section shows you both methods. However, if you want to avoid proofing text that uses the same formats as your regular text, you may prefer to create a New Style and base it on whatever style you are using for text. By default, your text style is Normal.

To select an existing style for the text not to be proofed: 


1.
Highlight an existing style from the Styles list box.


2.
Choose Modify.

To create a new style for the text not to be proofed: 


1.
Highlight the existing style you would like to base the new style on—in other words, the existing style closest in appearance to the text you plan to avoid proofing.


2.
Choose New.


3.
Enter a name for the new style in the Name text box of the New Style dialog box.


4.
Whether you are in the New Style or Modify Style dialog box (they look much the same), click on the Format button. Select Language from the list that appears.


5.
In the Language dialog box, select (no proofing) from the Mark Selected Text As list box. (It is the first item on the list.) Notice that this is the same dialog box you saw when you marked text directly.


6.
Click on OK in the Language dialog box, and then on OK in the Modify Style or New Style dialog box.


7.
Click on Close in the Style dialog box. (Note this shortcut: If you select a block of text to be assigned the "no proofing" style before you open the Style dialog box, you can assign the style to that text by choosing Apply instead of Close.) 


8.
Apply this style to any text that you do not want proofread by selecting the text and choosing the style in the Style box on the Formatting toolbar.

You can also incorporate the (no proofing) feature into any style that you use for special purpose text that you do not need to proofread.
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Can I check spelling in a foreign language?

If you include blocks of foreign language text in your documents, Word can proofread them for you. You will need, however, the appropriate foreign language dictionary. Microsoft has delegated the U.S. marketing of foreign language dictionaries and other proofing tools to Alki Software, reachable at 1-800-NOW-WORD. Sets of proofing tools—including dictionaries, thesauri, and hyphenation files—are available for the following languages:

Catalan

Danish

Dutch (multiple dialects)

English (Australian)

English (British)

Finnish

French (multiple dialects)

German (multiple dialects)

Italian

Norwegian (multiple dialects)

Portuguese (multiple dialects)

Spanish

Swedish

Solution

First, you need to install the dictionary you want to use:


1.
Copy the dictionary file into the folder that contains your other dictionary or dictionaries. Often, your dictionary folder is C:\WINDOWS\MSAPPS\PROOF—a central location from which many Microsoft programs can find and utilize it.


2.
Open the Tools menu and select the Options item.


3.
Select the Spelling tab.


4.
Click on the Add button in the Custom Dictionaries group. This displays the Add Custom Dictionaries dialog box, which opens to the current location of your current dictionaries—usually, C:\WINDOWS\MSAPPS\PROOF.


5.
Use the controls in the Add Custom Dictionaries dialog box to find and select the appropriate .DIC file. (This dialog box functions much the same as the familiar Open and Save As dialog boxes.


6.
Once you have selected a dictionary file, click on OK in the Add Custom Dictionaries dialog box.


7.
In the Spelling tab in the Options dialog box, select the dictionary file you just added in the Custom Dictionaries list box.


8.
Open the Language drop-down list and select the language format to apply to the new custom dictionary. This associates the correct language with the dictionary file, so that Word knows where to look when you specify that language as your proofing language.


9.
Click on OK in the Spelling tab to close the dialog box.

Now, when you want to proof text in the alternate language, mark the text as being in that language so that Word will recognize how you want to proof it. Follow this procedure:


1.
Select the text you want to proofread in another language.


2.
Open the Tools menu and select the Language item.


3.
In the Language dialog box, select the appropriate language in the Mark Selected Text As list box.


4.
Click on OK.

Word now recognizes the marked text as being in the appropriate language. When you run a spelling check, Word uses the appropriate dictionary to proofread the text.

You can also incorporate the language format into the style you apply to the text. See the Can I prevent a section of a document from being proofread? portion of this chapter for methods. Choose the appropriate language instead of the (no proofing) feature when you define the style.
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How can I choose which rules to apply when I check grammar?

Writing for different situations and audiences often requires that you use different tones of voice and grammatical rules. For example, putting "ain't" in the mouth of a fictional character is appropriate, but using "ain't" in a presentation to the Board of Directors probably is not. Similarly, business or technical jargon may be acceptable within limits for audiences in the same industry, but not for general audiences.

Word's grammar checker organizes its rules into two main categories, "grammar rules" and "style rules." (The use of the word style here may be confusing. It means style of writing, not a collection of formats that you apply to text.) Word's grammar checker can accommodate many different approaches to writing, and you can customize it quite easily.

Solution


1.
Open the Tools menu and select the Options item.


2.
Select the Grammar tab. In the Use Grammar and Style Rules box, you can see that Word offers three predefined sets of rules: Strictly, which checks your writing against every rule built into the program; For Business Writing, which overlooks several Style rules, such as avoiding jargon, and For Casual writing, which also overlooks several Grammar rules such as Informal Usage. Word also offers three customizable sets of rules, Custom 1, Custom 2, and Custom 3, each of which you can use for your own purposes (though you unfortunately cannot rename them).


3.
Select the set of rules you want to change from the Use Grammar and Style Rules list box. You can change one of Word's predefined sets of rules to reflect your own preferences, or you can define custom combinations of rules using the Custom 1, Custom 2, and Custom 3 options.



For example, you might want to create a custom set of rules that only flags the kinds of mistakes you typically make. Such a custom set of rules might flag wordy expressions, passive voice, weak modifiers, vague quantifiers, jargon, punctuation errors, redundant expressions, and double negatives, and overlook everything else.


4.
To set up a custom set of rules, select one of the custom items in the Use Grammar and Style Rules list box, then click on the Customize Settings button.


5.
The Customize Grammar Settings box opens, showing the Grammar rules. Until you make changes, every rule is checked—just as if you were using Word's strictest set of rules. Clear the check boxes from any rules you do not want to apply. If you change your mind, or if you are modifying an existing set of rules and want to apply a rule that was previously ignored, check the box to activate it.


6.
If you need an explanation of a particular rule, select it in the list box and click on the Explain button. Word displays a window in which the explanation appears.


7.
When you have finished selecting Grammar Rules, click Style and do the same with the list of Style rules that appears.


8.
Use the drop-down lists and text box in the Catch group to set the restrictions on split infinitives, consecutive nouns and prepositional phrases in a row, and long sentences. For example, if you are writing a children's book, you might tell Word to flag sentences longer than 15 words instead of the default setting of 35.


9.
If you want to customize another set of rules, you can use the Use Grammar and Style Rules drop-down list box to change the style you are customizing. With this dialog box, you can customize settings for several different styles in one session.


10.
When you have finished defining the grammar and style rules, click on OK in the Customize Grammar Settings dialog box, then click on OK in the Options dialog box.

If you decide you no longer want any of the customized settings in one of your sets of grammar or style rules, you can clear the customized settings by choosing Reset All in the Customize Grammar Settings dialog box. This clears only the settings in the set of rules you have currently selected. To clear customizations from another set of rules, choose that set from the Use Grammar and Style Rules drop-down box.
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What do I do if I added a misspelled word to my spelling dictionary? 

What happens if you accidentally hit the Add button while checking spelling? An incorrectly spelled Word gets added to the spelling dictionary. Is there any way of getting that word out of the dictionary? Fortunately, Word allows you to remove such words. As you'll see, you can use the same techniques to manually add words to your spelling dictionary. For example, you might often include a list of your colleagues' names in a memo; if you include these first and last names in your spelling dictionary, Word won't flag them as mistakes every time you proof a memo. Similarly, you might add the names of all the companies you regularly do business with, or of all your trademarked product names.

If you are responsible for setting up Word on the computers of several people in the same workgroup, you could significantly improve their productivity by distributing a CUSTOM.DIC file that already includes all the custom names they're likely to use. They can then make individual additions to your custom dictionary either by editing it, or by adding the words during the course of regular spell checking.

Solution

In the following steps, you will open and edit the CUSTOM.DIC custom dictionary file, which is actually a simple text (ASCII) file with each word on a separate line.


1.
Open the Tools menu and select the Options item.


2.
Click on the Spelling tab in the Options dialog box.


3.
Highlight the dictionary to edit in the Custom Dictionaries list box. Generally, you will edit CUSTOM.DIC, which is the custom dictionary Word creates the first time you add a word during spell checking. However, you can edit any available custom dictionary. (We'll show you how to create a new custom dictionary later.) 


4.
Click on the Edit button.


5.
Click on the Yes button in the dialog box that informs you that Word will open the dictionary as a Word document. If necessary, confirm the conversion from a text file by clicking on OK in the Conversions dialog box. You may also need to click on OK in the Tools Options Spelling tabbed dialog box to close it, so that you can then edit the spelling dictionary.


6.
Edit the dictionary to remove the word you want to delete. Each word must remain on its own line. Each line must end with a carriage return. (When you reach the end of a line as you type, press Enter to move the insertion point to a new blank line. If you cannot tell whether a carriage return ends the line, click on the Show/Hide Paragraphs button on the Standard toolbar. Each line should end with a paragraph mark.) You can also add new words, adding one word to each line and ending the word with a paragraph mark. Word normally organizes its custom dictionaries with all the capitalized words first, followed by all the lowercased words—with each group alphabetized. But you don't have to do it that way for it to work.


7.
When you have finished editing the file, close it and save it. By default, if you use Ctrl+S or the Save toolbar icon to save the file, it will automatically be saved as text only. If you open the Save As dialog box, make sure that you do not change the Save File as Type option—it must remain a text only document, or it will not work.
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Can I use more than one custom dictionary? 

You may want to create more than one custom dictionary, each for specific uses. For example, you may want to use one custom dictionary for your business documents and another for your personal documents. Perhaps there are some words you want to flag as incorrect in your business writing but not in your personal writing. Or perhaps you've developed a large set of "jargon" words for your technical writing, but you don't want Word to waste time checking those words when you're creating a non-technical document. Word allows you to create several custom dictionaries and specify which will be used.

Solution

To create a new custom dictionary: 


1.
Open a new file.


2.
Enter each word that you want to include in the file on a separate line, with a hard return at the end of each line.


3.
Save and close the file. In the Save As dialog box: 



Choose Text Only in the Save as Type box.



Specify a file name with the. DIC extension.



Use the dialog box controls to find your other custom dictionaries: probably in C:\WINDOWS\MSAPPS\PROOF or C:\WINWORD.



Choose OK.


4.
In the next steps, you will be activating the custom dictionary you've just created so that Word will actually use it when you run spell check. Choose Options from the Tools menu.


5.
Click the Spelling tab.


6.
In the Custom Dictionaries box, the new dictionary should appear but without a check mark next to it. Click on the dictionary.


7.
Choose OK to exit Tools Options Spelling.

Keep in mind that if you have more than one custom dictionary loaded when you run spell check, you can choose which dictionary you want to add a new word to. In the Spelling dialog box that appears when Word finds an incorrect spelling, click on the down-arrow next to Add Words To, and select the dictionary where you want to place the new word. Word will then use that dictionary until you change it again.
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Can I force Word to question a particular spelling?

I prefer theatre and centre to theater and center, yet Word's spelling dictionary always corrects my variant spellings. Is there any way to force Word to question the correct spellings so that I can use the variant spellings?

Solution

You can create a file that Word calls an Exclude Dictionary, which Word will use to flag correct words as if they were wrong.


1.
Click on the New button on the Standard toolbar to create a new file.


2.
Type the words that you want Word to question, correctly spelled, each in its own paragraph—just as if you were creating a new custom dictionary.


3.
Open the File menu and choose the Save As option.


4.
Use the dialog box controls to select the folder containing your custom dictionaries; most likely, C:WINDOWS\MSAPPS\PROOF. 


5.
Use the Save as type drop-down list box to select Text Only.


6.
Type a name for the file in the File name text box. The file you are saving must end in the extension EXC. Its root name must be the same as the main dictionary it must work with. For American English, the name for the exclude dictionary should be MSSP2_EN.EXC.


7.
Click on OK to save the file.


8.
Click on the Spelling button on the Standard toolbar. Now that the exclude dictionary exists, Word automatically loads and uses it when the spelling checker runs. If you want to check spelling without the exclude dictionary being active, you must rename its file before checking spelling, or move it to another folder.

If you always want to substitute a word, such as theatre for theater, you might also consider using Word's AutoCorrect feature to do so. Choose AutoCorrect from the Tools menu. Type the word you want to replace in the Replace box. Type the word you want to use instead in the With box. Make sure Replace Text as you Type is checked. Then choose OK.

Chapter 10: Printing Documents

Printing should be easy. You should be able to click on the print button and the word processor should print what you want it to print. So many types of documents exist, however, that printing occasionally becomes more complex. This chapter answers the following questions about printing in Word 95:



Can't I print any faster?



Can I print several files at once?



How do I create mailing labels?



How do I print envelopes?



How do I keep my envelopes from being double-spaced when printed?



Can I use copier labels instead of laser labels?



Can I print only a part of my document?



Can I print the associated material that comes with my document, such as annotations?



Can I send printer escape codes from my document?



Can I print bar codes?



How do I print the whole master document?



How do I print a subdocument?



Can I squeeze a little more text onto the same number of pages when I print them?
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Can't I print any faster?

In Word, print speed involves a variety of tradeoffs. For example, you can print faster if you're willing to wait longer for the Windows hourglass to disappear so that you can start typing again. If your documents are printing too slowly, you may want to examine tradeoffs you can make with other parts of your system. You can try several options for speeding up printing in Word 95.

Solution

One of the easiest ways to speed printing in Word is to replace TrueType fonts or PostScript fonts not included in the basic set on your printer with fonts that are built into your printer.

This eliminates the time your computer and printer normally spend downloading and receiving font information before your document prints.

This is generally only an option if your document uses relatively basic fonts, such as Times Roman, Helvetica, Courier, or similar versions of these fonts that often have similar names. Even if your printer's fonts have similar names to those on your computer, they may have slightly different widths, which can affect line breaks and cause problems in heavily formatted documents. If you are printing basic reports using common fonts, however, the use of printer fonts can significantly speed printing.

Printer fonts appear in the Standard Toolbar font list with an icon of a printer next to them. If you've used styles to create your document, it's easy to replace fonts globally.


1.
Select text in a style you want to change.


2.
Select the printer font you want to substitute from the Font list on the Standard Toolbar.


3.
Click in the Style list on the Standard Toolbar to highlight the entire style name. Press Enter.


4.
The Reapply Style dialog box appears. Choose Redefine the style using the selection as an example. All the text using the same style will be changed.

If you have based many or all of your styles on a single style, such as the Normal Style, changing the font in that style will automatically change all the others. As a result, you may find that you only need to change one or two styles to change an entire document.

Solution

The way Windows 95 "spools" print jobs may affect the speed of your printing. By default, Windows creates temporary data files that it sends to your printer; while it is waiting for your printer to finish with what it has already sent, it "spools" the data to your hard disk. These temporary data files for printing can be dramatically larger than document files.

Make sure you leave enough empty space on the hard disk to hold these files, or else Word will have to wait for pages to be printed before it can spool more information. Depending on the size of your files, you may need to keep at least 10 MB free and perhaps 20 MB or more. 

If this doesn't help, you may want to double-check that spooling is actually enabled: 


1.
From the Start button on the Windows Taskbar, click Settings, Printers. 


2.
The Printers folder opens; right-click on the printer you're using, and choose Properties from the pop-up menu. 


3.
Click the Details tab. 


4.
Click Spool Settings. 


5.
The Spool Settings dialog box opens. 


6.
Make sure Spool print job so program finishes printing sooner is checked. 


7.
Generally, printing should begin after the first page is spooled, but if this does not work well, try printing after the last page is spooled. 


8.
Each time you change a setting, close the Properties dialog box and try printing again to see whether you've solved your problem. 

Solution

The resources that Word saves by not having to display complex font formatting can be reassigned to printing. To display text in Draft Font:


1.
Choose Options from the Tools menu.


2.
Choose the View tabbed dialog box.


3.
Check the Draft Font checkbox then click on OK.

Switching to Draft Font before you print usually won't make a dramatic difference, but if you find that it helps enough to be worthwhile, you may want to create a macro that does it automatically. The following macro does the job: 

Sub MAIN

ToolsOptionsView.DraftFont = 1,.WrapToWindow = 1, _.PicturePlaceHolders = 0,.FieldCodes = 0,.BookMarks = 0, _.FieldShading = 2,.StatusBar = 1,.HScroll = 1,.VScroll _= 1,.StyleAreaWidth = "0" + Chr$(34),.Tabs = 0,.Spaces _= 0,.Paras = 0,.Hyphens = 0,.Hidden = 1,.ShowAll = 0, _.Drawings = 0,.Anchors = 0,.TextBoundaries = 0,.VRuler _= 0

Dim FPrec As FilePrint

GetCurValues FPrec

Dialog FPrec

FilePrint FPrec

End Sub

The macro recorder available through Tools, Macro enables you to record the most complex part of this macro—the long line between Sub MAIN and the Dim command—that specifies your Tools Options View settings, including Draft Font. The last four lines preceding End Sub have to be written manually, however, by using Word's macro editor. These lines open the Print dialog box, wait for your instructions, and execute your instructions.

The reason why those lines must be entered manually in Word is because you can't record the opening of a dialog box without also recording the settings you want to take effect in that dialog box. In this case, however, you don't want to restrict your print settings in advance—you just want to open the dialog box and let the user decide. This requires WordBasic code.

You might want to assign this macro to the Ctrl+P keyboard shortcut, so that whenever you press Ctrl+P to print, Word also switches to Draft Font first. Then, the only remaining step is to record a separate macro that redisplays your regular font when you're finished printing.

Solution

Finally, another method to increase printing speed is to turn off Word's Background Printing feature.

By default, Word 95 uses Background Printing, which means it returns control of the computer to you extremely quickly, and manages printing while you work on something else. The downside of this is it significantly slows printing. You may also find that Word runs more slowly, and that your mouse cursor jumps around. You may want to wait a little longer to start working in Word again, in exchange for faster printing and better performance. To disable Background Printing:


1.
Choose Options from the Tools menu.


2.
Choose the Print tabbed dialog box.


3.
Clear the Background Printing checkbox and click on OK.
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Can I print several files at once?

Occasionally, you may want to print more than one file at a time. For example, perhaps you want to print file copies of all the documents related to a specific project. You can't do this from Word's Print dialog box, but you can do it with File, Open.

Solution

To print several documents at once:


1.
Choose File, Open. 


2.
Select the files you want to print. After you select the first file, press Ctrl and select the next file. 


3.
Right-click on a file you've selected, and choose Print from the pop-up menu. 


4.
The Print dialog box opens. Make any changes in settings you require, and choose OK. Word will print all the documents you selected. 

If all the documents you want to print are part of one larger document, such as chapters in a book, you can assemble them all in a single master document, and then print the master document. All the documents will print. Printing a master document is discussed later in this chapter.
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How do I create mailing labels?

If you are like most people, you print mailing labels just often enough to forget how you did it the last time. Word 95 provides lots of support to make this process easier. You can create mailing labels in two ways.

The first method works best if you have just a few labels to make, and is explained in this chapter. The second method, explained in How do I do mail merge? in Chapter 2, is for those who have lots of labels to make and maintain.

Solution


1.
Select the printer for printing the labels. Word can print single labels or a whole sheet. If you have a label printer, you can take advantage of it from within any document. If you plan to print a sheet, you should open a new document to represent the sheet of labels.


2.
Open the Tools menu and select the Envelopes and Labels option. The Envelopes and Labels dialog box opens.


3.
Select the Labels tab in the Envelopes and Labels dialog box.


4.
To print a single label, enter the name and address in the Address text box. If Word finds a name and address in your document, it inserts that address in the Address text box as the default. If you want to print a label for another name and address, erase the default label by pressing Delete or the Backspace key, and type the address that you want.


5.
To print the return address on the label instead of a delivery address, check the Use Return Address check box. Word inserts the return address you entered into the User Info tab in the Tools, Options dialog box. You can delete or edit this address if you want. When you finish, Word will display a dialog box asking if you want to make the address you entered the default return address. If you choose Yes, the new address will be copied into Tools, Options, User Info and will remain there until you change it again.


6.
In the Print group, select either the Single Label or the Full Page of the Same Label option button. Full Page of the Same Label can be a convenient solution for adding return addresses to envelopes, or for creating labels that will be used in other ways, such as identifying equipment. If you select the Single Label option, select the row and column for the label on the sheet using the spin boxes. (This option allows you to use the remaining labels on partially used sheets, as long as the labels can stand another trip through your printer.)


7.
If the label you are using is large enough, the Delivery Point Bar Code check box becomes available. Check it if you want to print the POSTNET bar code for the address on the label.


8.
Click on the Options button to set the type of label you want to use and the printer options for the print job in the Label Options dialog box. Use the controls in the Printer Information group to select the type of printer you will use—laser or dot matrix—and the appropriate paper tray, if applicable. Use the Label Products drop-down list to select the label manufacturer, and select the label type by number in the Product Number list box. You can choose from more than 100 standard laser label sizes in Avery, Avery European, Inmac, RAJA and UNISTAT formats. Then click on OK to return to the Envelopes and Labels dialog box.


9.
If you need to use labels that are not listed, or need to adjust the print dimensions for a listed label, click on the Details button. (You may need to do this to print on copier labels, as discussed later in this chapter.) The Information dialog box opens, providing you with spin boxes to adjust the printing and label margins, height and width, and the number of labels appearing in each row and column. A Preview box shows you the effects of your changes. Click on OK when you are done adjusting dimensions.


10.
Print your labels by clicking on the Print button in the Envelopes and Labels dialog box.


11.
If you would rather save your labels as a table in a Word document so that you can use them later, click on the New Document button in the Envelopes and Labels dialog box. Word creates a document with the labels properly positioned for printing. You can print this document any time using the Print option on the File menu when you need the labels you have created. Remember to save the file before leaving Word.
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How do I print envelopes?

You may not print envelopes that often, although it is an attractive feature now that envelopes specifically designed for printers are available. Your company might have a printer dedicated to printing envelopes on your network, or your personal printer might have an easy-to-use envelope feed option.

Word provides two methods for printing envelopes. The most common method is described here. A different option is described in the Can I make an envelope template? section in Chapter 7, "Using Document Templates." You might also want to look at How do I do mail merge? in Chapter 2, "Using Word to Perform Advanced Tasks," to learn ways to print addresses on envelopes by means of mail merge.

Solution


1.
Set up your printer to feed envelopes, or select the printer dedicated to that task.


2.
In your document, select the address by dragging over it with the mouse if there is more than one address in your document. Word automatically recognizes as an address the first chunk of left-aligned text it finds in your document that consists of three or more consecutive lines separated by paragraph marks. In letters, this is almost always the address. When Word recognizes what it believes is an address, it automatically places that address in the Address box of the Envelopes and Labels dialog box. When the address is not self-evident, or when another text element may appear incorrectly to be the address, you will have to help Word identify the address by selecting it.


3.
From the Tools menu, select the Envelopes and Labels option. The Envelopes and Labels dialog box opens.


4.
Select the Envelopes tab in the Envelopes and Labels dialog box.


5.
If the default delivery address and return address are incorrect, enter the correct addresses in the Delivery Address and Return Address text boxes. If you want to omit the return address, check the Omit button.


6.
Click on the Options button to set the envelope size and printing orientation in the Envelope Options dialog box.


7.
Select the Envelope Options tab to set characteristics for the envelope. Use the Envelope Size drop-down list to select the envelope's dimensions. The default is Size 10, referring to the standard #10 business envelope. Other standard sizes available include #6 3/4, #9, #11, #12, Monarch, and a variety of European sizes. Use the spin boxes and buttons in the Delivery Address group and the Return address group to set the font and location for each address. The Preview box shows you the result of your changes. Check the Delivery Point Bar Code and FIM-A Courtesy Reply Mail check boxes to print bar codes, which aid automated mailing, on your envelope.


8.
Select the Printing Options tab to set the envelope feeding options for your printer. Use the Feed From drop-down list box to select the tray or feed method. Click on the icon in the Feed Method group that represents your printer's envelope feed position. The Face Up, Face Down, and Clockwise Rotation option buttons adjust the orientation of the envelope as it enters the printer. The icons change to reflect changes in the settings of these buttons. Select the picture that reflects the way you want to feed an envelope to your printer. You will have to change this very rarely. In particular, most laser printers must be fed using the default settings or the envelopes will jam.


9.
Click on OK in the Envelope Options dialog box when you are done setting the envelope's characteristics.


10.
To print an envelope, click on the Print button in the Envelopes and Labels dialog box. The envelope will print without further hassle; Word will not display the Print dialog box.


11.
To add the envelope as a special section at the beginning of the document, click on the Add to Document button. The envelope prints before the document does when you use the Print option from the File menu. (Unless you have a dedicated envelope feeder on your printer, this method can require some fancy paper changing as your document prints.)



When you add the envelope to your document, it becomes a separate section of your document, consisting of Page 0 and formatted in the size and shape of the envelope you've chosen. You can see this by choosing Print Preview and viewing Page 0.


12.
To change the settings of an envelope already added to a document, click on the Change Document button.
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How do I keep my envelopes from being double-spaced when printed?

Documents with attached envelopes that you created in Word 2.x using its built-in letter templates do not print properly after they are converted to Word 95. The envelopes print double-spaced. Double-spaced print is a conversion problem that is easy to fix. You just need to make a minor change in the Envelope Address Style built into those letter templates.

Solution


1.
Open the document in Word 95 that you created using a Word 2.x letter template.


2.
Open the Format menu and select the Style option. The Style dialog box opens, listing all the styles now in use in the current document.


3.
To view all the styles in the document template, not just those currently in use, open the List drop-down list box and select All Styles.


4.
Select the Envelope Address style and click on the Modify button. The Modify Style dialog box opens.


5.
In the Modify Style dialog box, click on the Format button and choose Paragraph from the list that appears. The Paragraph dialog box appears. This is the same dialog box that appears when you choose Format, Paragraph, except that in this context you can use it to change a style, not just selected text.


6.
In the Paragraph dialog box, use the Before and After spin boxes in the Spacing group to adjust each of these settings to 0 pt, and then click on OK. This eliminates the extra spacing that Word has added before or after each paragraph mark in your envelope letter addresses.


7.
In the Modify Style dialog box, check the Add To Template check box, then choose OK. This ensures that the change is added not only to the current document, but also to the envelope template attached to it.


8.
In the Style dialog box, click on Close.


9.
Repeat steps 2 through 8 for the Envelope Return style.


10.
Open the File menu and choose the Save All option. If Word prompts you, choose Yes to save the template, overwriting the original Word 2.x template file with the Microsoft Word 95 format.

Once you have successfully converted the template file on which the letter is based, perform these steps to update other documents based on the template:


1.
Open the document based on the template.


2.
Open the File menu and choose the Templates option.


3.
In the Templates and Add-ins dialog box, click on the Attach button.


4.
Select the template that the letter was created in using the controls in the Attach Template dialog box, then click on OK. (The controls in this dialog box function exactly like the controls in the Open and Save As dialog boxes.)


5.
In the Templates and Add-ins dialog box, check the Automatically Update Document Styles check box and click on OK.

Follow this procedure to ensure that Word automatically updates the envelope styles when you open each document based on the template.

If you are updating many envelope files, you may want to automate this process with a macro. Conversely, if you are creating envelopes for the first time, don't bother with the old Word 2.x templates at all. They've been superseded in Word 95 by the Letter Wizard, which can automatically create envelopes as it streamlines the process of building letters of all kinds.
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Can I use copier labels instead of laser labels?

Has your office ever run out of laser labels and sent you copier labels as a replacement? There is no need for panic. You can use them with Word and your laser printer.

The difference between copier labels and laser labels is that copier labels do not have an outside margin at the right and left edges of the form. This margin on laser labels is typically 0.5 inches. Your laser printer, as a result, cannot print closer to the edge of the label than the width of this margin.

Solution

To set up the page for copier labels, follow these steps:


1.
Open the Tools menu and select the Envelopes and Labels option. The Envelopes and Labels dialog box opens.


2.
Select the Labels tab, click on Options, select Custom Laser in the Product Number list box, then click on Details. The Custom Laser Information dialog box opens; here you can set precise custom measurements for each label and for their locations on the page.


3.
Use the spin boxes in the Custom Laser Information dialog box to set the following values:

Top Margin:
0.5"
Label Width:
1.5"

Side Margin:
0"
Label Height:
2.81"

V. Pitch:
1.5"
No. Across:
3

H. Pitch:
2.81"
No. Down:
7


4.
Click on OK in the Custom Laser Information dialog box. If you are ready to print labels, click on the Print button in the Envelopes and Labels dialog box. Otherwise click on Cancel.
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Can I print only a part of my document?

Word enables you to print any portion of your document that you want. You can select from among three methods for printing portions of your document.

Solution

To print the current page, follow this procedure:


1.
Place the insertion point on the page you want to print.


2.
Open the File menu and select the Print option.


3.
In the Print dialog box, select the Current Page option button in the Page Range group.


4.
Click on OK. The current page prints.

Solution

To print a selected portion of your document, follow these steps:


1.
Select the text you want to print.


2.
Open the File menu and select the Print option.


3.
In the Print dialog box, select the Selection option button in the Page Range group. (The Selection option is only available if you selected text before opening the Print dialog box.)


4.
Click on OK.

Solution

To print a range of pages, follow these steps:


1.
Open the File menu and select the Print option.


2.
In the Print dialog box, select the Pages option button in the Print Range group. Enter a page (for example, 5), a page range using a hyphen (for example, 5-12), or a combination of pages and page ranges separated by commas (for example, 5, 10-12, 18, 19, 24-26).


3.
Click on OK.
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Can I print the associated material that comes with my document, such as annotations? 

Word documents can contain a variety of associated information that you may want to print. This information includes:



Summary information stored in the File, Properties, Summary Info tabbed dialog box (such as title and author's name)



Annotations added by the document's reviewers



Styles associated with the document



AutoText entries associated with the document



Special key assignments built into templates associated with the document

Solution

To print one of the elements associated with a Word document: 


1.
Open the document.


2.
Choose Print from the File menu.


3.
Click the down-arrow next to the Print What list box.


4.
Select the document element you want to print.


5.
Set any other print settings you want, such as the number of copies or the pages to be printed.Choose OK. The document element prints.
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Can I send printer escape codes from my document?

Word 95 works very hard to hide the printer hardware from you. The printer driver does all the work. A printer driver is a program that accepts printed material from Word (or any other program running under Windows) and interprets it for your printer. The reason for a printer driver is so that the user does not have to worry about programming the printer's hardware.

Sometimes, however, printer drivers do not work as advertised, and you need to bypass the driver to turn on a particular feature of your printer. In addition, a few users like to work directly with the hardware. No matter what the reason, Word allows you to enter printer codes (also called escape sequences or printer escapes) and communicating them directly to your printer.

Solution


1.
Place the insertion point in your document where you want to insert the printer code.


2.
Open the Insert menu and select the Field option.


3.
In the Field dialog box, select All in the Categories list box and Print in the Field Names list box. You are inserting a field code that tells Word you want to send information directly to your printer.


4.
To tell your printer the information you want it to have, enter your desired printer escape sequence in the Field Codes text box.


5.
Click on OK. Word enters the escape sequence as a print field in the document. The field does not affect the on-screen formatting of your document, and is directly transmitted to the printer.

This method can fail if your printer driver misinterprets the escape code as it passes it on to the printer. Its success depends strongly on the type of printer you are using and how effectively it accepts commands directly from the word processor. In short, send commands directly to the printer only when you cannot solve a problem in any other way.
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Can I print bar codes?

Word allows you to print POSTNET codes, U.S. Postal Service-approved bar codes representing the destination address and ZIP code in machine-readable form, and FIM-A courtesy reply codes, bar codes used to identify the address side and orientation on a business reply envelope. Printing these codes can save you postage on bulk mailings and mailings of other types. (You may also have to qualify your mailing list with your local postmaster or through the Postal Service's Coding Accuracy Support System (CASS) certification program. For more information on this program, call 1-800-238-3150.)

Solution

You can print bar codes on both labels and envelopes. Turn to the How do I print envelopes? and How do I create mailing labels? sections in this chapter for instructions on choosing the options for printing these codes. On smaller mailing labels there may not be room for the POSTNET code: you may want to purchase larger labels and specify them through the Tools, Envelopes and Labels dialog box. To print bar codes, your printer must be capable of printing graphics.

Postal bar codes aren't the only kind of codes that exist. There are also inventory bar codes and the Universal Pricing Codes you recognize from the supermarket. Word doesn't include built-in support for these kinds of codes, but a number of third-party products do. For example, Bars & Stripes for Word for Windows (Tippecanoe Systems, 510-416-8510) installs inside Word and adds a bar code icon to Word's Toolbar. Bars & Stripes can automate the creation of large quantities of bar codes, and print them on widely available Avery labels on a standard laser, inkjet or dot-matrix printer.
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How do I print the whole master document?

As you learned in Chapter 8, master documents enable you to assemble and detach components of very large documents easily—such as chapters in a book. Working with master documents might cause some confusion about printing. No "master document option" exists in the Print dialog box. Printing an entire master document, however, is quite easy.

Solution


1.
Open the master document.


2.
Open the View menu and select Normal option. (If you only want to print outline headings for the entire master document, choose Outline view and use its tools to specify what levels of the outline you want to print.)


3.
Open the File menu and select the Print option. Print using any of the options available in the Print dialog box. Your master document will print exactly like any other long document.
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How do I print a subdocument?

Working with subdocuments might also cause some confusion about printing. A subdocument does not appear as an option either in the Print dialog box. Printing a subdocument, however, is quite easy. You have three methods at your disposal.

Solution

The first method for printing a subdocument is as follows:


1.
Open the master document.


2.
Double-click on the subdocument's icon to open the subdocument.


3.
While the subdocument is displayed in the active window, select the Print option from the File menu.


4.
Select your print settings and choose OK to print.

Solution

The second method for printing a subdocument is as follows:


1.
Open the master document.


2.
Use the buttons on the Outlining toolbar to expand or collapse headings in the outline. This allows you to display the subdocuments you want to print as a part of the outline.


3.
Select the Print option from the File menu.


4.
Choose your print settings and choose OK to print.

With the method just described, you will also print whatever outline levels are showing for other chapters. 

Solution

The third method for printing a subdocument is as follows:


1.
Open the subdocument directly, without opening the master document.


2.
While the subdocument is displayed in the active window, select the Print option from the File menu.


3.
Select your print settings and choose OK to print.

If you open the subdocument without opening the master document, make sure not to move it when you save it. If you do, Word won't be able to find the current version of the subdocument.
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Can I squeeze a little more text onto the same number of pages when I print them? 

Suppose you have a letter that you want to fit onto one page—but it's just a line or two too long. Or you have a report that must be no longer than 10 pages—but there's an extra half page you can't seem to edit away. There are many ways to make it fit—reduce the font size, extend the margins, and so on—but the most elegant solution is to have Word do it for you, using the Shrink to Fit feature. No matter the size of the document, Shrink to Fit attempts to squeeze it onto one less page.

Solution


1.
Choose Print Preview from the File menu. Your document appears in miniature in the Print Preview window.


2.
Click on the Shrink to Fit toolbar button—the icon that shows two pages turning into one page.


3.
Choose Print from the File menu.


4.
Set your print settings and choose OK to print the document.

Use your judgment when you're using Shrink to Fit. If you ask it to squeeze a document that's just a hair under two pages onto a single page, you may find the resulting text too small to read when it comes off the printer.

Chapter 11: Customizing Word

Word can be modified to look and feel the way you want. You can create toolbar buttons, change menu items, and redesign keyboard shortcuts. This chapter provides solutions for questions everyone has about customizing, including:



Can I create my own toolbar?



How do I create a custom button for a toolbar?



How do I change the menu?



How do I change the key assignments?
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Can I create my own toolbar?

Word provides a number of toolbars for you to use. However, you may prefer specific features from several different toolbars or you may want to delete features that you never use. You also may want to use a toolbar containing buttons for a particular type of project. With Word, you can create your own toolbars and use them just as you would any other toolbar.

Solution


1.
Open the View menu and select the Toolbars option.


2.
In the Toolbars dialog box, click on the New button.


3.
In the New Toolbar dialog box, enter a name for the new toolbar in the Toolbar Name text box.


4.
In the New Toolbar dialog box, select the document template to contain the toolbar in the Make Toolbar Available To drop-down list box. Selecting Normal (NORMAL.DOT) makes the toolbar available to any document; selecting another template makes the toolbar available only to documents based on that template.


5.
Click on OK in the New Toolbar dialog box. Word creates the toolbar, displays it, and opens the Customize dialog box, displaying the Toolbars tab.


6.
You add buttons to your toolbar by working in the Customize dialog box. To use one of Word's standard toolbar icons for one of its commands, select the menu on which the command appears in the Categories list box. Drag the button associated with the command from the Buttons group and drop it on your toolbar. Click on any of the buttons in the Buttons group, and an explanation of the related command appears in the Description box.


7.
To add a macro, font, AutoText entry, or style to a toolbar, select one of these items from the Categories list box. (These items appear at the end of the list.) The buttons group becomes a list box displaying the available list of the macros, fonts, AutoText entries, or styles available. Click on an item in the list to select it. Then drag the item from the list box and drop it on your toolbar. A generic button appears on the toolbar and the Custom Button dialog box appears.


8.
In the Custom Button dialog box, select one of the buttons in the Buttons group and click on the Assign button. The selected button then appears on the toolbar. You can edit the text on a text button by changing the default text in the Text Button Name text box before clicking the Assign button.


9.
To remove a button from your toolbar, drag it from the toolbar and drop it anywhere over the area of the Customize dialog box.


10.
When you are finished adding buttons to the toolbar, close the Customize dialog box by clicking on Close. You can later use the Delete and Customize buttons in the Toolbars dialog box to delete the toolbar when you no longer need it or to make further changes in the toolbar.
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How do I create a custom button for a toolbar?

Buttons are the primary interface for a toolbar. You need to be able to look at the button and know what command it invokes. Waiting for the Tooltip to appear can be annoyingly slow when you are rushed and behind deadline. Word provides a large library of buttons for you to use, but you may want to create your own. Your own buttons have immediate meaning for you; you can look at them and know exactly what you are doing by clicking on the button. Word allows you to create your own custom buttons.

Solution


1.
If you want to create a custom button for a Word command, first create a macro that invokes the Word command. You cannot create a custom button to replace one of Word's standard buttons without creating the macro first.


2.
If the toolbar is visible, open the Tools menu and select the Customize option. Click on the Toolbars tab if it is not already selected. Alternately, you can open the View menu, select the Toolbars option, select the toolbar in the Toolbars list box in the Toolbars dialog box, and click on the Customize button. Either procedure opens the Customize dialog box and displays the Toolbars tab.


3.
In the Customize dialog box, select the macro, font, AutoText entry, or style item Categories list box.


4.
Select the macro, font, AutoText entry, or style for which you want to create the custom button in the list box that replaces the Buttons group. Drag the item from the list box and drop it on your toolbar. A generic button appears on the toolbar and the Custom Button dialog box appears.


5.
In the Custom Button dialog box, click on the Edit button. The Button Editor dialog box appears.


6.
In the Button Editor dialog box, select a color (including Erase) from the palette presented in the Colors group. Click on any square in the Picture grid to fill that square with the selected color.


7.
Click on the arrow buttons in the Move group to move your image one square in the direction of the arrow on the Picture grid.


8.
Once you have created the button image, click on OK. (If you need to start over, click on the Clear button.) Word adds the button you have created to the toolbar.


9.
When you are finished creating custom buttons, click on Close in the Customize dialog box.
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How do I change the menu?

Word's menu is the main access to all of the features offered by the word processor. However bright Word's designers were, they may not have found the optimal organization of commands for you. You may prefer Spelling to appear on the Edit menu because you check spelling as a part of the editing process. You may also prefer a single menu of your own that contains the commands you use most frequently. Or you may want to create an all-new custom menu that loads documents specific to your company, such as timesheets, purchase orders, vacation requests. Such custom menus can save you countless keystrokes and mouse clicks as you work. With Word 95 you can create these types of custom menu options.

Solution


1.
Open the Tools menu and select the Customize option. The Customize dialog box appears. Select the Menus tab if it is not already selected.


2.
If you want to add a menu to the menu bar, rename an item on the menu bar, or delete a menu from the menu bar, click on the Menu Bar button. The Menu Bar dialog box appears.


3.
To add an item to the menu bar, enter its name in the Name on Menu Bar text box. Place an ampersand (&) before the hot key for the menu item. Select a position for the item in the Position list box. You can place the item as First or Last, in which case you add it to the menu bar by clicking on the Add button. If you select an existing menu bar item as the position, the Add button becomes the Add After button. Click on it to add the new item to the left of the item you have selected.


4.
To delete an item from the menu bar, select it in the Position on Menu Bar list box and click on the Remove button.


5.
To rename a menu bar item, select its name in the Position on Menu Bar list box, enter the new name in the Name on Menu Bar text box, and click on the Rename button.


6.
When you have finished working with the menu bar, click on Close in the Menu Bar dialog box.


7.
You can work with individual menus in the Customize dialog box, which remains open after you close the Menu Bar dialog box. Select the category of menu commands you want to work with in the Categories list box. (You can also select macros, fonts, AutoText entries, and styles from this list box.) Select the command you want to work with in the Commands list box. (The list of commands includes the separator line that appears on menus.) Select the menu to modify using the Change What Menu drop-down list box. The Name on Menu text box shows the name of the command you have selected in the Commands list box. Use the Save Changes In drop-down list box to select the document template that will contain the menu. Saving the menu to NORMAL.DOT makes the menu available in every document; saving to another template makes the menu available only to documents based on that template.


8.
To add the command you have selected, use the Position on Menu drop-down list box. The Auto position allows Word to add the item at a position predetermined by the Word designers for that item. The At Top and At Bottom positions cause the new item to be added to the beginning of the menu. If you select these positions, click on the Add button to add the item. If you select an existing menu item as the position, the Add button becomes the Add Below button. Click on it to add the new item below the existing item. You can use a name for the item other than that supplied by Word by typing it in the Name on Menu text box. (For some commands, however, Word may not make this option available.)


9.
To delete a menu item, select the menu containing the item in the Change What Menu drop-down list box and the item to delete in the Position on Menu drop-down list box. Click on the Remove button.


10.
You can rename menu items. When it is possible to do so, Word activates the Rename button. To rename an item, select the item in the Position on Menu drop-down list box, select the command named by that item in the Commands list box, and enter the new name in the Name on Menu text box. Click on the Rename button.


11.
If you make mistakes or want to reset the menus for other reasons, click on the Reset All button. Clicking on this button returns the menu to its default state after installation. Word activates this button after you have made changes. If there are no changes to reset, the button is not active.


12.
Click on Close in the Customize dialog box when you have finished changing the menu.
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How do I change the key assignments?

Keystrokes are the heart of word processing. You use them not only to enter characters, but to invoke commands. The use of a single keystroke to invoke a command, style, or macro can save both time and effort while you work. Although Word maps your keyboard to assign keystrokes to common commands and styles, you may need to assign additional keystrokes to accommodate your custom styles and commands. You also may want to reassign the keys so that the keystrokes are easy for you to remember. You can easily remap the keyboard to suit your taste.

Solution


1.
Open the Tools menu and select the Customize option. The Customize dialog box appears. Select the Keyboard tab if it is not already selected.


2.
Use the Save Changes In drop-down list box to select the document template that will contain the key assignments. Saving the key assignments to NORMAL.DOT makes them available in every document. Saving to another template makes them available only to documents based on that template.


3.
Select the category of commands to assign to keys in the Categories list box. You can select macros, fonts, AutoText entries, and styles as well as commands. Select the specific command to assign using the Commands list box. Any current key assignment for that command appears in the Current Keys list box.


4.
Click on the Press New Shortcut Key text box, or press the Tab key until this text box has the focus. Press the key combination you want to assign to the command. The name of the keystroke combination appears in the Press New Shortcut Key text box, and the names of any current commands assigned to that set of keystrokes are displayed in the area directly below the text box.


5.
Click on the Assign button to assign the keystrokes to the command.


6.
To remove a keystroke from the selected command, select the name of the keystroke in the Current Keys list box and click on the Remove button.


7.
To reset key assignments to the defaults at any time, click on the Reset All button.


8.
Click on Close when you are finished changing key assignments.

Chapter 12: Creating Macros

None of this applies to Word 97 or Word 2000 which work with Visual Basic for Applications Macros. Working with macros in Word 95 is rewarding and frustrating. The greatest benefit of macros is that you can program Word so that it looks and functions exactly as you want. Two of the frustrations are that Word 2.0 macros may not convert exactly and that advanced macros require some programming skill. This chapter is designed to provide solutions to common problems so that you can create macros that run well on the first try. 
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The topics covered are the following:



How do I convert my older Word macros to Word 95?



Is WordBasic similar to Visual Basic for Applications?



How do I customize a Word command?



How do I create a dialog box in WordBasic?



Can I use WordBasic to sort the items in a list box?



Can I use bookmarks with WordBasic to insert text?



Can I make my macros execute-only?



Can I convert dollars and cents to words describing the amount?



Can I copy macros from one template to another?



How do I keep from getting errors in macros that I have recorded?



How do I test for errors in a macro?



How do I test a macro?



How do I debug a macro?



What are the auto macros and how do I use them?



What are the reserved bookmarks and how do I use them?



Can I create a macro that modifies other macros?
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How do I convert my older Word macros to Word 95?

If you created macros in Word 6, you will probably have to make very few changes in Word 95, beyond adjusting your macros to take advantage of new Word features. New and revised macro commands appear in Appendix B.

Occasionally, when a macro deals with areas specific to the underlying operating system, it may require editing to reflect the differences between DOS/Windows 3.1 and Windows 95. Commands that may need editing to run under Word 95 in the Windows 95 environment include: Declare; ExitWindows; FileOpen; GetPrivateProfileString$() and SetPrivateProfileString; GetProfileString$() and SetProfileString; GetSystemInfo$(); Shell; and ToolsAdvancedSettings. 

Word 1 and Word 2 macros may require more extensive changes, however, as discussed below.  

Solution

Word 95 automatically converts Word 2.0 macros the first time you open the template containing the macros. Word 1.x macros need to be converted to Word 2.x macros first, and then they can be converted by Word 95. Convert Word 1.x macros to Word 2.x macros the same way you convert Word 2.x macros to Word 95: open the Word 1.x template in a version of Word 2.x.

Word 95, however, cannot convert all of your Word 2.0 macros. Some things have changed so drastically that they cannot be converted. Most of the harmless incompatibilities have been dealt with by Word's designers. If you open a macro for editing, you might see WW2_ prefixed to some of the commands. These are Word 2.0 commands that no longer appear on the Word 95 menu. In most cases, they function as they did before, but they no longer have menu equivalents and you cannot associate a dialog box with them.

Briefly, you may need to hand-edit your Word 2 macros if you have used one of the following techniques:



Testing for paragraph marks. (The method for testing has been simplified and you need to convert to that method.)



Using the GetProfileString$() or SetProfileString functions. 



Using error handling routines to trap specific errors. (WordBasic now has more specific error messages. You may be trapping the wrong error message using your old routine, or you may need to trap additional error messages.)



Using a name for a variable, subroutine, or user-defined function that is reserved for use by WordBasic only. (WordBasic has many new reserved words. You may have named a variable or one of your own functions using one of these names. You will have to change such names to use your macros with Word 95.)



Making assumptions about specific Word 2.x limits, such as the number of open documents allowed. (Word 95 has fewer limits. You need to make sure that your code supports the new limits. There is, for instance, now no fixed limit on the number of open documents.)



Creating your own dialog boxes. (Your dialog boxes may not format correctly after the conversion. You may need to redraw them using the Word Dialog Editor.)



Cutting or pasting text. (Word 95 has smart cutting and pasting. You may wish to take advantage of this new feature.)



Using the SendKeys function. (The keystrokes you need to send may have changed since Word 2, and the conversion process does not convert keystrokes that are arguments to SendKeys. You need to make the changes yourself.)

Other excellent resources for discovering what you need to change or update are the Microsoft Word Developer's Kit and the Microsoft Developer Network Development Library, both available from Microsoft.

The ease with which you can convert macros depends on the level at which you program macros. If you record all of your macros and edit them only to add lines like OnError Resume Next, your macros should convert painlessly. The more macro programming you have done, however, the more likely you are to have used one of the incompatible programming methods. If you program macros extensively in WordBasic, you should strongly consider getting the developer's resources mentioned in the previous paragraph to help you make the conversion.
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Is WordBasic similar to Visual Basic for Applications?

Every developer has heard about Visual Basic for Applications, largely because Microsoft has given it so much advertising attention lately. Word 95's WordBasic, while a full-featured language in its own right, is not Visual Basic for Applications. VBA, as it is sometimes called, is in Microsoft Excel and Microsoft Project, but according to Microsoft it will not appear in Word until the next major revision. VBA is the Macro language in Word 97 and Word 2000.
How can you use VBA with Word so that you can take advantage of new features like OLE Automation? There are a couple of possibilities.

Solution


1.
Is your application one that integrates Word with Excel or Project? If so, can you run the application from either of these two applications? If you can, you can use Visual Basic for Applications to control Word. You'll still have to know WordBasic syntax to control Word's features, but you gain the advantage of VBA's advanced features.


2.
If you have to control your application from Word, can you run parts of it under Excel or Project? If so, you can use Visual Basic for Applications when you shell out to Excel or Project.


3.
Can you build the parts of your application that are external to Word in the nonapplications (regular or professional) edition of Visual Basic itself? If so, you may be able to capture the same functionality by using the VBX controls provided by Microsoft and other suppliers. You can build dialog boxes and other windows that exist external to Word and keep the fancy logic and programming within these windows, using WordBasic only when necessary internally within Word.

Return to Table of Contents
Problem

How do I customize a Word command?

At some point you may wish that the Word designers would have created their commands differently. For example, you may want print preview mode to zoom to a percentage other than the default 44%. Is there any way you can redesign Word commands?

Actually, there is a way, but it takes a little ingenuity. You cannot change what a Word command or its equivalent WordBasic command does. You can, however, create a macro that surrounds the command with other commands that produce the results you desire. You can attach this macro to a menu item, toolbar button, or key assignment and use it instead of the command the Word designers created.

Solution


1.
Double-click on the REC box on the status bar to start the macro recorder. (You can also start the recorder from the Macro dialog box, which you open by selecting the Macro item from the Tools menu.)


2.
In the Record Macro dialog box, type a name for the macro in the Record Macro Name text box and a description in the Description text box. In the Make Macro Available To drop-down list box, select the template to contain the macro. You can use the name of the Word command for your macro, but it is better to use a standard naming convention for the macros you create to customize Word commands. For example, you could use the prefix My attached to the name of the Word command, as in MyFileExit.


3.
Click on the Toolbars, Menus, or Keyboard buttons to assign the macro to a button, menu, or key. For instructions on using the tabs in the Customize dialog box, see Chapter 11, "Customizing Word." If you want to use an existing toolbar button for your modified command, you will have to create a duplicate using the button editor. You can name the menu item associated with a command anything you want; therefore, you can use Word's built-in menu names for your modified command. Click on the Close button to exit the Customize dialog box and start the recorder. The Recorder toolbar appears.


4.
Take the mouse and menu actions you want to record, including the command you want to change, and then click on the Stop button on the Recorder toolbar.


5.
Open the Macro dialog box using the Macro item on the Tools menu. Select the macro you just recorded in the Macro Name combination box and click on the Edit button.


6.
Make any changes in the macro that you need to make. For instance, you might want to add an OnError command of some sort to handle any errors that might occur. Once you have finished modifying the recorded macro to suit your needs, close the document window containing the macro.
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How do I create a dialog box in WordBasic?

WordBasic enables you to display and use any of Word's built-in dialog boxes as part of your macros. You may, however, need to create your own dialog boxes. Two methods are available for creating dialog boxes. The first method is to write WordBasic code that creates and displays the dialog box; you then run the code to see what it looks like. Trial and error perfects the dialog box until it is the way you want. The second and preferred method, however, is to use the Word Dialog Editor, which you can use to draw a picture of your dialog box. The Word Dialog Editor creates the code for the dialog box from your drawing.

Solution


1.
Open the Word Dialog Editor. If no program item icon appears for the Word Dialog Editor, you can run the file \WINWORD\MACRODE.EXE.


2.
When the Dialog Editor starts, it creates a new dialog box for you. You can also create a new dialog box at any time by executing the New command on the File menu.


3.
To add controls to your dialog box, select the type of control to add from the Item menu. A control will appear in the dialog box. Some controls (Button, for instance) present a dialog box that asks which specific type of the control you want to use. Select the type using the option buttons in the dialog box, and click on OK. The type of control you defined appears in the dialog box.


4.
Position controls by dragging them to the location where you want them to appear. Drag on the control's frame to change its size. To align controls relative to one another, place the first control of its type where you want it, and then add the rest of the controls of that type. For example, add an OK button and drag it into position. Then add all the other push buttons, including Cancel, that you plan to use. The buttons are added in a neatly aligned vertical stack. To group controls, first insert the Group Box, select it, and then add the controls that belong to it.


5.
To modify the properties of a control, double-click on it. The Word Dialog Editor displays the information dialog box for that control. You can use the controls in the dialog box, which are different for each control type, to adjust the size, position, and characteristics of the control.


6.
After you are finished creating and adjusting controls, exit the dialog editor using the Exit command on the File menu. You are then prompted to save the dialog box to the Clipboard. Click on the Yes button.


7.
Open the document window for your macro. Next, open the Edit menu and use the Paste item to insert the dialog commands into your macro.


8.
You need to add a Dim statement after the block of commands you have inserted. The Dim statement prepares to display the dialog box. You also need to add a Dialog command to display the dialog box. Use a variable to collect the return code from the Dialog command so you can check for errors. The code to create and display a simple About dialog box appears as follows:

 Rem The six lines below were pasted from the Dialog Editor

 Begin Dialog UserDialog 340, 144, "Write Environment"

 
Text 97, 15, 170, 13, "Write Environment"

 
Text 121, 40, 98, 13, "Version 2.0"

 
OKButton 109, 102, 88, 21

 
Text 51, 70, 240, 13, "Copyright 1993 Forrest Houlette"

 End Dialog

 Rem The two lines below were added by hand to display

 Rem the dialog box

 Dim Dlg As UserDialog

Trap = Dialog(Dlg)
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Can I use WordBasic to sort the items in a list box?

In Word 2.0's WordBasic, the only way to sort items in a list box was to include them in the right order when you added them to the list box. This sorting method did not work under all circumstances, such as when the user enters items into a dialog box for displaying later in a list box. The only alternative was to sort the array that contained the desired items. The sorting took place prior to adding the items to the list box, and you had to write the sort procedure in WordBasic. This alternative was usually a slow procedure. Since Word 6, WordBasic enables you to sort the items intended for a list box before adding them by using a special sort function. This sort function is faster and more efficient than the old alternative.

Solution


1.
Write the WordBasic code that creates the array you intend to use to fill the list box.


2.
Use the SortArray command to sort the array. The syntax for this command is as follows:



SortArray ArrayName[$]() [, Order] [, From] [, To] [, SortType] [, SortKey]



ArrayName[$]() is the name of the array that contains the items for the list box.



Order is 0 for ascending and 1 for descending. If you omit this item, 0 is the default.



From is the index of the first element in the array to sort. If you omit From, the default is 0.



To is the index of the last element in the array to sort. If you omit To, the default is the last element of the array.



SortType is 0 to sort the rows of the array and 1 to sort the columns of the array. If you omit SortType, the default is 0. You must have a two-dimensional array to be able to sort the columns.



SortKey indicates which row or column to sort. SortType determines whether you are performing a row or column sort. SortKey is 0 if the first element in the row or column is used to determine the sort, 1 if the second element is used. You must have a two-dimensional array to use SortKey. If you omit SortKey, the default is 0. In a row sort of a two-dimensional array, for example, SortKey is 0 if you want to sort by the items in the first column, and 1 if you want to sort by the items in the second column. If column 1 contains first names and column 2 contains last names, a SortKey of 0 sorts the array by first name, a SortKey of 1 sorts the array by last name.


3.
Use ListBox, ComboBox, DialogListBoxArray, or DropListBox to fill the list box.

The following code fragment fills an array for a combination box, sorts it, and displays it in a dialog box:

Rem Dimension the array

Dim ComboBox1$(17)

Rem Insert items in the array

ComboBox1$(0) = "Classical Topics"

ComboBox1$(1) = "Actions"

ComboBox1$(2) = "Cubing"

ComboBox1$(3) = "Scamper"

ComboBox1$(4) = "Questions about Art"

ComboBox1$(5) = "Questions about a Concept"

ComboBox1$(6) = "Questions about a Dilemma"

ComboBox1$(7) = "Questions about a Group"

ComboBox1$(8) = "Questions about an Object"

ComboBox1$(9) = "Questions about a Place"

ComboBox1$(10) = "Questions for Self-Evaluation"

ComboBox1$(11) = "Questions about Someone You Know"

ComboBox1$(12) = "Questions about Someone's Life"

ComboBox1$(13) = "Questions about Someone You Have Studied"

ComboBox1$(14) = "Reporter's Formula"

ComboBox1$(15) = "Pentad"

ComboBox1$(16) = "Synectics"

ComboBox1$(17) = "Tagmemics"

Rem Sort the array

SortArray ComboBox1$()

Begin Dialog UserDialog 524, 206, "Ideas"

Rem The next command inserts the array into the combo box


ComboBox 22, 39, 364, 150, ComboBox1$(),.ComboBox1


Text 21, 17, 368, 13, "Select a method for exploring ideas:"


OKButton 417, 19, 88, 21


CancelButton 417, 43, 88, 21

End Dialog

Dim Dlg As UserDialog

Trap = Dialog(Dlg)

Problem
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Can I use bookmarks with WordBasic to insert text?

Often you want to insert text at definite locations within a document, for instance when entering information in a boilerplate contract. You can collect the information in a custom dialog box, but how do you insert the information where it ought to go? The answer is to insert the text at bookmarks that mark the locations.

Solution


1.
As you build your document, insert bookmarks to indicate where the information must go. Keep track of the names you give the bookmarks, because you need to use those names in the macro you create to insert the information.


2.
Use the EditGoTo command to move to the bookmark you want. The syntax is quite simple: EditGoTo NameOfBookmark$. The following example moves the insertion point to the bookmark named One:



EditGoTo "One"


3.
Use the Insert command to insert the text. The syntax is as follows: Insert Text$. The following example inserts the name stored in Name$ at the bookmark we moved to in step 2:



Insert Name$
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Can I make my macros execute-only?

When you distribute macros to colleagues or within your organization, you may not want the recipients to be able to read the macro code. One reason for hiding the code is to prevent inexperienced users from changing it by accident while exploring the Macro option on the Tools menu. Another reason is that you might have a considerable investment in developing the macros, and want to protect that investment. You also might feel your macros give your company a competitive edge you do not want others to have. You can hide the code by making your macros execute-only.

Solution


1.
Use the MacroCopy command to copy the macro to a new name and set the ExecuteOnly switch. The syntax for this command is as follows:



MacroCopy [Template1:]Macro1$, [Template2:]Macro2$ [, ExecuteOnly]



Template is the name of the template containing the macro.



Macro$ is the name of the macro.



ExecuteOnly makes the copied macro execute-only; it runs, but you cannot view the code.



The following command copies a macro from the Wedlg template to the We template, converting the copied macro to execute-only form:



MacroCopy "Wedlg:Audience", "We:Audience", ExecuteOnly


2.
When you develop macros, it is wise to develop two templates: one that contains the macro code and one that contains the execute-only versions. In your development template, build a macro that contains MacroCopy commands for each macro that you intend to distribute. Distribute only the template containing the execute-only versions. Users can either load this template globally or copy the macros to a template of their own.
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Can I convert dollars and cents to words describing the amount?

You have a set of monetary amounts expressed in digits representing dollars and cents. Can you convert these amounts to words that express the same thing? If you pull data out of a spreadsheet and insert it into Word documents, you might frequently encounter this problem. Fortunately, WordBasic provides two statements that help.

Solution


1.
The WordBasic command Str$(n) returns the string representation of the value represented by n. As an example, the string representation of the value 22 is twenty-two. Depending on the context in which you are making the conversion, you might have to strip the dollar sign from the number you are converting. You might also have to break the number at the decimal point and convert its two parts separately. You definitely need to take care in structuring the document text so that the converted number fits into the sentences correctly.
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Can I copy macros from one template to another?

A problem with macros is that you have to store them in a template. What do you do if you want to share your macros with others? In addition, what if those macros are in three different templates? Fortunately, Word provides two facilities for copying macros. One method, which uses the MacroCopy command, is described in Can I make my macros execute-only? earlier in this chapter. The other method, which utilizes the macro organizer, is covered here.

Solution


1.
Open the Tools menu and select the Macro item.


2.
In the Macro dialog box, click on the Organizer button.


3.
In the Organizer dialog box, use the Macros Available In and Macros Available In drop-down list boxes to open the source and destination templates. If the file you need is not available on the list, click on the Close File button. After the file closes, the button converts to the Open File button. Click on it and use the Open dialog box to locate the appropriate file. It does not matter which side of the organizer contains the source and destination templates. The Copy button arrow reverses direction as needed, and the In and To labels change position as necessary.


4.
Select the macros you want to copy in one of the list boxes. You can select multiple items by holding down the Ctrl key as you click with the mouse.


5.
Click on the Copy button to complete the copying operation.


6.
Click on the Close button in the Organizer dialog box after you finish copying macros.

Note that the Macros tab in the Organizer dialog box also allows you to rename and delete macros. It does not, however, allow you to make them execute-only.

The above applies to Word 97 except that what can be moved, copied, and renamed in the Macro Organizer are Macro Modules or Project Items.
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How do I keep from getting errors in macros that I have recorded?

Recording is the easiest way to create a macro. Once you start the macro recorder, each action you take with Word is recorded as a WordBasic command. When you run the macro, these commands are replayed to Word in the same order as you took the actions that invoked the commands. Recorded macros, however, sometimes produce seemingly random errors. Sometimes they work; sometimes you see an error dialog box and the macro runs only part way. Is there a way to prevent such errors from occurring?

Solution

Recorded macros often work perfectly every time. When they fail in this sometimes random fashion, the cause is almost always a command that cannot fully execute. For instance, if your macro contains an UnlinkFields command and your document contains no fields, WordBasic presents an error dialog box on the screen and halts execution of the macro.

For better or worse, WordBasic reports an error and halts execution whenever a command cannot execute. In a recorded macro, the results are frustrating; the macro only executes part way. Actually, WordBasic's behavior is intended to be helpful. By presenting the error, WordBasic is providing you the opportunity to handle the error. Recorded macros, however, do not include error handling routines.

As a result, the solution is to add an error handling routine to your macro. To do so, follow these steps:


1.
Open the Tools menu and select the Macros option.


2.
In the Macro dialog box, use the Macros Available In drop-down list box to select the template containing the macro. Then select the macro to modify in the Macro Name text box and click on the Edit button. Word opens a macro editing window, displays the Macro Editing toolbar, and displays the code for the macro in the macro-editing window.


3.
After the Sub Main statement in the macro, add the following line: On Error Resume Next. (Note: Do include the spaces.)


4.
Close the macro file by selecting Close from the File menu. When asked whether to save, click on the Yes button.


5.
When you exit the document or when you exit Word, you will be asked whether to save the document template. Click on the Yes button in the message box, otherwise the change in your macro will not be saved.

The line you added instructs Word to ignore any errors and to restart the macro at the line following the line that caused the error. This is not sophisticated error handling. Using On Error Resume Next presumes that the error is inconsequential to your work and that the line causing the error does not need to execute. For nearly all your recorded macros, this assumption is valid. However, if it is not valid, you should include more sophisticated error handling. (How do I test for errors in a macro? in this chapter describes how.)
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How do I test for errors in a macro?

Errors occur in any program, WordBasic programs being no exception. In fact, WordBasic intentionally generates errors to tell you about how the processing of the macro statements is going. If you trap these errors and evaluate them, you can respond to the situation created by your macro by resolving common problems like a disk not being inserted in a drive before continuing processing. How do you trap errors?

Solution

WordBasic provides two means of responding to an error condition. You can use one of the following two statements to handle errors:



On Error Resume Next



On Error Goto Label

These statements should appear at the beginning of your macro. Errors in any commands that precede them will not be trapped. Each command takes a different action when an error appears. On Error Resume Next notes what error has occurred, stores the number of that error in a variable named Err, and then immediately resumes execution of the macro with the next command. In effect, Word ignores the error. On Error Goto Label has a slightly different effect. It notes the error that has occurred, stores the number of that error in Err, but then branches to the label you supplied and continues execution with the first command after the label.

On Error Resume Next works well in situations where it does not matter which error occurred. On Error Goto Label works well in situations where it does matter which error occurred. The statements following the label handle the error. Usually you find out the error number stored in Err and then execute WordBasic statements to correct the error condition. You can then branch back to the statement where the error occurred using the Goto Label command and resume execution of the macro.

After you have handled an error, it is wise to reset the value of Err to 0. Doing so informs Word that no error is currently active. If you want to completely disable error handling after you have responded to an error, you need to inform Word to reset error handling. You do so by including the following command: On Error Goto 0. This command instructs Word not to use the label to which you just branched for handling the next error. It also sets Err equal to 0. After executing On Error Goto 0, you must include another error-handling statement in your macro, otherwise Word responds to the next error by presenting an error dialog box and halting execution of your macro.

The following two annotated code fragments demonstrate the use of error handlers. The following macro performs all of the actions necessary to finishing a chapter for a book:

Sub MAIN

Rem Set the error handler to resume execution with the next statement.

On Error Resume Next

Rem Select all, reset paragraph indentation, update fields, unlink

Rem fields, go to the start of the document, perform a spelling check,

Rem do a search and replace to remove double spaces after sentences,

Rem and save in WinWord 2.0 format.

EditSelectAll

FormatParagraph.RightIndent = "-0.5" + Chr$(34)

UpdateFields

UnlinkFields

StartOfDocument

ToolsSpelling

EditReplace.Find = " ",.Replace = " ",.Direction = 0, _.MatchCase = 0,.WholeWord = 0,.PatternMatch = 0, _.SoundsLike = 0,.ReplaceAll,.Format = 0,.Wrap = 1

FileSaveAs.Format = 105,.LockAnnot = 0,.Password = "", _.AddToMru = 1,.WritePassword = "",.RecommendReadOnly = _0,.EmbedFonts = 0,.NativePictureFormat = 0,.FormsData = 0

End Sub

In this macro, only two of the commands could fail to execute in a document containing as much text as a chapter, those referring to fields. The only reason for an error to occur is that fields do not appear in the document. In this macro, therefore, it is safe to use On Error Resume Next. If an error occurs, the command producing the error is not needed. Execution can safely resume with the next command in the sequence.

The next macro is an AutoExit macro that cleans up as a document of a certain type exits. Note the use of On Error Goto Label:

Sub MAIN

Rem Go to the label Hop: if an error occurs.

On Error Goto Hop

Rem Try to activate the help window containing the file "Process

Rem Cues." If the help window cannot activate, an error occurs.

Rem Resume execution at the label Hop:.

AppActivate "Process Cues"

Rem If no error occurs, send the key sequence to close the help

Rem window and execute the remaining commands in sequence.

SendKeys "%fx"

AppActivate "Process Cues"

Hop:

Rem Cancel error handling because the next error must be _handled by a

Rem different label.

On Error Goto 0

Rem Set the new error handler.

On Error Goto Hop2

Rem Try to activate the help window containing the file "Write

Rem Environment Help." If the help window cannot activate, an error

Rem occurs. Resume execution at the label Hop2:.

AppActivate "Write Environment Help"

Rem If no error occurs, send the key sequence to close the help

Rem window and execute the remaining commands in sequence.

SendKeys "%fx"

AppActivate "Write Environment Help"

Hop2:

End Sub

In each error handler, the AppActivate command is used deliberately to generate an error if it is possible to do so. If the error occurs, two commands are skipped because they are unnecessary. If the error does not occur, the two commands are executed. After each error handler, On Error Goto 0 is used to reset error handling, and a new On Error Goto Label statement reestablishes error handling with an appropriate label name.

Problem

How do I test a macro?

Recording and writing macros requires a testing phase. You have to find out if your macro works. Are there any general guidelines to follow when testing a macro?

Solution

To test a macro, you run it to see what happens. If the macro does not work, proceed to the stage of debugging, covered in How do I debug a macro? in this chapter. When you test your macro, you should have its macro editing window open to take advantage of the Macro toolbar's testing aids. You cannot run your macro while its editing window is the active window, however. You must make a document window active and run the test from the Macro toolbar, which remains available as long as you have the macro editing window open.

The Macro toolbar offers the following buttons that can help with testing.



Start runs the active macro, the name of which is always shown in the Active Macro drop-down list box on the left side of the toolbar. You can change the active macro if you want by selecting a new macro name from this list. Your first step in testing should be to run the macro to see what happens.



Trace runs the active macro with a slight variation. Each command in the macro editing window is highlighted as it runs. If you arrange your document windows so that the active document and the macro editing windows are both visible, you can both watch the actions performed and see which lines are responsible for them. This is a variation of the testing procedure that provides more information to you about which line caused the problem, if a problem should occur. If a problem does occur, Word highlights the command that caused it.



Continue restarts the running of a macro if it has stopped for some reason. You might have stopped it using the Stop or Step buttons, for instance.



Stop halts the execution of a macro. This button is extremely useful if your macro continues executing after it should have stopped.



Step causes one command in a macro to execute and then stops the macro. You can click on Step repeatedly to work through a macro line by line, or you can click on Continue to allow the remainder of the macro run without interruption.



Step Subs functions exactly like Step, except it does not pause after each action taken when you run a macro from within a macro. Step Subs pauses only after the commands in the active macro's editing window are completed. If the active macro were to have a macro you have written as one of its commands, which is perfectly allowable, Step Subs does not pause after the execution of each command in the embedded macro. It pauses again when it encounters the next command after the embedded macro, whereas Step would pause after each command in the embedded macro. Step Subs is useful when you know that all the commands in the embedded macro are running properly.
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How do I debug a macro?

Debugging is the process of finding and fixing errors in your macro. It can be tedious and time-consuming. Are there any guidelines to help focus and speed debugging?

Solution

If you have recorded your macro, your first step in debugging should be to re-record the macro. If this course of action solves the problem, you do not have to proceed further. If recording again does not solve the problem, use the Step button on the Macro toolbar to move through your macro line by line. (See the instructions in How do I test a macro? in this chapter.) You need to have both your active document and your misbehaving macro visible on your screen. Also follow the following commonsense rules:


1.
Word is doing exactly what you told it to do, which is not necessarily what you want it to do. You need to look first at what you told Word to do to see if you can find the problem. For instance, if a paragraph format is not set correctly, did you set it correctly in the dialog box when you recorded the macro? Chances are that the source of the problem is something that you said to do that was not what you intended to say.


2.
WordBasic commands consist of a name and some parameters that the command might require. The name of the command invokes the action named. Most WordBasic commands are named after the menu items that you use when you take the same action by hand, as in FileSaveAs. Some command take no parameters, others do. Parameters can appear as an item or list of items separated by commas in parentheses after the command name, as in AppMaximize("Microsoft Excel"). Parameters can also appear as an item or list of comma-separated items following the command name, as in Font "Arial",8. Parameters can also appear in similar list, but in a form wherein some begin with a period and have an equal sign followed by a value, as in EditReplaceFind.Find=" ",.Replace="",.Direction=0,.MatchCase=0. In this form of a WordBasic command, each item beginning with a period serves to represent the state of a dialog box control bearing a similar name. The value after the equal sign, if it is present, represents the state of that dialog box control. Violating these conventions when editing by hand always leads to problems.


3.
There are just a few things, really, that can go wrong in writing a macro. The following list describes these possibilities, along with common symptoms:




Infinite Loops. The macro just keeps on running and will not stop unless you click on the Stop button on the Macro toolbar. The most likely cause is a command that causes the macro to execute a second command, which in turn causes the first command to be re-executed, causing the second to re-execute, and so on. The most likely cause in a recorded macro is an incorrect On Error statement. Examine the macro carefully using the Step button on the Macro toolbar. When you have found the two statements that are calling each other, break the chain of calls the most convenient way.




Misspelled Statements. You receive a Syntax Error or a Label Not Found Error. Word cannot compensate for your mistakes in typing. Prevent this by recording commands whenever possible. (The Record Next Command button on the Macro toolbar lets you insert a new command into an existing macro by recording it rather than typing it yourself.) Correct it by comparing what you typed, character by character, to the examples given in the WordBasic Help File, accessible from the Word Help contents by clicking on WordBasic Reference.




Extra Characters. You receive any of a variety of errors, but they will all have "incorrect" or "missing" or a similar word in their description of the problem. Word is interpreting the extra characters as a part of a command and cannot make sense of the command. The solution is to compare what is in the macro editing window character by character to the example in the WordBasic help file.




Incorrect Information. Your macro does not do what you want it to do, but everything else seems correct. Check the values you have assigned to the parameters of your commands; one of those is probably wrong. The easiest way to correct the problem is to select the problem command, switch to an available document, and re-record the command using the Record Next Command button while paying close attention to the settings in the dialog boxes you use. If you have typed the command because you cannot record it, select the command and retype it.

Debugging a macro can be frustrating. It can be so frustrating that continuous long efforts at debugging are usually unproductive. You easily can get trapped in a rut and not see the problem from a fresh perspective. Debugging is best done in short bursts with breaks in between. Stay with the procedures suggested in this section for the best results. Change only one thing at a time in your macro between each test run. If you change more than one command, you might fix the problem you had and introduce another one.
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What are the auto macros and how do I use them?

I have heard of automatic macros in Word. What are they and how do I use them?

Solution

Word provides five macros that, if they exist in your template, run automatically when certain events occur.



AutoExec

When Word starts



AutoNew

When a new document is created



AutoOpen

When you open a document that already exists



AutoClose

When you close a document



AutoExit

When you exit Word

These macros can contain any commands that you want to execute when one of these events occurs. AutoExec runs automatically only from NORMAL.DOT. The rest will function from any template.

Examples of using these macros are easy to think of. As is noted in Can Word automatically open a document based on a template other than NORMAL.DOT on startup? in this chapter, AutoExec can be used to open a document based on another template besides NORMAL.DOT. AutoNew can be used to display the Save As dialog box as soon as the document is open, strongly suggesting to users that they should save the file immediately. AutoOpen can be used to display a custom toolbar unique to the template the document is based on. AutoClose can be used to remove the specialized toolbar if there are no other documents based on the template open. AutoExit can be used to reset default settings that may have been modified by different templates.

Note: You can prevent an auto macro running by holding down the Shift key as you open or close Word or a document. For example, if you press Shift while you click OK in the File, New dialog box, no AutoNew macro will run.
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What are the reserved bookmarks and how do I use them?

What are reserved bookmarks? What does Word use them for? How can I use them in my macros?

Solution

Reserved bookmarks are like any other bookmark in Word: they mark a specific location in a document. They are reserved because Word itself uses them within its program code to identify locations in a document. As a result, you cannot use bookmarks of the same name when you create your own bookmarks.

You can use the reserved bookmarks, shown in Table 12.1, in any of your macros. If you need to move to one of the locations noted, you can use EditGoTo to move to that location. You can also use them with the DDEPoke command to insert information at one of these locations. The \EndOfDoc bookmark is especially useful for this purpose.

Table 12.1

Reserved Bookmarks in Word

Bookmark

Location

\ Sel


Active selection or the location of the insertion point.

\ PrevSel1

Last selection you edited. The same as running the GoBack 




statement once.

\ PrevSel2

Second to last selection you edited. The same as running the GoBack 




statement twice.

\ StartOfSel

Beginning of the active selection.

\ EndOfSel

End of the active selection.

\ Line


Current line or the active selection's first line. Includes the next line




if the insertion point is at the end of a line, but is not at the last line of 




the paragraph.

\ Char


Current character or the active selection's first character. If there is no 




selection, the character following the insertion point.

\ Para


Current paragraph or the active selection's first paragraph.

\ Section

Current section including the following section break or the active 




selection's first section.

\ Doc


The complete contents of the current document, but not including the 




last paragraph mark.

\ Page


Current page including the page break at the end of the active 




selection's first page.

\ StartOfDoc

Beginning of the document.

\ EndOfDoc

End of the document.

\ Cell


Currently selected table cell or the first cell in the active selection.

\ Table


The current table or the first table in the active selection.


\ HeadingLevel

The current and any subordinate headings and text, or the heading 




preceding the selected text.
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Can I create a macro that modifies other macros?

Comments are useful in macros while I develop them, but they only inflate the size of the template that I deliver to the users. Stripping comments out by hand is slow and tedious. Can I write a macro that modifies other macros; in this case, to strip comments out of other macros?

Solution

You can write macros to modify other macros. The procedure is quite simple. To strip comments, for example, you can record a macro by following these steps:


1.
Open the Tools menu and select the Macro item.


2.
Select a macro in the Macro Name list box and click on the Edit button.


3.
Double click on the REC box on the status bar to start the recorder.


4.
In the Record Macro dialog box, enter a name for the macro in the Record macro Name text box and select a template in the Make Macro Available To drop-down list box. Enter a description in the Description text box if you wish.


5.
Click on the OK button to start the recorder.


6.
Open the Edit menu and select the Find option.


7.
In the Find What text box, enter REM. Click on the Find Next button.


8.
Extend the selection to the end of the line by pressing Shift+End.


9.
Press the Delete key to remove the comment.


10.
Stop the recorder by clicking on the Stop button on the Recorder toolbar.

You can use this macro to remove comments from macros one at a time, or you can automate it by adding a loop to continue searching for remarks until there are no more in the macro. 

Chapter 13: Using Word on a Network

Word runs comfortably on a network, although several problems are common to advanced users. The most frequently asked questions include:



If my documents are available on a network, how can I keep them secure?



How can I manage revisions with others on my network?



How do I send a file via e-mail from within Word?



How do I route a file to several reviewers via e-mail from within Word?



How do I use workgroup templates?



What working habits do I need to develop if I am using Word on a network?

Return to Table of Contents
Problem

If my documents are available on a network, how can I keep them secure?

Whether you store your documents centrally on a network server, or locally on a peer-to-peer network that can enable others to access your hard disk, you may have documents that require confidentiality. Word enables you to protect your documents with a password so that others cannot open it unless they type the password first.

Solution

To protect a file with a password: 


1.
Open the file you want to protect.


2.
Choose Save As from the File menu. The Save As dialog box opens. If you are working with a new file that you haven't yet named, enter a name in the File name box.


3.
Choose Options. The Options tabbed dialog box opens to the Save tab, showing Word's options for saving files.



File-Sharing Options for the current document appear at the bottom of the dialog box. You now have three choices: 




Entering a Protection Password prevents anyone, including yourself, from accessing the file without entering the same password.




Entering a Write Reservation Password allows anyone to open and read the file, but prevents anyone else from changing it unless they enter the password first.




Checking the Read-Only Recommended box means that if a user opens the file, he or she cannot make changes to it without returning to the Options Save tabbed dialog box and clearing the Read-Only Recommended checkmark. This is, of course, the weakest form of file protection.



Note that the File Sharing options are shaded and unavailable if Word finds that you are not the original author of the document. This occurs if the author's name that was originally placed in File, Properties, Summary Info does not match the Name stored in Tools, Options, User Info tabbed dialog box on your copy of Word. Simply changing the author's name in Summary Info will not make these options available; you have to change the name stored in Tools, Options, User Info, then exit Word, restart Word, and reload the file.


4.
If you choose Protection Password or Write Reservation Password, type the password. Word will prompt you to type it again; you must type it identically, using the same capitalization and punctuation.


5.
Word now returns you to the Save As dialog box; choose OK to save the file with its password. (If you choose Close instead, the password does not take effect.) 

There are a few things you should know about Word's password protection. First, Word passwords are case-sensitive—you can't open a file unless you type the password exactly, with the same capitalization and punctuation. Second, Word passwords do not prevent you or anyone else from deleting a Word file through DOS or Windows.

By the way, you can also protect elements of a document. Using Tools, Protect Document, you can prevent any changes to a document except annotations, revision marks or filling-in of forms.
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How can I manage revisions with others on my network? 

Most documents these days are the result of collaboration among teams of people. It's common for several people to make comments on a document—comments that must be carefully tracked and integrated. Word includes revision marking, tracking, and editing features that dramatically simplify this process. These features are available through the Tools, Revisions dialog box.

Essentially, Word's Revisions feature works as follows: when you turn on revisions and start editing, both your revisions and the original text are stored in the document. You can display your revisions as colored underlined text within the document, with deletions shown as colored strikethrough text. Word also places a borderline to the left of any line that includes a revision, helping you quickly see which text has been revised.

To simplify editing, you can tell Word to track revisions in the background, in which case you edit normally without seeing any revisions until it's time for your revisions to be reviewed.

Several reviewers can insert revisions in the same document; each is assigned a different color so that you can quickly tell the reviewers' comments apart. You can choose whether they all work on the same file, or on separate copies of the same file which can then be merged.

Solution

In preparing a document for revision by others, you have a number of choices: 



You can copy the document on a floppy disk and have the reviewer use that file to make revisions. Then, when the file is returned to you, you can use Word's Merge Revisions feature to integrate each set of revisions into a single file, or...



If you are on a network, you can attach the file to an electronic mail message that includes information about your request for revisions—such as the scope of review you are requesting or the deadline for returning comments. (Using integrated e-mail from within Word is covered later in this chapter.) Once again, when the files are returned, you can use Word's Merge Revisions feature to integrate the comments into one file where you can review them all at once.

In these examples, you are creating duplicate copies of files with the same file name. When revisions are returned to you, be careful not to store them all in the same folder unless you change their names first; otherwise, you will overwrite all but one copy of the file. This is not a problem in the third and fourth scenarios: 



If your e-mail system is MAPI or VIM compatible (these include leading mail systems such as Microsoft Exchange, Microsoft Exchange, and Lotus cc:Mail), you can use Word's routing feature to send the same file consecutively to each of several reviewers. The second reviewer will not receive the file until the first reviewer has finished and forwarded it. (Routing documents is covered in more detail later in this chapter.)



If you are on a network, you can make a single copy of the file available to all reviewers in a central network folder, perhaps using Tools, Protect Document to specify that they can do nothing else except use Word's Revisions feature unless they have the document's password. In this case, you do not have to use Merge Revisions; all the revisions are already included in the same file, with each reviewer's revisions marked in a different color.

In the next set of instructions, assume that you are the document's reviewer. To mark up a document with Word's revisions feature: 


1.
Open the document you want to revise.


2.
Choose Revisions from the Tools menu. The Revisions dialog box opens.


3.
Check the Mark Revisions While Editing box.


4.
If you do not want your revisions to appear in colored text on screen while you work, clear the Show Revisions on Screen box. With this box cleared, your document edits will appear normally. Cuts you make will appear to disappear from the document. Additions you make will appear no different from the original document text. However, revisions will be tracked in the background, and you can see them at any time by reopening the Revisions dialog box and checking Show Revisions on Screen again.


5.
If you do not want your revision additions and deletions to appear as underlined and strikethrough text in printed copies of the document, clear the Show Revisions in Printed Document box.


6.
Choose OK.


7.
In the document, make all the revisions you want. When you're finished making revisions, save the file and forward it to the next reviewer or the original author. If you are on a network, you may be able to store the file in a location accessible to the next person who needs it, or you might attach the file to an electronic mail message that includes cover information about the changes you made, and overall comments about the project you're working on. (Using e-mail from within Word is covered later in this chapter.) 

In the next instructions, assume you are the document's original author, faced with the task of coordinating and integrating all the revisions that reviewers have made. First, assume that all revisions have been made in a single file. Later, you'll learn how to use Merge Revisions to combine several files containing revisions into a single document.

To review a document that has been revised using Word's Revisions feature:


1.
Open the document.


2.
Choose Revisions from the Tools menu.


3.
Choose Review. The Review Revisions dialog box appears. This box offers several choices. If you want to accept all revisions at once, choose Accept. Word will integrate all the revisions into your document—the original version of the document will disappear altogether unless you have a backup copy elsewhere. (To preview what the document would look like if you chose Accept, choose Hide Marks. To see the revisions again, choose Show Marks.) 



Conversely, if you want to reject all revisions at once, choose Reject. Word will discard all revisions from the document—the revisions will no longer exist unless you have a backup copy elsewhere.



More likely, you'll want to review the revisions one by one, and make individual decisions on each of them. To move forward within the document, click on the Find button containing the right-arrow; to move backward, click on the Find button containing the left arrow. In either case, Word moves to the next revision and highlights it.



When a revision is selected, the name or initials of the reviewer making the current revision appears in the Review Revisions dialog box, along with the time and date the revision was made. This information helps you evaluate the revision: Was it based on complete and current information? How much weight does it carry? If it conflicts with another reviewer's comments, which one should take precedence? 


4.
You now have four choices: you can Accept or Reject the individual revision, or you can double-click within the document to edit the revision, then return to the dialog box to Accept it when you're satisfied. The dialog box remains open while you work in the document. However, you have to click on the dialog box to make it active again. Occasionally, you may want to temporarily skip making a decision on a revision until you see what other comments have been made. If so, choose Find again to view the next revision.


5.
When you're finished editing revisions, choose Close.


6.
Save the updated document.

If, as discussed earlier, you now have more than one copy of your document, and you need to merge revisions before you can edit them, follow these steps: 


1.
Open the file that contains the revisions made by the first reviewer.


2.
Select Revisions from the Tools menu. The Revisions dialog box opens.


3.
Choose Merge Revisions. The Merge Revisions dialog box appears.


4.
Use the dialog box controls to find the folder containing the file where you're collecting the revisions. (The Merge Revisions dialog box behaves much like the File, Open dialog box.) 


5.
Select the file where you're collecting revisions.


6.
Choose OK. Word will now copy all revisions from the open file into the file you selected in step 5.


7.
If you need to merge files from another reviewer, close the open file. Then open the next reviewer's copy of the file and repeat steps 2-6.


8.
When you are finished merging all revisions, close the Revisions dialog box and save the file containing everyone's revisions.


9.
Choose Revisions from the Tools menu again, and begin reviewing the comments. Each reviewer's comments will appear in a different color, up to eight different colors.
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How do I send a file via e-mail from within Word?

If you're reading this chapter, you're probably on a network, and therefore, you probably have electronic mail. If so, you may be able to use your electronic mail system to send documents from within Word, or to use Word's built-in routing feature to specify a series of consecutive recipients for a document.

The benefits of e-mail and routing slips are the same as they've always been: they provide an orderly, extremely efficient way of making sure that data gets to all the people who need it. Beyond that, the return receipt feature built into most contemporary e-mail systems ensure that you know when they've received the information, so that you can monitor whether they've taken action. The benefits of e-mail and routing slip integration into Word are convenience; you may no longer have to exit Word and load a separate program to send the Word files you're creating.

In the examples that follow, assume that Microsoft Exchange is already up and running in your office, and that you have access to it. Microsoft Exchange comes with every copy of Microsoft Windows 95. The principles discussed here should work with other standards-compliant electronic mail systems for Windows, including Microsoft Exchange and Lotus cc:Mail.

Solutions

Start by examining how to send a Microsoft Word document to another computer from within Word, using Microsoft Exchange.


1.
Open the file you want to send.


2.
Choose Send from the File menu. This command appears if Word found an active, compatible electronic mail system when you installed it.


3.
If you are using Microsoft Exchange, you may be asked to choose a Profile – the address book and other settings you want Exchange to use during this E-mail session. Choose the default MS Exchange Settings profile or another custom profile you may have created, and choose OK. 


4.
The New Message dialog box appears. If you are using Exchange and have chosen Word as your E-mail editor, this dialog box resembles a Word screen, with a special WordMail toolbar and To:, CC:, and Subject boxes. An icon representing the file you are sending appears in the bottom half of the window. 


5.
To select a recipient, click the To: button. The Personal Address Book address list appears. Double-click on a name to display it in the Message Recipients box. If you want to send the file to another recipient, double-click on another name.


6.
If you want to send cc:s to other recipients, select each name and click the Cc button.


7.
Choose OK. You're returned to the New Message window. If you want to assign your message a subject name, click in the Subject line and type the subject you want.


8.
If you want to include a cover note, click in the white box where the file icon already appears, and start typing. 


9.
If you want to include another file you're not currently working on, click the Insert File icon. The Attach dialog box will open; it resembles the File, Open dialog box. Use the dialog box controls to select the file you want to attach. You can attach as many files as you like. The additional files will also appear as icons in the New Message window.


10.
When you're finished editing your cover note and attaching files, choose Send from the File menu or click the Send button. Word will send the files and return you to the document you were working on.

An interesting note about Word's Send Mail feature that you may not expect: it sends an exact copy of the file in its up-to-the-second form, including any edits you have made but not saved. Don't assume that Word's Send Mail feature also re-saves your copy of the file, though—it doesn't. If you don't save your own file, you'll be in the unlikely situation of e-mailing your colleague a more complete, up-to-date file than the one you've stored on your own hard disk!
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How do I route a file to several reviewers via e-mail from within Word?

As you've seen, you can send a file to several recipients at once via e-mail by choosing more than one address for your To: and cc: lists. But what if you want to route a file, and get the reactions to your recipients in order, one at a time? To route a document:


1.
Open the document to be routed.


2.
Click Address to choose names to receive your message. 


3.
The Microsoft Exchange Personal Address Book opens. Double-click on each of the names you want to include. When you've selected all the names you want, choose OK. 


4.
The Routing Slip dialog box returns. Use the arrow keys to rearrange the names on the list so the document is routed in the order you choose. To select a name, highlight it and choose Remove. 


5.
In the Route to Recipients box, choose whether to route to recipients One After Another, or All at Once. 


6.
Using the checkboxes, whether you want the document to Return When Done, and whether you want to Track Status. If you choose Track Status, you will receive E-mail each time a recipient completes and forwards the file. 


7.
To protect the document for Revisions, Annotations, or Forms (in other words, to specify that a reader can only edit the document with Revision Marks on, or add annotations, or add text in specific form fields), make a selection from the Protect For box. (Protecting for Revisions is the default setting; you can also choose not to protect the document from editing at all. 

8. To add a Routing Slip (a covering note), click Add Slip. Enter the text of your routing slip in the Message Text box. To route the document, choose Route.  

Return to Table of Contents
Return to Table of Contents
Problem

How do I use workgroup templates?

As a member of a workgroup, you probably need to share special templates that are used to standardize documents throughout your workgroup. Although Word and Office include a \TEMPLATES folder, using it does not allow you to share templates with others effectively. The \TEMPLATES folder usually resides on your local drive and is ideal for storing your personally customized templates.

Word allows for another folder setting—Workgroup Templates—for accessing additional templates. This is a folder stored on a file server or one pre-selected computer on a peer-to-peer network where it can be accessed by anyone in your workgroup connected to the same local area network. You can use this as a second location for storing personal templates, but, as its name implies, you should use it to store the shared templates used by your workgroup. By default, Word assigns no workgroup template folder.

Once you establish a shared template folder, all templates stored in that folder will also appear in your list of templates when you choose File, New to create a new file. If templates with the same name exist on both your local computer and the workgroup template folder, the template stored on your own hard drive takes preference over the workgroup template.

Solution

To establish a folder for workgroup templates:


1.
Open Word's Tools menu and select the Options item.


2.
Select the File Locations tab.


3.
Select the Workgroup Templates item in the File Types list box.


4.
Click on the Modify button. The Modify Location dialog box will appear.


5.
Use the controls in the Modify Location dialog box to select the drive and folder where the workgroup templates are stored. These controls work like those in the familiar Open and Save As dialog boxes. If you are not currently signed onto your network, and (as is likely) you plan to establish the workgroup folder on a network drive, choose Network Neighborhood, and follow your normal sign-on procedure. Once you do, your network drives will be available.


6.
If the folder for the templates does not yet exist, you can create it using the New button. Enter the name of the new folder in the Create Folder dialog box and click on OK.


7.
Click on OK in the Modify Location dialog box after selecting the folder, and then click on the Close button in the Options dialog box. The new Workgroup Template location will take effect immediately. If you have just created a workgroup template folder for the first time, other users on the same network can now connect to it by following the steps just listed.
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What working habits do I need to develop if I am using Word on a network?

Working with Word on a network requires some forethought about sharing documents. You need to develop certain working habits to avoid creating problems in the shared working environment.

Solution


1.
If you use document-protection passwords, write them down. Consider filing them in a central, secure location. If you forget the password or are away from work, no one can open the document protected with the password.


2.
Keep in mind that not all types of Word passwords prevent others from making changes in the document. Through Tools, Protect Document, you can set passwords to prevent annotations or form-field edits. These passwords, however, do not prevent other changes in the document.


3.
Workgroups often use shared templates to keep their documents consistent. If this is your situation, do not use personal templates when formatting shared documents. Use the workgroup templates only. Using other templates will introduce inconsistencies.


4.
Avoid reassigning keys or customizing shared templates without the knowledge of your colleagues. Redefining aspects of shared document templates or shared documents can confuse other users.


5.
Use only the fonts that are shared by other users in the group. Otherwise, Word will be forced to substitute what it believes is the closest font; this can introduce many formatting problems into carefully formatted documents, such as newsletters, fliers and proposal documents. If you think a font may not be shared and it is a TrueType font, open the File menu, select the Save As option, click on the Options button in the Save As dialog box, and check the Embed True Type Fonts check box on the Save tab in the Options dialog box. When you save the document, the fonts will be included in the document's file. Any user on the network will be able to view and use the font if it is embedded in the file.

Chapter 14: Using Word with Other Applications

Whenever a new version of software comes out, the new version is never completely compatible with all the existing software you might want to use with it. Several incompatibilities have been found for Word 95. This chapter helps you work around these types of problems:



Should I use Enter or Shift+Enter in my macros?



How can I protect number formatting in merges from Access?



Word 2.x Foreign Language Proofing Tools are Out-of-Date.
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Should I use Enter or Shift+Enter in my macros?

In Word 2.0 dialog boxes that contained text controls required the user to type Shift+Enter to start a new line. (The input dialog box was a good example.) If you are migrating users from Word 2.0 macros to Word 95 macros, should you continue to use Shift+Enter, or should you switch to using Enter only to start the new line? Word 95 provides a simple solution.

Solution

Under most circumstances, Word 95 enables both the Enter and Shift+Enter keystrokes to create a new line in text controls displayed by dialog boxes. You can, however, use the new style (the Enter keystroke alone) in all of your directions. Word 95 automatically deals with your mistakes as you migrate to the updated system.

If you want to use a dialog box in which the Enter keystroke causes the dialog box to close (the behavior for InputBox dialog boxes under Word 2.0), you need to design your own dialog box and customize the way it behaves after the user presses Enter. The sample code shows one method:

Sub MAIN

Begin Dialog UserDialog 320, 144, "Microsoft Word"

 TextBox 10, 66, 292, 18,.TextBox1

 OKButton 10, 6, 88, 21

 CancelButton 10, 30, 88, 21

End Dialog

Dim dlg As UserDialog

n = Dialog(dlg)

Rem If Enter is typed, insert the result of the dialog box

If n = -1 then Insert dlg.textbox1

End Sub
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How can I protect number formatting in merges from Access?

When you merge data from Microsoft Access in a mail merge, some numeric formatting may be lost. Word sees the data as numbers, not as formatted numbers. To fix this, you need to add a Numeric Picture switch in your merge field because Word's mail merge feature might not add this switch for you automatically. Numeric Picture switches tell Word how you want your numbers formatted—for example, how many decimal points you want to appear, or whether you want thousands to include commas (as in 1,000).

Solution


1.
Click on the merge field that will receive the Access data and press Shift+F9 to reveal the field codes.


2.
If the field code appears as { MERGEFIELD Order_Amount }, change it to the following:



{ MERGEFIELD Order_Amount \# $,#.00 }

In this example, the switch you've added specifies that Word includes a dollar sign before each number it imports, and uses two decimal points afterward. In other words, it specifies that numbers appear as dollars and cents. You can find out more about the Numeric Picture switch by searching the Word Help file for "Numeric Picture."
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Word 2.x foreign language proofing tools are out-of-date.

If you purchased special foreign language proofing tools for Word 2.x, you will receive an error message when you run Word Setup. You can keep running Word Setup and Word will install properly, but you can't use the proofing tools.

Solution

You will have to purchase updates for Word 95. These are available from Alki Software, at 1-800-NOW-WORD.

Chapter 15: Troubleshooting Word

Everyone eventually has trouble with software. Even if you're sure you installed it correctly, something doesn't work as expected. It seems Word 95 is no different because of all the trouble users have reported. This chapter shows you how to solve the most frequently reported troubleshooting problems, including:



My printer driver does not work right. What can I do?



How do I prevent an inserted graphic from increasing the file size?



I can't save my document because too many files are open.



Word 95 seems to have corrupted one of my documents. How do I fix it?



My keyboard is not working right. What is the problem?



How do I keep Word from wrapping a space character to the beginning of a line?



Word reports that it cannot open NORMAL.DOT. What do I do?



The Backspace and Delete keys do not work sometimes. Why?
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My printer driver does not work right. What can I do?

Are you are experiencing any of these problems with your printer: 



You cannot use its special features?



You cannot access a built-in font?



Some fonts do not print?

Is there anything that can be done?

Solution

Most printer problems originate with the printer driver, the program that Windows uses to communicate with your printer. You have three options for solving these types of problems:


1.
Contact the manufacturer of your printer to get an updated printer driver. The latest version usually fixes all known bugs.


2.
Install a printer driver for a different printer that has similar features. Often printers use compatible codes to control the same features. Sometimes you can even switch your printer to emulate other types of popular printers. (Check your documentation.) Many printers are Hewlett-Packard II, PostScript, Epson, or IBM ProPrinter-compatible; use drivers for these printers to see if they provide a temporary or, possibly, permanent fix.


3.
In some cases, you can pass printer codes to control the troublesome features directly from your document to your printer. See Can I send printer escape codes from my document? in Chapter 10, "Printing Documents."
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How do I prevent an inserted graphic from increasing the file size dramatically?

When you link graphics into your document, the file size increases. The increase occurs because Word stores a rendering of the graphic in the document. The size of the increase is determined by the number of bytes required to store the picture of the graphic. For many documents an increase in file size may not be a problem. If you want to save real estate on your hard drive for other files, you might want to reduce the file size by storing only the links to the graphics and not the picture.

Solution


1.
To remove the pictures of linked graphics from the document file, open Word's Edit menu and select the Links option. 


2.
The Links dialog box lists all links in the Source File list box. Select the links representing the graphics you want to change.


3.
Clear the Save Picture In Document check box.


4.
Click on OK.


5.
Save the file.

You can also clear the Save Picture in Document check box when you insert a picture using the Picture command on the Insert menu. The check box appears in the Insert Picture dialog box.
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I can't save my document because too many files are open.

Autosave attempts to save or you attempt to save. Word responds with an error dialog box that informs you too many files are open and you cannot save. Word literally refuses to save a file. What can you do?

Solution

If you receive this error, you can temporarily fix the problem by closing all other applications. Each application open represents at least one, and probably more, files open. Try to save again. 
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Word 95 seems to have corrupted one of my documents. How do I fix it?

Occasionally one of your documents becomes corrupt. You can open it, but before you make many edits, Word crashes. How can you rescue the document?

Solution

If you can open the file at all, immediately follow these steps:


1.
Open the File menu.


2.
Select the Save As option.


3.
Set Rich Text Format in the Save as type drop-down list box.


4.
Enter a new name for the file in the File name text box.


5.
Click on OK.

This procedure saves the file in Rich Text Format (RTF). The conversion to this format should correct any corrupted information and rescue as much of the file as possible. Then, open the RTF file in Word, save it as a Word document, and continue working with the file.

In converting a file to rich text format, you may need to open the Tools menu and select the Options item to reset some options before attempting the rescue. If you have trouble opening a corrupted file at all, on the View tab in the Options dialog box, clear the Draft Font check box. On the General tab, clear the Background Repagination check box. Then attempt to open the file and convert it to RTF.

If you simply cannot open the file, make a copy of the file just to back yourself up. Then try this procedure:


1.
Open an MS-DOS prompt from the Windows 95 Desktop. 


2.
Type the following command, then press ENTER:



COPY CON+OLDNAME.DOC NEWNAME.DOC



OLDNAME.DOC is the name of the corrupted file. NEWNAME.DOC is the file name you are copying the corrupted file to. The word CON appears on your screen and the cursor flashes on a blank new line.


3.
Carefully press the spacebar 12 times.


4.
Press the F6 key.


5.
Press the ENTER key.


6.
Restart Windows and open Word.


7.
Open the new file you created.

This seemingly mysterious procedure copies the file and strips the header information out of it. When you open the new file, you may have to remove foreign characters from the beginning of the document. Your text should remain intact in the middle of the document. You will have to reformat the file.
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My keyboard isn't working right. What is the problem?

When you use keyboard commands, such as Home and End, your keyboard does not work as the Word manual says it will. What's wrong?

Solution

Chances are you installed the WordPerfect Help option and allowed Word to install the WordPerfect keyboard. Take these steps:


1.
Open the Tools menu and select the Options item.


2.
Click on the General tab.


3.
Clear the Navigation Keys for WordPerfect Users check box.


4.
Click on OK.

Your keyboard should behave in the way the Word manual describes after clearing this box.
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How do I keep Word from wrapping a space character to the beginning of a line?

I learned in high school that you type two spaces at the end of a sentence. Word is wrapping one of those spaces to the beginning of the next line. How do I prevent Word from wrapping the space?

Solution 1


1.
Change your typing practices. What you learned in high school was correct – for typewriters. It is not correct for the word processing programs today. Unless you are using Courier New or some other mono-spaced font, you should only be typing one space at the end of a sentence. Times New Roman and Arial fonts (for example) automatically space sentences correctly following a period, question mark, etc.

Solution 2


1.
Open the Tools menu and select the Options item.


2.
Click on the Compatibility tab.


3.
Select Word 6-Word 7 in the Recommended Options For drop-down list box.


4.
Investigate the Wrap Trailing Spaces to Next Line setting in the Options list box. (It is the last setting on the list.) If its box is checked, clear the box.


5.
If you experience problems with converted files, be sure to check all of the Word compatibility settings to see if this option is turned on.
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Word reports that it cannot open NORMAL.DOT. What do I do?

When you start Word or are running Word, you see a message that reports NORMAL.DOT cannot be opened. Since NORMAL.DOT is the basic document template, you cannot create a document. How do you work around this problem?

Solution

The only time Word cannot open NORMAL.DOT is when there is not enough memory to do so. Close all other applications and try the command that produced the error again. If you still get the error, the problem is that some program has locked a segment of memory while it was running but not released that memory back to Windows when it exited. Shut down and restart Windows. This action frees all memory and returns it for Windows' use.
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The Backspace and Delete keys do not work sometimes. Why?

You press the Backspace or Delete key and Word issues an error sound. No material is deleted from the document. Why does this occur?

Solution

The Backspace and Delete keys are disabled under two conditions:


1.
There is hidden text in the material to be deleted.


2.
The insertion point is at the beginning of a paragraph and the preceding paragraph is in a different format.

You must be able to view hidden text to delete it. To view hidden text, take these steps:


1.
Open the Tools menu and select the Options item.


2.
Click on the View tab.


3.
Check the Hidden Text check box.


4.
Click on OK.

You should now be able to use these keys to delete hidden text.

Word prevents you from accidentally reformatting a paragraph by deleting a paragraph mark. Paragraph formats are stored in the paragraph marks. When you delete the paragraph mark, the preceding paragraph takes on the format of the following paragraph. As a result, Word prevents you from deleting a paragraph mark that contains different formatting from the following paragraph mark.
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This section was added by Charles Kyle Kenyon. The following are valuable resources. You may want to open the links in your browser and mark them as favorites or bookmarks. They will lead you to many answers and solutions.

Frequently Asked Questions About Microsoft Word (http://www.addbalance.com/word/index.htm)

Web Resources for Microsoft Word (http://www.addbalance.com/word/wordwebresources.htm) This may be the page you were expecting when you looked here. It has hundreds of links which will are far more up-to-date than what I could put in this document.

Downloads for Microsoft Word (http://www.addbalance.com/word/download/index.htm) This guide, Word Questions and Answers, can be downloaded from there and updated versions may appear there from time to time. If they are, they will show a new version number. (This is Version 2001.01.)

Microsoft MVP Word FAQ site (http://www.mvps.org/word) (Truly an awesome resource!)

Intermediate Users’ Guide to Microsoft Word (http://www.addbalance.com/usersguide/index.htm) This was formerly titled Legal Users’ Guide to Microsoft Word – Supplemented. It is a multi-chapter tutorial on how to really make Word work for you.
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Closing Notes from Publisher – How to Contact

This document could really use some updating but I’m not up to it, at least not by myself. If you update any part of it and would like to share (with or without attribution) please send the update to me. Please also let me know of any serious errors (either as stated or as applied to later versions of Word. You can reach me by email at WordQuestions@addbalance.com. 

Please note that although Margaret M. Berson did virtually all of the work in putting this together, she has not given permission for this publication on the web. If you use the guide and you feel that there are problems with it, you should not contact her but rather me, Charles Kenyon, because you would not have had the problems but for my publication of it.

- End of Document (do not delete this line it contains a bookmark required for pagination) -
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